0
Text message error 50

  1. Subfjr
    Froyo Nov 24, 2016

    Subfjr , Nov 24, 2016 :
    Since yesterday I can't send text messages only to one of my contacts because it's always giving that error 50. What can I do to solve it??
     

    #1
  2. Tokolozi
    Marshmallow Nov 24, 2016

    Tokolozi , Nov 24, 2016 :
    Found this in the first google result:
     

    #2
    Ceasedd and Subfjr like this.
  3. Kéno40
    Jelly Bean Nov 24, 2016

    Kéno40 , Nov 24, 2016 :
    I had a problem last week with a MMS which wasn't sent.

    I had to erase it, reboot the phone and then, after a while, it was OK.
     

    #3
    Subfjr likes this.
  4. Subfjr
    Froyo Nov 25, 2016

    Subfjr , Nov 25, 2016 :
    Thanks for your help, but it's not the case, I had dual Sim, test with both and didn't send for that contact, and it's only to that one. The only difference is that with one network the error is 50 and the other is error 21
     

    #4
  5. Kéno40
    Jelly Bean Nov 25, 2016


    #5
    meatandy and Subfjr like this.
  6. mirsadk
    Cupcake Dec 22, 2016

    mirsadk , Dec 22, 2016 :
    i had a similar problem but after installing google text app everything is working fine
     

    #6
    Subfjr likes this.
  7. rudsethi001i
    Cupcake Apr 30, 2017

    rudsethi001i , Apr 30, 2017 :
    Could you please help me even I am also getting the same problem even after installing the google text app.

    Thanks
     

    #7
  8. vinayleo
    Cupcake Aug 12, 2017

    vinayleo , Aug 12, 2017 :

    To fix this issue please follow the steps
    1.Dial *#*#4636#*#*
    2.Go to SMSC and update with the number as shown in the picture.
    3.Click refresh and reboot the device

    Problem is solved.
     

    Attached Files:


    #8
  9. vivekbangal4
    Cupcake Nov 17, 2018


    #9
  10. B_Wrath
    Nougat Nov 17, 2018

    B_Wrath , Nov 17, 2018 :
    You just bumped a two year old thread. Congrats on becoming a forum necromancer.
    Which phone do you use ?
     

    #10
  11. thecipher
    Eclair Nov 17, 2018

    thecipher , Nov 17, 2018 :
    That is probably because you got a new sim. For a new sim it takes around 48 hours to activate the SMS services. I would suggest you to wait for 2 days and then try.
    Hope this will solve your problem.
    @vinaybangal4
     

    #11
  12. Kennon9
    Cupcake Jan 15, 2019

    Kennon9 , Jan 15, 2019 :
    I tried this method but the problem still occurs. Is there anything else I can try?
     

    #12
  13. Kéno40
    Jelly Bean Jan 16, 2019

    Kéno40 , Jan 16, 2019 :
    Just find the menu "APN setting" and re initialze it.
    Reboot. Then, it should work. If not, you'll have to see with your carrier.
     

    #13
  14. Tejas Tharu
    Gingerbread Jan 31, 2019

    Tejas Tharu , Jan 31, 2019 :
    I faced this similar issue, Since I am living in India and we usually recharge with U/L packs giving data and unlimited calls, hence I didn't check my balance. If it is below zero, then the operator will block your SMS service. Kindly check your talk time balance. It should be > 0, then only SMS will work.
     

    #14
  15. shubham shivane
    Cupcake Jul 20, 2019

    shubham shivane , Jul 20, 2019 :
    I had this same problem on my oneplus5 with vodafone sim in it with monthly plan i have no problems in calling then i checked my balance it was - 2rs something as soon as i recharged my talktime balance problem was solved for me and my text massages got delivered
     

    #15