0
Other

"The dm-verity is not started in enforcing mode" |NEED HELP!|

  1. F_Nathan_Vandeweghe_AKWx Donut Dec 16, 2016

    F_Nathan_Vandeweghe_AKWx, Dec 16, 2016 :
    Can anyone tell me how to fix this?
    I've went to the website "goo.gl/aqINs6" but I'm not that smart to understand this :/

    So if someone has faced this or knows a fix!
    Tell me please :c
     
    Last edited: Dec 17, 2016

    #1
  2. phw990 Eclair Dec 16, 2016


    #2
    chrone likes this.
  3. Yoga_nathan Cupcake Dec 17, 2016

    Yoga_nathan, Dec 17, 2016 :
    Is there any other way to disable dm-verity check?? Instead going for stock recovery and stock ROM??

    I wish to install RR or CM14 ROM on my oneplus 3.
     

    #3
  4. Bartnl Lollipop Dec 17, 2016

    Bartnl, Dec 17, 2016 :
    The link ain't working.
    For the OP3T you need too flash a dm-verity file. But as you are on a OP3 I am not sure.... you can give it a go.
    https://forums.oneplus.net/threads/...wrp-root-nandroid-efs-backup-and-more.475142/ Downloadlink in 4th post (flashing TWRP)
     

    #4
  5. F_Nathan_Vandeweghe_AKWx Donut Dec 17, 2016

    F_Nathan_Vandeweghe_AKWx, Dec 17, 2016 :
    Well I found out. Just some bad TWRP. I reflashed the stock recovery. Then I sideloaded my OOS Open Beta 9. After that, flashed TWRP 3.0.2-19
    That worked.
    OP3 is working smooth af now.

    Links for those who are having the same issue or problem.

    ! Note: It will reset your whole content of your phone. Don't forget to backup.

    Links:
    Stock recovery; http://downloads.oneplus.net/oneplus-3/oneplus_3_oxygenos_openbeta_9/ (All the way down)
    TWRP 3.0.2-19; http://forum.xda-developers.com/showpost.php?p=68691560&postcount=56
    Open Beta 9; http://downloads.oneplus.net/oneplus-3/oneplus_3_oxygenos_openbeta_9/ (A bit above the recovery download)
     

    #5
  6. G_João_Paulo_Leite_de_S Cupcake Dec 22, 2016

    G_João_Paulo_Leite_de_S, Dec 22, 2016 :
    flash Stock ROM Open Beta 9 or OxygenOS 3.2.8???
    flash from recovery stock???
     

    #6
  7. Andaar Froyo Dec 23, 2016

    Andaar, Dec 23, 2016 :
    OOS 3.2.8 then you can put official TWRP (I did it a moment ago).
     

    #7
  8. Ahryos Froyo Dec 29, 2016

    Ahryos, Dec 29, 2016 :
    When you had the issue, did you get the screen saying that the bootloader is unlocked (orange), and after the "DM-verity issue" screen popped up (red)? And do you know if the fact that DM-verity has failed would cause something bad to happen?
     

    #8
  9. G_Rahat_Mahbub_lZtN Cupcake Dec 30, 2016

    G_Rahat_Mahbub_lZtN, Dec 30, 2016 :
    You have to use stock rom at first. You will get this warning if you flash the open beta via TWRP. You CANNOT do that. what you have to do to get rid of this is flash the 3.2.8 rom. This will get rid of the dm-verity warning. To ever get open betas on your phone, you have to go through the very long, arduous, time-consuming, and tedious process of sideloading the rom through stock recovery. But to get rid of the warning, flashing the 3.2.8 rom should fix it. It did for me. Then you can load CM14.1 or RR5.8.0. I recommend AICP 12.1. Good luck
     

    #9
  10. Yoga_nathan Cupcake Dec 31, 2016

    Yoga_nathan, Dec 31, 2016 :
    I went back to oxygen stock marshmallow version and installed twrp older version (latest of marshmallow) then changed to custom ROM of Nouget. Now I don't get that verity error.
     

    #10
  11. j0rdyknight Cupcake Jan 3, 2017

    j0rdyknight, Jan 3, 2017 :
    ***FIX FOR DM_VERITY ERROR ONEPLUS 3 WORKING 03/01/2017***

    NOTE: You Will Have to Wipe to Do This- Meaning You WILL LOOSE ALL your Data!

    {ALL LINKS AND IMAGES PROVIDED}

    I AM NOT RESPONSIBLE OR LIABLE FOR ANYTHING THAT HAPPENS TO YOUR PHONE. PROCEED AT YOUR OWN RISK!

    Hello.
    Ive Had One Plus as My Main Go to Phone company now for some time. I have the OP1, The OP2 and now the OnePlus3 In all its glory.

    I have had Twrp-3.0.2-1-oneplus3.img flashed to my ONE PLUS 3 for a while now as i used to use Cyanogenmod13.
    I went back to stock OOS3.2.8 due to issuses.
    Yesterday 02.01.2017 I decided to try a new Rom Called FreedomOS. Went perfectly well untill i Messed it up :/ .
    Im no noob when it comes to rom modding swapping etc, as its pretty much the reason i dumped my iphone, but then again im no Einstein either.
    This Was My Error:
    Capture.JPG

    But I Found This Method FIX Myself - Following Different Parts Of Methods, So i will try to give credit and links where I can. Everything I Used Will Be Linked to My Mega Account For You All to Use Freely.

    DOWNLOADS:​
    You Will Need All Of These​


    Beginning Step:
    If you havent Already Install WinRar Either x32 if your PC is 32bit, or x64 If your PC is 64bit.

    Step1:
    You want to Use this Tool - OnePlus3-ToolKit-v3.7-By-@ahmed_radaideh
    Run OnePlus3-ToolKit-v3.7 -RUN.bat File
    Once Open Press Any Key to continue.

    Step2:
    (OPTIONAL) If you dont have TWRP Installed Do it now. (If you already have TWRP Installed Skip To Step3) Press the numebr 7 Then Press 1. This Will Flash TWRP. Then once Done press any key, this will now boot your OP3 Into TWRP. Your OP3 will reboot to system, bringing up the error again. Wait and Then you will boot into TWRP.

    Step3:
    Now Connect Your OP3 To PC Via USB Type-C Cable. You Want To Open your Phone Storage on your PC and Drag Over The 2 Main Zip Files:
    1.no-verity-opt-encrypt-5.0.zip
    2.cm-13.0-20160820-SNAPSHOT-ZNH5YAO0J6-oneplus3
    3. (OPTIONAL- If you want to stay on CM13) open_gapps-arm64-6.0-mini-20161202.zip

    Step4:
    Now On your OP3 In TWRP Go Into Install
    Select "no-verity-opt-encrypt-5.0.zip" "Swipe" To Flash it. Once done go back to "Install".

    Step5:
    Now Select "cm-13.0-20160820-SNAPSHOT-ZNH5YAO0J6-oneplus3" -This is a snapshot Which means Most Things are Working On That Version Of CyanogenMod.
    "Swipe" to confirm the Flash. "Wipe Dalvik/Cache". Then "Reboot".

    Step6: (OPTIONAL)
    If you want to stay on CM13 Snapshot Then Go back to "Install" and select
    "open_gapps-arm64-6.0-mini-20161202.zip"
    to install and "Swipe" to confirm the flash. Then "Wipe Dalvik/cahe". Now "Reboot".

    Now You Should Successfully Have Fixed The Issue and Be Running CyanogenMod 13 Snapshot For OP3.

    You Should now Be able to go back to TWRP and flash any ROM you Wish.

    This Worked for Me. There Are No Promises It Will Work For You. But I did this on My OP3 so i Would **ASSUME** It would work the same way.

    Thanks Jordan K
    Any Questions Or Help Needed Feel Free To Contact Me.

    Credits:
    OnePlus3-ToolKit-v3.7-By-@ahmed_radaideh- https://forum.xda-developers.com/oneplus-3/development/toolkit-oneplus-3-toolkit-unlock-t3398799

    no-dm_verity-opt-encrypt-5.0
    https://build.nethunter.com/android-tools/no-verity-opt-encrypt/

    CyanogenMod 13 Snapshot OnePlus3:
    https://download.cyanogenmod.org/?device=oneplus3

    GAPPS:
    http://opengapps.org/
     

    #11
  12. krv09 Gingerbread Jan 12, 2017

    krv09, Jan 12, 2017 :
    It's simple use this command in fastboot,
    "Fastboot oem selinux enforcing"

    If you have trouble going to fastboot mode, use developers mode ,you can enable it by clicking bulid number 7 times ,in that advanced reboot option, then press and hold power button and then it shows reboot ,in that fastboot
     

    #12
  13. satisastur Eclair Jan 12, 2017


    #13
  14. bhyde Froyo Jan 13, 2017


    #14
  15. obiwan+ Honeycomb Jan 29, 2017

    obiwan+, Jan 29, 2017 :
    I have this annoying message, too. Does everyone get it? For the last months I used TWRP and CyanogenMod 13. Now I upgraded TWRP to the current version 3.0.3.0 and clean-installed OxygenOS 4.0.2 final. The OS loads and works, but why does this message come up?
     

    #15
  16. bagou01 Gingerbread Apr 19, 2017


    #16
  17. abhineet15misra Cupcake Aug 4, 2017


    #17
  18. MrCharlie Gingerbread Aug 14, 2017

  19. elanglois Lollipop Aug 14, 2017

    elanglois, Aug 14, 2017 :
    Nope. That'd a different warning
     

    #19
  20. elanglois Lollipop Aug 14, 2017

    elanglois, Aug 14, 2017 :
    There is an easy fix that takes 5 minutes or less

    You are going to flash an older firmware in TWRP that will allow commands that have been removed in newer firmware. Reboot to fastboot bootloader. Issue a disable and enable command from your PC using fastboot, then issue a "reboot recovery" command to go back to TWRP. Flash the latest firmware for your device, then boot the phone normally.

    Here are details ... https://forum.xda-developers.com/oneplus-3t/how-to/fix-dm-verity-warning-final-fix-4-0-3-t3555094
     

    #20