1
'Three UK' wideband audio (a.k.a. 'HD calling') on OP3T

  1. chris.walker Honeycomb Feb 12, 2018

    chris.walker, Feb 12, 2018 :
    I've asked this before, but didn't get much of a response, so maybe it's a UK/'Three' related issue (or maybe it's just me?!)...

    Does anybody find that wideband audio (a.k.a. 'HD calling') no longer works since the Oreo/OOS 5.x update on the OP3T? Even calls to other Three users that used to be in 'HD' quality now always just sound like 'old fashioned' standard phone call quality.

    It's been broken since OOS 5.0 and is still broken in 5.0.1. It always used to work fine in Nougat.
     

    #1
    K1531653495493 likes this.
  2. chris.walker Honeycomb Feb 21, 2018

    chris.walker, Feb 21, 2018 :
    For anyone that cares, clearing all apps' cache from settings, and wiping cache from recovery, has no effect. I can only assume this is a bug. Let's see if it's fixed in 8.1.
     

    #2
    K1531653495493 likes this.
  3. ravijain87 Gingerbread Apr 15, 2018

    ravijain87, Apr 15, 2018 :
    I have the OnePlus 5 and was under the impression that that Three didn't allow HD voice on phones that weren't bought from them (except IPhone which works in a different way). My understanding was that this is due to them not being able to make the necessary changes in firmware on unlocked phones? It's interesting that you were able to do this on your OnePlus 3T. How did you confirm this was working?
     

    #3
    K1531653495493 likes this.
  4. chris.walker Honeycomb Apr 15, 2018

    chris.walker, Apr 15, 2018 :
    You're talking about VoLTE - agreed, Three don't support this on devices that weren't bought from them.

    But I'm talking about standard 'HD Voice' quality for phone calls - it's been around for years on UK networks, you must have called someone before and noticed the sound quality is better than a standard 'old fashioned' phone call? It doesn't require 4G, it works on GSM networks too.

    I've just picked up two phones belonging to other members of my family - both on Three, and both Motorola phones that were not bought from Three - and called one from the other. The call was in 'HD Voice' quality! This is what it used to sound like when I called them too, before I upgraded to Oreo.

    https://en.wikipedia.org/wiki/Wideband_audio
     

    #4
    K1531653495493 likes this.
  5. VinayML Gingerbread Apr 15, 2018


    #5
    chris.walker likes this.
  6. chris.walker Honeycomb Apr 15, 2018

    chris.walker, Apr 15, 2018 :
    Thanks. I suspect it's network/carrier related. That's why I've captured logs and they've been sent to the OP dev team. Hopefully they will be able to analyse and figure out what the issue is - even if it something specific to my network in the UK. It definitely used to work for me too!
     

    #6
  7. ravijain87 Gingerbread Apr 15, 2018


    #7
    chris.walker likes this.
  8. chris.walker Honeycomb Sep 4, 2018

    chris.walker, Sep 4, 2018 :
    For anyone who's interested - this was still a problem after the 5.0.5 OOS update. But yesterday, I changed networks from 3 UK to Vodafone UK, and as soon as I put my new Vodafone SIM in my OP3T, HD Voice calls immediately started working again. So it was obviously an issue related to the 3 UK network (even though it used to work on 3 UK), or perhaps my four year old SIM card. A new SIM card and/or moving to a new network has fixed it.
     

    #8
  9. danouk Donut Sep 7, 2018

    danouk, Sep 7, 2018 :
    Hello, thanks for updating this thread. Is your HD calling working on Vodafone to Vodafone calls, or Vodafone to any other network? Also do you know a HD call has been established? Is it just by ear, or can you see a setting / config item in your phone showing HD call capable?


    Currently on O2 pay monthly SIM only. No WiFi calling and no HD calling!

    -- Dan
     

    #9
  10. chris.walker Honeycomb Sep 7, 2018

    chris.walker, Sep 7, 2018 :
    Hi Dan - I haven't tried calling anyone else on Vodafone yet, I've only called other Three users so far. So yes, it works across networks, and both my outgoing calls to them, as well as their incoming calls to me, are in 'HD'.

    There's no indication on the phone that it's a wideband audio call, but you can hear it instantly. It sounds like a Skype call. I was quite surprised that it suddenly started working, just because I'd changed networks. It's weird, because it definitely used to work on Three. I'm sure an Oxygen OS update broke it a long time back. Maybe some incompatibility was introduced with my four year old Three SIM card, and it's more related to me now having a new SIM card rather than having changed networks? Might be worth doing a SIM swap on your O2 SIM, if it's old, just to see if it fixes the issue?
     

    #10
  11. __AK__ Gingerbread Sep 7, 2018

    __AK__, Sep 7, 2018 :
    I've been getting the HD icon show when in call. It shows under the number you're calling. This is on OnePlus 6 on Three. WiFi calling and Volte is also enabled on my phone on Three.

    1536357703361.jpg

    --------

    WiFi calling works on o2. I've a dual sim setup.

    How to enable? Open the my o2 app. Swipe to the right and the menu will come up. Click on 4g and WiFi calling and you have to add it to your account. Its free and doesn't mess with your contract length.
     
    Last edited: Sep 7, 2018

    #11
    chris.walker likes this.
  12. chris.walker Honeycomb Sep 8, 2018

    chris.walker, Sep 8, 2018 :
    Must be because you've got a OP6, or maybe a newer Three SIM. WiFi and 4G calling are enabled on my Vodafone account - I can see when I log into My Vodafone - but there's no VoLTE option in the OP3T settings. It clearly says on the Vodafone website that it only works on phones bought from them anyway. And just to be clear, this is all different from HD calling anyway. That *is* working for me now, so I'm happy about that!
     

    #12
  13. __AK__ Gingerbread Sep 8, 2018

    __AK__, Sep 8, 2018 :
    Try to enable it this way:

    dial *#800#
    tap logikit
    tap function switch
    tick VoLTE and VoWiFi
    restart phone.

    then in setting under SIM you have the option to enable VoLTE and VoWiFi.
     

    #13
  14. chris.walker Honeycomb Sep 8, 2018

    chris.walker, Sep 8, 2018 :
    Thanks. But yeah, tried that before on Three and again when I switched to Vodafone, and it doesn't work. I wasn't expecting it to, to be fair. Must be related to you having an OP6. Given it's meant to be restricted to handsets bought from the networks themselves, I'm surprised it works for you. Unless you bought your OnePlus directly from O2? I'm guessing VoLTE doesn't work on your Three SIM.
     

    #14
  15. __AK__ Gingerbread Sep 8, 2018

    __AK__, Sep 8, 2018 :
    I did buy my phone from o2 and both Volte and WiFi calling work on 3 aswell with this phone.
     

    #15
    ravijain87 and chris.walker like this.
  16. chris.walker Honeycomb Sep 8, 2018

    chris.walker, Sep 8, 2018 :
    That's good. I can understand it working on O2 if you bought the phone from them, but not sure how you've got it working on Three too?! Maybe there's better support for it on the OP6.
     

    #16
  17. ravijain87 Gingerbread Sep 9, 2018

    ravijain87, Sep 9, 2018 :
    Yeah I can't figure this out. I have now moved to the OP6 and I have noticed recently that I am getting HD voice when I'm making calls (I'm still on three). I've not got VoLTE though. I had turned off the status bar icon for this so have reenabled it and will keep with it for a few days to see if it's maybe not available where I live but maybe at work or in other areas to see if something has changed in the last year.

    I had previously called three about VoLTE and they told me this could only be enabled on devices they have sold. Given that they do not sell any OP devices then I had previously given up at that point.

    From what I understand, Three implement VoLTE in a different way to O2 so also not sure if having the O2 version of the OP6 has fixed the issue... but if it has then why?!
     

    #17
    chris.walker likes this.
  18. danouk Donut Sep 17, 2018

    danouk, Sep 17, 2018 :
    Chris does the signal type change when you initiate a phone call now you're on Vodafone. For example when my phone is idle I see 4G and medium signal strength. As soon as I attempt to make a phone call the signal type drops to H (hspa I assume)
     

    #18
  19. chris.walker Honeycomb Sep 17, 2018

    chris.walker, Sep 17, 2018 :
    Yes, it does, but it always did. That's normal on any network, you will always revert back to 3G during a call, then it will go back to 4G after it has ended. The only exception is if you're making a call over VoLTE, whereby I assume it remains on 4G during calls.
     

    #19
    danouk likes this.
  20. __AK__ Gingerbread Sep 26, 2018

    __AK__, Sep 26, 2018 :
    Updated to pie on OP6.

    Since the last update VOLTE no longer works on 3 UK. (could be I'm not in an area supported, but then again I've moved around the city quite a bit the last 2 days and haven't picked it up a single time, no icon)

    However WiFi calling is working fine still on 3 UK, incoming calls also show the contact name now as compared to unknown before.
     

    #20
    prfraczek and chris.walker like this.