1
Timezone instability

  1. _gez_
    Cupcake Oct 5, 2015

    _gez_ , Oct 5, 2015 :
    Happened to my brand new OP2 so I switched this option off. I'm in Australia on AEST.
     

    #21
  2. championwaqas
    Cupcake Oct 6, 2015

    championwaqas , Oct 6, 2015 :
    Can you please try these steps and see if the issue is resolved?
    Hard Reset your OnePlus:
    -Back up all your important files and information, as the process will erase all data.
    To back up your data :
    ( You can sync your Google account to backup Apps data, wifi settings, pictures and contacts. Make sure you have enabled auto sync and backup data from settings. For music, video or other files, you can copy the files to computer by connecting the USB cable.)
    -Shut down your phone, and turn it back on while pressing the Volume Down button until you feel it vibrate.
    -Once in Simple Recovery, select "Wipe cache partition", and swipe to the right or press the power button.
    -When you get the "Cache wipe complete" message, continue and select "wipe data / factory reset" to fully re-initialize your ROM.

    Let me know if the problem persists after these steps!
     

    #22
  3. scottbeatty
    Donut Oct 7, 2015

    scottbeatty , Oct 7, 2015 :
    I've been noticing this off and on since I received my OPT. Also a T-Mobile subscriber. Central Daylight Time in Texas.
     

    #23
  4. noweakness
    Honeycomb Oct 7, 2015

    noweakness , Oct 7, 2015 :
    This happens to my roommate and I who are both on T Mobile and have OP2

    He's a pilot, so automatic time zone is a necessary function for him as he travels between time zones on a daily basis. And I agree, its a not a fix, its removing a feature.
     

    #24
  5. ShaynePierce
    Cupcake Oct 16, 2015

    ShaynePierce , Oct 16, 2015 :
    I am seeing this problem too on my OP2. I found two different places to set/check time zones. First in the clock app which I get to by pulling down the tray and then clicking on the time. Under settings I see "Home time zone" which I had set correctly. Under that setting is "Change Date and Time", clicking there shows the "Automatic time zone" setting. Other options are greyed out until you turn the "Automatic time zone" setting off. I saw that the default was Eastern time zone - I changed it to my time, zone "Mountain Daylight" and then set the "Automatic time zone" back to on. I still see the Mountain Daylight - although it is now greyed out. I don't know if it will fix it permanently, but I hope it does.
     

    #25
  6. championwaqas
    Cupcake Oct 23, 2015

    championwaqas , Oct 23, 2015 :
    Oneplus has decided to replace the phone under warranty. Hopefully the replacement does not have this bug.
     

    #26
  7. MrZS
    Cupcake Oct 27, 2015

    MrZS , Oct 27, 2015 :
    Same issue here OP2 OS 2.1.1 in CST, When I turn on automatic timezone it switches to EST. Currently switched to Manual but should travel abroad soon. Looks like I'll need to manually update in every stop...
     

    #27
  8. gknight
    Eclair Dec 6, 2015

    gknight , Dec 6, 2015 :
    I'm on an AT&T network and I too have the same issue, I cannot afford to switch off the automatic time zone change since I travel quite frequently. Been using this phone since it was out and still issues. I guess I need to contact customer service. Anyone has an idea if this is a HW issue or a SW issue, backing up data and doing a factory reset doesn't sound all good and involves a lot of time just brining it back to speed.. @OnePlus any solutions?
     

    #28
  9. championwaqas
    Cupcake Dec 7, 2015

    championwaqas , Dec 7, 2015 :
    This is HW issue. I had the exact same issue. Here are the steps customer support made me go through:
    1- Asked to factory restore the phone. Did not fix the issue.
    2- Was asked to setup a appointment for OP tech to remotely access my computer and apply some patches. Did all that and issue was still there even after all patches were applied.
    3- OP customer support declared this a HW issue and asked to print DHL label and ship the phone back to United Kingdom.
    4- Took around 2 weeks to get a brand new in the box OP2.
    However, since I already started using another phone in the meanwhile, I did not feel like switching back to OP2 and I sold the replacement as brand new sealed. Did not check to see if the issue was resolved.
     

    #29
  10. visundar
    Cupcake Feb 2, 2017

    visundar , Feb 2, 2017 :
    Is this issue back again with oxygenos 4.0.2? I had my automatic network provided time zone set. I didn't see this earlier before the os update
     

    #30
  11. AlexWelle
    Cupcake Mar 13, 2017

    AlexWelle , Mar 13, 2017 :
    I have the same Problem on my OP3T.

    I'm traveling a lot all around the world, hopping from one timezone to another. I need my home time on the phone all the time. I turned the function to get the time from the network off as well as the automatic time zone.

    But since a while my time jumps to Chinese time frequently - even when I'm at home in Germany. [e]1f628[/e]

    I need to solve this bug urgently because it's a pain in the a..
     

    #31