2

tmobile op6t google pay not working saying my phone has altered software

  1. vinnieardito Donut Jan 7, 2019

    vinnieardito, Jan 7, 2019 :
    hey everyone it's Jan 7 2018 I have a TMobile one plus 6t and I got a software update build number a6013_34_181228 and when I went to go to pay for my lunch with my phone it says this phone can no longer be used to make purchases before the update it worked fine so I deleted my debit card from Google pay and I tried to re add my card and it will not allow me to set up my debit card to use because it says the phone is rooted or has altered software. my phone is def not rooted or altered anyone have this problem? or a fix for it thanks
     

    #1
    kvance60115 and P1546906573729 like this.
  2. aeronbc Donut Jan 7, 2019


    #2
    vinnieardito likes this.
  3. vinnieardito Donut Jan 7, 2019

    vinnieardito, Jan 7, 2019 :
    ok thanks for the response I really appreciate it I was hoping it wasn't just me
     

    #3
  4. Neddard KitKat Jan 7, 2019

    Neddard, Jan 7, 2019 :
    What's your Google Pay version?

    For reference, I disabled it on my 6T from the start since I don't use it, but to test things I re-enabled it. I got to the step after taking a picture of a card or manually adding its info without error. I stopped there, though. My GP version is 1.53.186034020. The current version on the Play Store is 2.80.225228531.
     

    #4
  5. vinnieardito Donut Jan 7, 2019

    vinnieardito, Jan 7, 2019 :
    lemme see thanks
     

    #5
  6. vinnieardito Donut Jan 7, 2019

    vinnieardito, Jan 7, 2019 :
    1546897977365.jpg
     

    #6
  7. aeronbc Donut Jan 7, 2019

    aeronbc, Jan 7, 2019 :
    I have the latest: 2.80.225228531
     

    #7
  8. vinnieardito Donut Jan 7, 2019

  9. Neddard KitKat Jan 7, 2019


    #9
  10. vinnieardito Donut Jan 7, 2019

    vinnieardito, Jan 7, 2019 :
    after I put in my security code on back of card and it tries to add the new card plus it says this phone can't be used if I try to pay with another card that's already on g pay
     

    #10
  11. aeronbc Donut Jan 7, 2019

    aeronbc, Jan 7, 2019 :
    Google Pay worked fine before update so my cards are already present in the app. I went to pay for my lunch today and received an error that I couldn't use Google Pay. If I try to add a new card I suspect that I will get an error.
     

    #11
  12. vinnieardito Donut Jan 7, 2019

    vinnieardito, Jan 7, 2019 :
    it's def the update then
     

    #12
  13. Neddard KitKat Jan 7, 2019

    Neddard, Jan 7, 2019 :
    I never took the process that far, so I can't offer much more. But maybe it's a short circuit between the newest GP and the TMo update from today/yesterday.

    Have you tried clearing GP's cache and data, along with a force-stop maybe? You'd probably need to re-add all cards afterwards.

    Sorry I can't offer more.
     

    #13
  14. aeronbc Donut Jan 7, 2019


    #14
  15. kvance60115 Donut Jan 7, 2019

    kvance60115, Jan 7, 2019 :

    Exactly the same with me!! Wish I would have read this before wiping the phone to factory though.
     

    #15
  16. rando191 Donut Jan 8, 2019


    #16
    vinnieardito likes this.
  17. Msr360 Eclair Jan 8, 2019

    Msr360, Jan 8, 2019 :
    this is a huge problem, a roaming update bricked it. I wonder what else is broken
     

    #17
  18. kvance60115 Donut Jan 8, 2019

    kvance60115, Jan 8, 2019 :

    Here is a bug report. More people that vote the more likely it gets fixed: https://forums.oneplus.com/threads/google-pay-not-working-after-update-to-9-0-2-t-mobile.980144/
     

    #18
    vinnieardito likes this.
  19. Msr360 Eclair Jan 8, 2019

    Msr360, Jan 8, 2019 :
    this isn't something that can Ben left unfixed. it will affect other applications
     

    #19
  20. tfarley01 Froyo Jan 8, 2019