303
[Tool] JOxygenOS Installer - Flawlessly clean install OxygenOS & COS12

  1. captsakis
    Gingerbread Apr 5, 2015


    #41
  2. carl2210
    Honeycomb Apr 5, 2015

    carl2210 , Apr 5, 2015 :
    Can you use this tool to flash from oxygenOS to CM12, or any other roms?
     

    #42
  3. Jamesst20
    Jelly Bean Apr 5, 2015

    Jamesst20 , Apr 5, 2015 :
    Well actually it is able to install other zip than the OxygenOS zip. So yes.
     

    #43
    I73770k and joantheboss3 like this.
  4. oscarvanl
    Jelly Bean Apr 5, 2015

    oscarvanl , Apr 5, 2015 :
    I'd recommend you wait a few days for CM12S instead - If you don't know how to backup these things then it could be a headache. CM12S won't require a wipe and will be updated through the phone.
     

    #44
    keithnyc likes this.
  5. Jamesst20
    Jelly Bean Apr 5, 2015

    Jamesst20 , Apr 5, 2015 :
    Nope you don't have too :) but it wouldn't have done anything bad if you did as long as you didn't remove the zip. By removing the zip you will prevent the Bootloader to be relock, nothing too bad

    Both of you, the issue is that the software is waiting your device to be reconized in Recovery Mode. You may want to check your drivers

     

    #45
  6. sidtodai
    Cupcake Apr 5, 2015

    sidtodai , Apr 5, 2015 :
    Okay So here it is,
    I heard the news that OxygenOS is out and quickly downloaded the Zip file.
    And Googled around how to unlock Bootloader and Install Custom Recovery.
    Step 1 : I followed the steps and successfully Unlocked the Bootloader
    Step 2 : Dowloaded TWRP image file and Renamed it " openrecovery-twrp-v2.37" and gave the cmd "fastboot flash recovery [file:name].img"
    Step 3 : Reboot the system and copied supersu in the internal storage
    step 4 : When i tried to get into recovery mode i was been directed to cynogen recovery, I tried to look up for solutions online but couldn't find any. Then it clicked that I had to uncheck CM recovery in developers options. After which I went to recovery mode of TWRP and successfully install supersu.

    Then I had a problem of Connecting my device to the computer via usb. It would just make a sound of Connecting that to in usb-debugging mode.
    I tried to give commands[fastboot commands; unlocking ] from start but was unable to connect. Then I googled it and found that Storage>three dots>USB connect to pc and WOLA!! Was succeeded.

    Step 5: Transferred the OxygenOS and went in recovery mode tried to install but failed. [Had taken back up before ]

    Then when I checked 'fastbood oem device-info"

    device tampered-true
    device unlocked-false
    charge screen enabled- false.

    Tried to unlock it, but then the system reboots and TWRP recovery mode is launched

    I am confused.My phone is normal thank god it didn't turn into a Brick. But I am not able to install OxygenOS


    What Should I do? Please HELP

    If I take it to the OPO center will I be charged for flashing and would I void the Warranty ?
     

    #46
  7. carl2210
    Honeycomb Apr 5, 2015

    carl2210 , Apr 5, 2015 :
    WOW then you my friend should have been on the Oxygen OS team. I agree it should have come with a simple tool to do this. Not a lot people like me know how to flash roms and don't want to risk it.
     

    #47
  8. Jamesst20
    Jelly Bean Apr 5, 2015

    Jamesst20 , Apr 5, 2015 :
    Hehe thanks :) if you have some spare time I would be really thankful to know if it worked for you. The tool has been downloaded over 100+ times and only got 2 feedback which was the same (drivers not installed)
     

    #48
  9. trueblue2
    Froyo Apr 5, 2015

    trueblue2 , Apr 5, 2015 :
    Thanks, James, for this tool. I might take it for a spin, tonight or tomorrow. I first thought that sticking with CM would be the prudent thing to do, at least while OPO took their time to polish OxygenOS. But reading your comments, I get the impression that OxOS is mature enough? Would you agree? And if not happy, is there a way back to CM for someone that has successfully used your tool? Thanks for your thoughts.
     

    #49
  10. gabemiller832
    Eclair Apr 5, 2015

    gabemiller832 , Apr 5, 2015 :
    Eventually I installed OxygenOS but I don't really like it, I decided to go for cm-12-20150405-NIGHTLY-bacon,

    BUT

    I cannot start the phone in recovery mode! Volume down/volume up + power doesn't work anymore. The combination just starts the phone and that's all.
    Does this mean that OxygenOS cannot be replaced, ever?

    Any idea?


    View attachment 284693

    This is with USB debugging enabled on OPO and after installing PdaNetA4170.exe

     

    #50
  11. Jamesst20
    Jelly Bean Apr 5, 2015

    Jamesst20 , Apr 5, 2015 :

    Sadly can't see your Screenshot. Look, PM your TeamViewer ID & Password so I can assist you just like OnePlus One support would do and we will fix your phone together
     

    #51
  12. gabemiller832
    Eclair Apr 5, 2015


    #52
  13. Jamesst20
    Jelly Bean Apr 5, 2015


    #53
  14. Jamesst20
    Jelly Bean Apr 6, 2015

    Jamesst20 , Apr 6, 2015 :
    Extremely disappointed to have hundred of downloads and only 2 feedback... what a nice community
     

    #54
    Klaeje and Ceasedd like this.
  15. TekBoi
    Gingerbread Apr 6, 2015

    TekBoi , Apr 6, 2015 :
    You are a garbage person for uploading it on a garbage website. Upload it on Google Drive like a real person.
     

    #55
  16. Ceasedd
    Marshmallow Apr 6, 2015


    #56
    keithnyc likes this.
  17. traxtopel
    Gingerbread Apr 6, 2015


    #57
  18. kishorparmar
    Eclair Apr 6, 2015


    #58
  19. Oneplus Fangirl
    Ice Cream Sandwich Apr 6, 2015

    Oneplus Fangirl , Apr 6, 2015 :
    No feedback yet?

    Has anyone used it? Or people are too afraid to brick their phone?
     

    #59
  20. DinkoDes
    Ice Cream Sandwich Apr 6, 2015

    DinkoDes , Apr 6, 2015 :
    I am not thinking to try Oxygen for now but this is what I did not expect that company will not do by them self . Really unprofessional.

    @Helen this should be revarded.
    Thanks for installer and I hope it will support move from CM12 to Oxygen when time come.
     
    Last edited: Apr 6, 2015

    #60
    MartijnBudding likes this.