Touch sensitivity issues: A letter to OnePlus...

  1. carburano
    Jelly Bean Jul 31, 2014

    carburano , Jul 31, 2014 :
    Dear OnePlus,

    my name is Francesco aka Carburano, i'm an Android enthusiast and since 2007 i'm enjoying smartphone world (I created rom for HTC Diamond and LG O2X).

    When I first heard about your project I immediately thought: "that's cool, finally an open alternative to the nexus... surely i will buy it!"

    I have been patient for months, I have defended you here on the forum and in italian blogs, I received the invitation and I finally bought it ... I didn't care about yellow display, you hardly notice it ...
    But your management of complaints was not at the level of your marketing campaign, your deny of the problem, your bans ...
    Dear OnePlus you know on the forums it's easier to raise the voice.. You have to understand ...

    In the meantime my 5 days old OPO started to have strange behaviours ...

    1- bad grounding issue : when laying on isolating surface, touch is awful. On my bed or on the car stand only one or 2 touch are recognized (today in my car it was impossible to use pinch to zoom in gmaps). It is unacceptable.

    See this video i made: in the first part of the video i have OPO in my hand (6 touch) second part on the bed (difficult to reach 2 touch).


    see my new video against my Nexus 4:

    2- ghost touch and very high latency when typing (VOTE THIS ISSUE ON Jira https://jira.cyanogenmod.org/browse/BACON-55): typing performance with opo are very deluding. Sometimes touchscreen goes crazy and it's almost impossible to write something. there are many videos regarding this issue and this is mine (Please watch it at max resolution and fullscreen, you will notice that when tapping fast a diagonal line will appear (it is a swipe)... it happens very frequently and writing an SMS or an Email is very frustrating.):

    Here another video made by me... OPO vs Nexus 4

    Here are other videos about the two problems from other forum users:

    https://www.youtube.com/watch?v=4iiwD_Tnp-Q (OPO Vs Nexus 5 - grounding issue)







    On the forum i noticed that many of us have problems with the touch...
    And everybody wrote here, asking for help but you ... After 2 days ... you ignore us ... Tickets, private messages, quotes in the thread ... We don't deserve your attention .. .

    AH BEFORE YOU ASK I already disabled double tap to wake, double tap to sleep and gestures, i tried factory reset, flash factory image but nothing helped! I removed also screen protector and case... but nothing!

    Maybe you do not esteem us as we have estimated you. Maybe you prefer to be pay attention only to new customers, giving them another chance to give you 299 euro ...

    Meanwhile my love is almost ended ... I need your attention always not only in the pre-sales phase.

    You know, I've worked as head of customer care in a computer company. You know that the maximum response time to a ticket for me was 8 working hours? You know .. If you organize the work you can handle it ...

    You say you have too many requests. Ask yourself why ... Maybe your product is poor? Maybe you did something wrong, only thinking on marketing?

    So I have many questions but no answers.

    OnePlus are you just an illusion or can we expect an answer?

    I'll give you 24 hours to give me an answer but it should be professional and credible. Please answer to your beloved customer.

    Let me know.

    Truly yours.


    PS: I will Never Settle until I receive an answer from you!

    PPS: my ticket number is 36151

    PPS: I don't want a refund or another phone. I want a fully working OnePlus One!

    @Carl @David S. @Emmanuel @Ruta @Sparkolo @nguser @Pete @Mike @CM_Abhisek @cyanogen

    EDIT 31/07 h. 13.55. Jira ticket has been closed with unresolved status. Maybe this means that this is an hardware issue... now we urgently need a sign from OP

    EDIT 2:
    another suggestion from our friend @MickeyMouse

    Try installing this app: https://play.google.com/store/apps/details?id=org.dsandler.apps.markers

    it is a simple drawing app which recognize pressure on supported phones... obviously OPO doesn't support pressure on touch screen while Moto G (tested by @@MickeyMouse) is fully working...

    I used the app also to test the latency and ghost touch... here attached a screenshot:

    a you can see on the left there is a swipe with two fingers from top to bottom... suddenly the lines goes a little bit crazy. on the right i double tap from top to bottom... often two taps are recognized as swipe.

    EDIT 3: I attached also the marker file from my nexus 4 (as you can see it's perfect)

    EDIT 4: 23:05 31/07/2014. Abhisek of Cyanogen team gave me an answer in Jira... He said that they are still investigating on the issue... So it's not solved and they still don't know what is causing it.

    EDIT 5: added 2 more videos. I did a OPO vs Nexus 4 for both issues

    EDIT 6: 01/08/2014 h. 23.30:

    Finally someone answer me... he was Andy (@Andy ?!?!?)

    He wrote me a sincere email and he thanked me for the detailed post :) He said that typing issue (the worst in my opinion) it's software related and they are working hard to solve it.

    On the other hand he confirmed that Grounding issue is hardware related (we knew this, but as i stated many time this happens also on other devices... BTW thank you @BadCluster your work around let me pinch to zoom on Gmaps while i'm on the bed :))

    And now second, awesome news...

    As stated by Andy Typing issue is software related... infact... after 5 minutes i received his email, a wonderful genius (Xavier) posted this comment on Jira Issue:

    Good news BACON-55 sufferers (I hope). I was tinkering with the /sys sub-fs exposed by the synaptics-rmi-ts driver, and I did this:

    root@A0001:/sys/class/input/input0 # cat baseline_test
    TRx To TRx Short Test Failed[2]!
    2107: syna_ts_data->vendor_id=2,data_buf[4]=255
    2 error(s).

    And bam! suddenly the ghost swipes are gone! Reproduced consistently after a couple clean reboots. I'm on the last CM11S to date.

    Could someone else try it?

    So it seems that he found how to mitigate the problem with imprecise typing (and tap as swipe issue).

    So let's try... Do this (credit to Harska K from its Jira comment):

    From Phone:
    1. Install: https://play.google.com/store/apps/details?id=jackpal.androidterm&hl=en
    2. Open, type "su". Ensure it says root@A0001 or something like that.
    3. Paste this command in: cat /sys/class/input/input0/baseline_test
    4. Press enter.
    5. Should be done, no need to reboot.

    From Computer:
    1. Plug phone in, enable debugging.
    2. sudo adb shell (if linux, don't know about Windows)
    3. cd /sys/class/input/input0
    4. cat baseline_test

    It's worth noting that I did not have any "errors" when I ran this. Xavier did.

    It works!!!! But it's still no perfect... So...

    It's not a definitive solution but it's a very good start and I'm sure now CM Team will solve it!

    So Thanks Andy and Xavier! You made my day!!!

    UPDATE 05-08-2014

    the amazing developer Xavier discovered that ghost swipe issue is touchscreen firmware related and it should be fixed by Synaptics.

    In the meantime he merges his patch in a kernel available HERE: http://forum.xda-developers.com/oneplus-one/general/kernel-ghost-swipes-tentative-fix-t2839378

    UPDATE 12-08-2014

    Hi guys... finally... i settled.

    My ticket (and RMA request) was closed whitout any explanation when i was away (the only email I received was from Andy... but it was only a simple response email without any useful support.

    Other than that my RMA request was not considered at all.

    So... i decided to give my OPO to my father (he needs a big phone to read and call and see videos - STOP. OPO is perfect for this but it is not good for my use).

    I'm angry and i feel cheated by customer support.

    It's not possible that an hardware problem like grounding one is not handled by this company.

    I'm sorry but I think also that ghost swipe problem will be not solved soon (at least not officially).

    I just buyed a second hand 16 gb - 2gb LG G3 from a friend of mine

    I know it's not good, fast and open source as opo but money aren't growing on trees and I hate to use mine for this not working device...

    ah... and touchscreen is working great (10 touches in my car while it's on car stand)...

    Goodbye Oneplus. You simply were an illusion.

    Attached Files:

    Last edited: Aug 13, 2014

  2. CokeandGummies
    Froyo Jul 31, 2014

    CokeandGummies , Jul 31, 2014 :
    Oh man sorry to hear about your issues. Hope that they can get the issue resolved for you. Although you have every right to be angry you might want to change your approach to getting answers. I'm sure a calmer post would most likely end up with you getting a better response. But that my 2 cents hope you can get your issue resolved!

  3. carburano
    Jelly Bean Jul 31, 2014

    carburano , Jul 31, 2014 :
    I wrote this letter after many quotes in posts, private messages, comments on Jira and 2 support tickets :)

    I simply need a fully working OnePlus One (note, i don't want another phone... I want OPO)

  4. dualcorebrain
    Ice Cream Sandwich Jul 31, 2014

    edgehab, SilverLegend, Axara and 4 others like this.
  5. CokeandGummies
    Froyo Jul 31, 2014

    CokeandGummies , Jul 31, 2014 :
    As I said I completely understand where your coming from. Especially since you've gone through other methods of communication. But in life I've just learned keeping a calm demeanor no matter how annoying or stressful the situation may be is the best way to go. But I really do hope you get your issue resolved because it does seem to be an issue that many members are running into! GL...and be patient my friend I'm sure that the company is under alot of strain just trying to keep up with demand. So don't be disappointed with the lack of communication just keep pushing through buddy! I'm sure you'll get an answer or fix soon!

    ronoldo and nunopinho1982 like this.
  6. n19htmare
    Jelly Bean Jul 31, 2014

    dark0ne and edgehab like this.
  7. carburano
    Jelly Bean Jul 31, 2014

    carburano , Jul 31, 2014 :
    a fully working old technology :)

    DaniBarts, Axara, ThreeX and 9 others like this.
  8. carburano
    Jelly Bean Jul 31, 2014

    carburano , Jul 31, 2014 :
    Yeah... but since it's a problem for many users i simply wanted to make this problem visible to the community! :)

    edgehab, TrishaLaff, navarde and 2 others like this.
  9. CopierColler
    Froyo Jul 31, 2014

  10. luckyfmj
    Ice Cream Sandwich Jul 31, 2014

    edgehab, kjvikram06, calvin35 and 8 others like this.
  11. gotrunx
    Honeycomb Jul 31, 2014

    gotrunx , Jul 31, 2014 :
    I agree with you completely. It's understandable that many defect products come to the customers (even though they say they have a rigorous quality control) since they are a new company with a new product. But, if they want for their project to have any future, they need to start providing better support. Especially when this many users have defects on their devices... and many users have problems to use their invites.

    You have my full support and I guess there are much more people here who will alse stand by your side.

  12. Jooel+one
    Gingerbread Jul 31, 2014

  13. moontaze
    Gingerbread Jul 31, 2014

    moontaze , Jul 31, 2014 :
    I have another phone of the "ZTE" brand and it has the same problem and uses cynogen. So maybe its a software issue that can be fixed with an update

    ludo960, hamatro and EmmaWATTson like this.
  14. carburano
    Jelly Bean Jul 31, 2014

    carburano , Jul 31, 2014 :
    since nobody will answer we cannot say if it will be solved via OTA or it's an HW problem :(

    BTW grounding problem is HW for sure.

  15. Kenz78
    KitKat Jul 31, 2014

    Kenz78 , Jul 31, 2014 :
    I hope they will replace u with a new unit. I tried on the bed and flat surface and did not get those problem. I guess its a harware problem. Sure hope OP will look into this, and replace all problem unit if they want the good words flow around

    carburano likes this.
  16. roderickh
    Ice Cream Sandwich Jul 31, 2014

    carburano likes this.
  17. Milad
    Lollipop Jul 31, 2014

  18. carburano
    Jelly Bean Jul 31, 2014

  19. maxiv
    Eclair Jul 31, 2014

    maxiv , Jul 31, 2014 :
    Swiping to the left in SwiftKey to delete the last word is almost impossible. It keeps on just typing the letter where my swipe ended.

    Example: If i swipe from L to D the last word should be simply deleted....instead the keyboards simply types "D". It's not an issue with SwiftKey, since this has been working perfectly on the Nexus 5 and Samsung Galaxy Nexus...

    I too need an answer soon, otherwise it's bye bye OPO...

  20. carburano
    Jelly Bean Jul 31, 2014

    carburano , Jul 31, 2014 :
    I agree. I compared Nexus 4 touch sensitivity to Opo and the last one seems a 1999 touchscreen

    pac757 likes this.