1
Trouble Ticket Submitted: No 4G on T-Mobile for ME!

  1. LibraSun
    Jelly Bean Jul 11, 2014

    LibraSun , Jul 11, 2014 :
    I know I'm NOT the only one this has happened to...
    And I even filed a bug report with OP and on CM's JIRA system about this...

    My OPO was refusing to grab "4G" no matter what I try (and T-Mobile is out of suggestions)! And it never — even momentarily — registered "4G" service since it arrived. So I set off on a 3-week long question to find a solution. This is my story....

    Update 1:
    PROBLEM NEARLY SOLVED: See post #273 of this thread!

    Update 2:
    PROBLEM SOLVED! See post #290 (and earlier) of this thread!

    ALREADY TRIED


    ♦ Turning it off and on again. :D
    ♦ Replace T-Mo 4G-capable SIM (twice)
    ♦ Tested my SIM in a branded T-Mobile 4G LTE device (works)
    ♦ Check "Preferred Network Type" = 4G (Recommended)
    ♦ Check APN = set to T-Mobile US LTE (tried both others, too!)
    ♦ Verified user Profile has no checkbox next to "2G/3G" setting
    ♦ Verified OPO is operating within known-good 4G environment
    ♦ Verified others in same room can easily obtain 4G service
    ♦ Noted that "E", "3G" and "H+" are only status symbols showing
    ♦ Created new user Profile with no options checked (i.e. Normal)
    ♦ Disabled user Profiles (no improvement)
    ♦ FACTORY DATA RESET (problem continues)
    ♦ Added and toggled "LTE" panel to Quick Settings (no effect)
    ♦ Added "Network Type" panel to Quick Settings (shows "2G 3G")
    ♦ Installed and ran Sensorly app to gauge local 4G signal (poor)
    ♦ Changed Google Voice settings so regular phone number (not GV-issued number) appears in Settings > About Phone > Status > Phone Number field
    ♦ Inserted known-good 4G-capable SIM from working T-Mobile handset (Note: Gives 4G!!) - tried 4x
    ♦ Inserted new T-Mobile SIM that was 1st activated in a different 4G LTE device (Note: Does not give 4G!!) - tried 3x
    ♦ Created new T-Mobile APN from scratch, using official settings (same issue)
    ♦ Reset all APNs to stock/original and activated "T-Mobile LTE v4" (same issue)
    ♦ Checked IMEI at T-Mobile's IMEI Status Check page ("Unrecognized device")
    ♦ Compared notes with other affected OPO owners (no pattern emerged yet)
    ♦ Increased postpaid T-Mobile plan to higher data limits (3GB; no improvement)
    ♦ Emailed T-Mobile's task force to request careful attention to my account (pending!)
    ♦ Engaged T-Force team to track down any remaining possible causes
    ♦ Change carrier or temporarily subscribe to another MVNO network (GSM-based)
    NOTE: A freshly-activated $30 T-Mo Starter Kit from Wal-Mart works in 4G!!

    NOT YET TRIED

    ♦ Reflash original/stock CM11S ROM or Color OS
    ♦ Inspect phone internals or antennas for possible defects or poor contact
    ♦ Replace OPO unit

    ♦ Compare OPO build dates among 6 known affected units

    IMPORTANT NOTES

    ♦ User's previous smartphone was a 3G device (considered irrelevant)
    ♦ User's previous Profiles were ported into OPO automatically via CM account
    ♦ Old Profiles did have "2G/3G" option checked, but have been unchecked
    ♦ No special Performance or Developer options have been utilized
    ♦ User has not rooted this phone nor flashed anything to it, at any time
    ♦ T-Mobile staff want so badly to blame the phone, but that is illogical
    ♦ Activating a new SIM inside a 4G LTE device may be a prerequisite for some!
    ♦ Do not ask T-Mobile to change your IMEI number (doesn't work that way)

    T-MOBILE NOW HAS A SOLUTION INVOLVING THE INDIVIDUAL ACCOUNT!

    HAS ANYONE ELSE HAD THE SAME TROUBLE RECEIVING 4G DATA CONNECTION ON T-MOBILE in the U.S. (who lives in a major metropolitan area)?

    P.S. I will continually update this post with further findings, solutions, notes, etc.
     
    Last edited: Jul 25, 2014

    #1
    vavahvoom likes this.
  2. LibraSun
    Jelly Bean Jul 11, 2014


    #2
  3. thh
    Honeycomb Jul 11, 2014


    #3
    LibraSun likes this.
  4. petermikhail
    Froyo Jul 11, 2014


    #4
    SakreD and LibraSun like this.
  5. LibraSun
    Jelly Bean Jul 11, 2014

    LibraSun , Jul 11, 2014 :
    Yep, definitely! Almost felt guilty making them give me another one for free, but had to rule that out as a possibility. We think alike!
     

    #5
  6. LibraSun
    Jelly Bean Jul 11, 2014

    LibraSun , Jul 11, 2014 :
    Yes. I tried all three APN's in succession. Believe it or not, even T-Mobile Customer Care reps were unclear which one would work with the OPO. When I told them "It's a 4G phone" they said definitely pick the regular APN (epc...). When later in the conversation I brought up that "It's an LTE device" they said, "Oh, then use the T-Mo LTE APN" like I was an idiot.

    Turns out I am an idiot ... because (to T-Mobile, anyway) 4G does not imply LTE. I'm learning!
     

    #6
  7. thh
    Honeycomb Jul 11, 2014


    #7
    LibraSun likes this.
  8. LibraSun
    Jelly Bean Jul 11, 2014

    LibraSun , Jul 11, 2014 :
    Trying that now...

    Result:

    Set Preferred Network Type = TD-SCDMA, GSM/WCDMA and LTE

    Note: I have already been checking Settings > About Phone > Status and seeing "UMTS" in the "Network Type" field, almost exclusively. When it's not "UMTS", it's typically "HSPA+".
     

    #8
  9. booraddley
    Gingerbread Jul 11, 2014

    booraddley , Jul 11, 2014 :
    Maybe call T-Mobile? See if they need to add your device to some database so they can provision it for LTE?

    I dunno, I'm not a Tmo customer ... yet. My OPO has a defect.
     

    #9
    LibraSun likes this.
  10. thh
    Honeycomb Jul 11, 2014

    thh , Jul 11, 2014 :
    Is this a international version ?
     

    #10
    LibraSun likes this.
  11. Tuamammatroia
    Froyo Jul 11, 2014

    Tuamammatroia , Jul 11, 2014 :
    Can u ask to OP how to check if you HW is international model or by mistake Chinese with proper back cover.. That can be an answer while in US china LTE band aren't supported....
     

    #11
    iomollie and LibraSun like this.
  12. viethoc
    Gingerbread Jul 11, 2014

    viethoc , Jul 11, 2014 :
    I checked my OPO info and have the same on Set Preferred Network Type as yours. However on the Settings I have Network Type = LTE.
    BTW, I have T-Mobile and 4G connection. Good luck to solve your problem.
     

    #12
    LibraSun likes this.
  13. LibraSun
    Jelly Bean Jul 11, 2014

    LibraSun , Jul 11, 2014 :
    Thanks.

    I even just did a complete FACTORY WIPE RESET and no change. Still "no 4G". Ugh.
     

    #13
  14. LibraSun
    Jelly Bean Jul 11, 2014

    LibraSun , Jul 11, 2014 :
    Will address this (unlikely) possibility with OP if/when they respond to my Trouble Ticket.
     

    #14
  15. LibraSun
    Jelly Bean Jul 11, 2014

    LibraSun , Jul 11, 2014 :
    Yes, it's the One they send to U.S. customers (also known as "International" or "Global" version).
     

    #15
  16. LibraSun
    Jelly Bean Jul 11, 2014

    LibraSun , Jul 11, 2014 :


    While that advice works great for AT&T customers, there's no such provisioning system at T-Mo. Their system automatically acknowledges all phones without any hassle.
     

    #16
  17. LibraSun
    Jelly Bean Jul 11, 2014

    LibraSun , Jul 11, 2014 :
    Yep, tried all three T-Mo APN settings. No dice.
     

    #17
  18. mmcnama4
    Cupcake Jul 11, 2014

    mmcnama4 , Jul 11, 2014 :
    Yea... AT&T customer here. No dice for me, they can't figure out how to get me LTE either.
     

    #18
    LibraSun likes this.
  19. PTL
    Gingerbread Jul 11, 2014

    PTL , Jul 11, 2014 :
    trying activating a new sim on a reg tmo branded phone, that way tmo database will enable lte service, once thats complete swap that sim to the 1+1 and you should be good to go

    you need to whitelist the sim card for LTE first them once activated just move it over
     

    #19
    LibraSun likes this.
  20. LibraSun
    Jelly Bean Jul 12, 2014

    LibraSun , Jul 12, 2014 :


    I like your theory, but no one at T-Mobile agrees with this at all (I've asked multiple people).
    Also, other OPO owners just moved their SIM over to the OPO and bam, working fine! (But did they lack 3G like I did before?? hmmm)

    Will try it anyway... just need to find a micro-SIM phone on the T-Mobile LTE network. ;-)
     

    #20