1
Truecaller in not identifying the callers in real time.

  1. AnantOPO
    Froyo Mar 24, 2018

    AnantOPO , Mar 24, 2018 :
    hello friends,
    I have done everything in phone settings on Truecaller settings, but true caller is not identifying the caller names in a real-time (no Truecaller notification pop up) . I could not find the Threads related to the Truecaller, hence creating a new thread for this issue.
    please reply me if you have any hundred percent working solution for this issue.
    Thanks in advance.
     
    Last edited: Mar 24, 2018

    #1
    Multi8ball likes this.
  2. msivam
    Froyo Mar 24, 2018


    #2
  3. bharadwaj_k
    Gingerbread Mar 24, 2018

    bharadwaj_k , Mar 24, 2018 :
    I think Truecaller app is optimised. Goto Battery optimisation check Truecaller as don't optimise.
     

    #3
    itskiran2000 likes this.
  4. sandeep104701
    Gingerbread Mar 24, 2018

    sandeep104701 , Mar 24, 2018 :
    yes same trick fixed my issue with true caller also.
     

    #4
  5. bharadwaj_k
    Gingerbread Mar 24, 2018

    bharadwaj_k , Mar 24, 2018 :
    Sounds great. Android 8.0 comes up woth the effective optimisation to save battery and performance things.
     

    #5
  6. G_ketan_shah_grQM
    Froyo Mar 24, 2018

    G_ketan_shah_grQM , Mar 24, 2018 :
    For OS 8.0, Oreo:

    Enable "draw over apps" by navigating to your phone settings, tap on the search icon and type draw to find the setting.

    Important settings you need to enable:-

    Enable "draw over apps". Go to your phone settings, tap on the search icon and type draw and toggle it on. Note, it may be named "Apps that can appear on top" in newer devices.

    Make sure ’Show notifications’ is enabled in your Phone Settings -> Application manager > Truecaller.
     

    #6
    dsmonteiro likes this.
  7. Multi8ball
    Eclair Mar 24, 2018

    Multi8ball , Mar 24, 2018 :
    OnePlus identifies which app you open the most and keep them open in RAM, and the one you use less usually gests cleared from RAM to save battery. To fix this issue go to battery optimisation and select don't optimise.
     

    #7
  8. kirti+1984
    Cupcake Mar 24, 2018

    kirti+1984 , Mar 24, 2018 :
    where is this battery optimisation?
     

    #8
  9. Raghu2706
    Honeycomb Mar 24, 2018

    Raghu2706 , Mar 24, 2018 :
    Please disable"Advanced Optimization" Battery -- Battery Optimization --- Top rigth corner 3 dots . here u find the mentioned option. It should work.
     

    #9
    kirti+1984 likes this.
  10. bharadwaj_k
    Gingerbread Mar 24, 2018

    bharadwaj_k , Mar 24, 2018 :
    Settings->Battery-> Battery Optimisation

    There you can check
     

    #10
    kirti+1984 likes this.
  11. Raghu2706
    Honeycomb Mar 24, 2018

    Raghu2706 , Mar 24, 2018 :
    Please disable"Advanced Optimization" Battery -- Battery Optimization --- Top rigth corner 3 dots . here u find the mentioned option. It should work
     

    #11
    kirti+1984 likes this.
  12. kirti+1984
    Cupcake Mar 24, 2018

    kirti+1984 , Mar 24, 2018 :
    done dude. let's see if it works. service centre is 40km far from my house
     

    #12
    bharadwaj_k likes this.
  13. AnantOPO
    Froyo Mar 24, 2018

    AnantOPO , Mar 24, 2018 :
    what do you mean, friend?
     

    #13
  14. Raghu2706
    Honeycomb Mar 24, 2018

    Raghu2706 , Mar 24, 2018 :
    It will work for sure. Before I faced the same issue and later disabled advanced Optimization.
     

    #14
    kirti+1984 likes this.
  15. kirti+1984
    Cupcake Mar 24, 2018

    kirti+1984 , Mar 24, 2018 :
    G8 buddy. will ask help if it did not. it's so annoying to pickup all calls. spam calls are like 1 in every 15 mins. these has to be inbuilt pH software to correct it.
     

    #15
  16. kirti+1984
    Cupcake Mar 24, 2018

    kirti+1984 , Mar 24, 2018 :
    I mean. I don't want to travel 40km and spend 300 after spending 35k
     

    #16
  17. itskiran2000
    Honeycomb Mar 24, 2018

    itskiran2000 , Mar 24, 2018 :
    True. This fixes it
     

    #17