1
Truecaller not working on oneplus 6

  1. pradeep_pr
    Donut Jun 24, 2018

    pradeep_pr , Jun 24, 2018 :
    Truecaller doesn't pop up while I get an incoming calls. I can only open app and search for details of the number. am I the only one or everyone are facing the problem??
     

    #1
    Dhruv.803 likes this.
  2. cobusr
    Cupcake Jun 25, 2018

    cobusr , Jun 25, 2018 :
    Use the app simpler dialer thats works great. (here in the netherlands)
     

    #2
  3. porwaltusik
    Cupcake Jun 26, 2018


    #3
  4. J1527058450637
    Eclair Jun 26, 2018

    J1527058450637 , Jun 26, 2018 :
    Goto Truecaller app info: battery > battery optimization > select Truecaller and select Don't optimize. problem solved
     

    #4
    Sonu Prashant and Z1543748121846 like this.
  5. pooorna
    Froyo Jul 1, 2018

    pooorna , Jul 1, 2018 :
    I think ur network provider doesn't support working data connection while in call...
     

    #5
  6. badulla.p
    Gingerbread Jul 31, 2018


    #6
  7. MayankSingh3493
    Eclair Jul 31, 2018

    MayankSingh3493 , Jul 31, 2018 :
    same problem faced by me
    just go to setting..battery.. battery optimisation..true caller and select dont optimise
    it will work perfectly ..
     

    #7
  8. sanghanijd
    Gingerbread Aug 1, 2018

    sanghanijd , Aug 1, 2018 :
    Even if it doesn't it would have data connection active upto the point where call is answered (for incoming calls) or call is dialed (for outgoing calls). So, it should work for incoming calls. The issue here is battery optimization as rightly pointed out
     

    #8
  9. RIMJHIMKAUL
    Cupcake Aug 11, 2018

    RIMJHIMKAUL , Aug 11, 2018 :
    Goto Settings->Apps->Special Access->Draw over other Apps->Truecaller->Permit drawing over other apps

    If this doesn't help:
    Goto Sttings->Apps->Special Access->Notification Access->Truecaller->Turn it On

    It should work now :)
     

    #9
    tvteja likes this.