6
Trying to buy but website buttons doesn't work!

  1. Vpie649
    Cupcake Nov 21, 2014


    #81
  2. redrunnerbeans
    Honeycomb Nov 21, 2014

    Last edited: Nov 21, 2014

    #82
    lispercat likes this.
  3. yvesluts
    Cupcake Nov 21, 2014


    #83
  4. mackmother
    Cupcake Nov 21, 2014

    mackmother , Nov 21, 2014 :
    I have the same issue what gives? Tried to send a ticket, not working...I am going bananas....help!!


     

    #84
  5. 12Fully
    Cupcake Nov 21, 2014

    12Fully , Nov 21, 2014 :
    did you use IE or Chrome?
     

    #85
  6. MartinezBR
    Eclair Nov 21, 2014

    MartinezBR , Nov 21, 2014 :
    Ok guys. I've already done so I won't be able to go back to those pages and take screen shots. So this might not be 100% clear.

    On the page with the red button not working press F12 (do it on I.E. just in case... and I hope your I.E. is updated to the same degree as mine, because things could be different).
    When you rpess f12 a tab will open on the bottom of the page. If your's is the same as mine, than on the left of that tab there is a black ribbon with several icons.

    The first one is "F12" than <arrow> than a box wth > inside and next is a little spider. That is the DEBUGGER button. You could also press CTRL+3 on this version.

    When you open it, right below the "debugger" text there is a little folder icon with a arrow pointing down. That is the "open new fle" icon. Click it or, in this version, just hit CTRL O.

    type the following in the window

    56130e2070f23ccb496fd4fd6ef1469c_1416581504.js

    This file will either have 11k+ lines or only 1k+ lines. If its not 11 or something near that, press CTRL SHITF P so that it will reorganize the text.
    Go on the search box on the right and type

    this.options.onFormValidate

    it should highlight that text on line 4409. Now you put your mouse over the line bellow that (it reads "return result") and press f9.
    A little red ball should appear and on the right there should have appeared something ends with (4410, 9) on the breakpoint part.

    Now you enter your information and click on "save". You will see that the screen will pause (a pause signal will apear). Now go to the right, above the place that apeared the (4410, 9) in a place thats called WATCHES. Double click the "false" thats written in front of "result" and change it to "true".

    Click anywhere in the screen and press F5. it should save and you are done.

    Try going to the cart again and repeat as necessary.
     

    #86
  7. btrsbols
    Froyo Nov 21, 2014

  8. redrunnerbeans
    Honeycomb Nov 21, 2014

    redrunnerbeans , Nov 21, 2014 :
    Cheers for posting. That is an epic workaround!! (But not very tablet friendly)

    Will boot the old laptop up in the morning.
     

    #88
    Audrey.Is.Fantastic likes this.
  9. 12Fully
    Cupcake Nov 21, 2014

  10. chrisprice3
    Cupcake Nov 21, 2014


    #90
    lispercat likes this.
  11. georgenan
    Cupcake Nov 21, 2014


    #91
  12. georgenan
    Cupcake Nov 21, 2014

    georgenan , Nov 21, 2014 :
    try again as they were doing some manitance a few hrs ago
     

    #92
  13. Tim van Limpt
    Cupcake Nov 21, 2014

    Tim van Limpt , Nov 21, 2014 :
    This works perfectly (By Darkscore)
    Made it more readable.


    You have to right click on the save button then debug (inspect element, lowest button) then the source code appears at the bottom

    Then you search until this point:

    <div class="my-account"><div class="page-title">

    (use Ctrl-F and look for my-account to find it)


    then you right click it and click edit as html
    then ctrl+ a
    then ctrl+ c

    Open notepad (text editor)
    Press Ctrl + V to paste the text inside.

    Save it as test.html --> and open it with Google Chrome (or another browser).

    Click test.html.

    Now a text based site opens (without layout), fill in your name and last name here and press save.
    This should bring you to the next page.

    But make sure you are logged in on another tab already!

    Done this in Crome

    All props to Darkscore
     

    #93
    brentxd likes this.
  14. lispercat
    Cupcake Nov 21, 2014

    lispercat , Nov 21, 2014 :

    The reason the red buttons are dead is because before submission, javaScript validate function fails and the form submission bails out.

    We need to trick it to return true.
    To trick it, open the form in say Internet Explorer, press F12 to enter developer tools.
    Right below the F12 Debugger you'll see the "Open Document" menu.
    Open https://content.oneplus.net/…/56130e2070f23ccb496fd4fd6ef14…
    It will be obfuscated so press "Turn on pretty print" (Ctrl-Shift-p)
    Find this.options.onFormValidate line (line 4409 in my case).
    Put a break-point on the next line "return result;" (put cursor on it and press F9)
    Enter the information in the form and press "Save address" (or other save buttons)
    You will hit the break-point. Now in the Watches window (to the right of your javaScript text) change the value of "result" from false to true.
    Press F5. Now your form should be saved.
    After you've filled out all the necessary forms you can continue with the purchase.

    ps. I tried to make it readable for non IT folks, so just try to follow it step by step :)
     

    #94
  15. Pedro4455
    Cupcake Nov 21, 2014


    #95
    lispercat likes this.
  16. naz1396
    Donut Nov 21, 2014


    #96
    Otana and lispercat like this.
  17. naz1396
    Donut Nov 21, 2014


    #97
  18. joah16
    Cupcake Nov 21, 2014

    joah16 , Nov 21, 2014 :
    Thanks guys for your help, having the same problem...
    Tomorrow trying the new method :)
     

    #98
  19. NarutoFreak
    Cupcake Nov 21, 2014


    #99
  20. lispercat
    Cupcake Nov 21, 2014

    lispercat , Nov 21, 2014 :
    Yep, that should do it as well. The trick is to turn off JavaScript right before clicking the Save button