0

Turn off airplane mode to make a call

  1. Rahul.chavan Eclair Dec 5, 2018

    Rahul.chavan, Dec 5, 2018 :
    Hello

    I am getting "Turn off airplane mode to make a call" error and no network on my One Plus 6 handset.
    I turned on airplane mode and restarted the phone.
    After restart, it remains in airplane mode even though I turn off the airplane mode, no network and if i try to make call shows "Turn off airplane mode to make a call".

    All other features and functions are working fine

    I visited service center and they told me your phone is water damaged...so the motherboard is gone and I have to replace mother board to fix this issue. Which will cost me 24000 as per service center.

    It's really bad experience. I never dropped my phone in water.
    What I remember is, some water from glass spilled on my phone 3 weeks back but I wiped the water and cleaned phone and it was working perfectly fine then.

    Is One Plus 6 really a splash proof phone?
    I was a great admirer of One Plus mobiles. This experience has shaken that view.
    Please do not put your hard earned money in such crap phone which is not even splash proof.

    Rahul
     

    Attached Files:


    #1
  2. ngydat KitKat Dec 5, 2018

    ngydat, Dec 5, 2018 :
    Could you post a screenshot of your quick settings when you have this error message ?
     

    #2
  3. Rahul.chavan Eclair Dec 6, 2018

    Rahul.chavan, Dec 6, 2018 :
    Attaching another pic.... I already verified everything... even Service center not getting issue.. also in previous screenshots you can see, no airplane mode sign.

    upload_2018-12-6_11-39-20.png


    I have video clip too.. but not able to attache here so attaching pic from it
     

    #3
  4. withaniket Cupcake Jul 13, 2019

    withaniket, Jul 13, 2019 :
    Hi Rahul, I am facing the exact same problem. Can you please advice how did you fix this issue??
     

    #4
  5. Priyanshu Sharma Jelly Bean Jul 13, 2019


    #5
  6. withaniket Cupcake Jul 13, 2019

    withaniket, Jul 13, 2019 :
    yes, tried that as well. Can someone please help me solve this
     

    #6
  7. Rahul.chavan Eclair Jul 14, 2019

    Rahul.chavan, Jul 14, 2019 :
    is all others functionality is intact?
    my phone automatically started working fine recently(hardly 2/3 weeks back). I did nothing, if you have same problem just visit OnePlus service center and let them open and clean up the device, I did that when the problem started.
    after that waited so long and it started working. I guess phone was not water damaged, it started working after the update we received.
    just wait and use phone for other things like games, photography.. hope your phone will start working soon.
     

    #7
  8. Priyanshu Sharma Jelly Bean Jul 14, 2019

    Priyanshu Sharma, Jul 14, 2019 :
    Which Oxygen OS version are you using? Is it happening after the update?
     

    #8
  9. Rahul.chavan Eclair Jul 14, 2019

    Rahul.chavan, Jul 14, 2019 :
    oxygen os 9.0.7 currently, I found phone is working after1 week of Jun update.
     

    #9
  10. Priyanshu Sharma Jelly Bean Jul 14, 2019

    Priyanshu Sharma, Jul 14, 2019 :
    Is it working now or still same issue?
     

    #10
  11. Rahul.chavan Eclair Jul 14, 2019

    Rahul.chavan, Jul 14, 2019 :
    phone is working now perfectly.
     

    #11
  12. Priyanshu Sharma Jelly Bean Jul 14, 2019

    Priyanshu Sharma, Jul 14, 2019 :
    Glad to hear that it's working fine now.. But it's weird that it automatically started working..
     

    #12
  13. Rahul.chavan Eclair Jul 14, 2019

    Rahul.chavan, Jul 14, 2019 :
    yes for me too :)
     

    #13
  14. Priyanshu Sharma Jelly Bean Jul 14, 2019

    Priyanshu Sharma, Jul 14, 2019 :
    I think this a bug with this update because no one had this issue before the update including you...

    You can submit your bug in feedback section of Community app or just to use this link to submit bugs-

    https://forums.oneplus.com/feedback/

    One last question, Is this started happening just after updating the phone or after few days?
     
    Last edited: Jul 14, 2019

    #14
  15. Rahul.chavan Eclair Jul 14, 2019

    Rahul.chavan, Jul 14, 2019 :
    I don't remember, but I posted here just within week, when this problem occurred.
     

    #15
  16. Rahul.chavan Eclair Jul 14, 2019

    Rahul.chavan, Jul 14, 2019 :
    yes I used feedback too recently.
     

    #16
  17. Priyanshu Sharma Jelly Bean Jul 14, 2019

    Priyanshu Sharma, Jul 14, 2019 :
    Okay no problem... Just wanted to know if anyone will have the same problem then i can suggest them...

    That's great...
     

    #17
  18. henners151 Cupcake Jul 30, 2019

    henners151, Jul 30, 2019 :
    I'm having this issue after my phone suffered saltwater damage. :sob:

    After cleaning and soaking the boards in isopropyl alcohol for the weekend I regained all functionality
    apart from the issue discussed in this thread.

    I have tried clearing the cache and resetting "Wi-Fi, mobile & Bluetooth" and a full reset but the problem is persisting.

    Does anyone have any advice?
     

    #18
  19. Kytharsis Marshmallow Jul 30, 2019

    Kytharsis, Jul 30, 2019 :
    Get your device repaired...
     

    #19
  20. Horsault Marshmallow Moderator Jul 30, 2019

    Horsault, Jul 30, 2019 :
    And also, backup all your data while it's still possible!
     

    #20
    Kytharsis likes this.