263
[Tutorial] How to use the OPO on T-Mobile USA

  1. Simian
    Honeycomb Jul 24, 2014

    Simian , Jul 24, 2014 :
    Hmm. Interesting. Thanks for the response!
     

  2. dn8
    Gingerbread Jul 24, 2014

    dn8 , Jul 24, 2014 :
    did you root your phone?
     

  3. crushingyen
    Gingerbread Jul 24, 2014

    crushingyen , Jul 24, 2014 :
    I actually just ordered my phone today lol; it's still pending shipment.
     

    dbavey likes this.
  4. PushkarRavi
    Froyo Jul 24, 2014

    PushkarRavi , Jul 24, 2014 :
    I was getting 4G on my OPO but on my Note 2 I used to get LTE as well. I followed every setting step by step you suggested but still its 4G. Is there anything else I need to do get LTE connectivity on my phone?
    The reason why I am worried is that, as soon as I use my phone for calling, the network drops to 3G while on my Note 2, it used to drop from LTE to 4G only.
     

  5. crushingyen
    Gingerbread Jul 24, 2014

    crushingyen , Jul 24, 2014 :
    The signal icons on both the OPO and Note 2 are actually pretty different due to the way the ROM was built.

    I'm assuming that your Note 2 was un-modified and was using whatever software T-Mobile had provided you. As I've stated previously with regards to what the signals mean on the phone vs what you're getting from your carrier:

    • 4G on the OnePlus One = LTE on T-Mobile = LTE on your Note 2
    • H+ on the OnePlus One = 4G @ 42 Mbps max speed on T-Mobile = 4G on your Note 2
    • H on the OnePlus One = 4G @ 21 Mbps max speed on T-Mobile = 4G on your Note 2 (since no signal icon exists to differentiate this frequency)
    Thus, if you see 4G on your OnePlus One, you are truly getting LTE connectivity; it's just the phone represents the signal differently. If you want to be certain of what you are getting, go to Settings --> About Phone --> Status. From there, your phone will show you what you are getting in terms of the possibilities:

    • 4G on the OnePlus One = LTE in the Settings app
    • H+ on the OnePlus One = HSPA+ in the Settings app
    • H on the OnePlus One = HSPA in the Settings app
    • 3G on the OnePlus One = 3G in the Settings app
    • E on the OnePlus One = EDGE in the Settings app
    • G on the OnePlus One = GPRS in the Settings app
    As for the network drop to 3G during calls on the OnePlus One, this is actually the true representation on all AOSP-based ROMs. If you've ever used a CM ROM on a previous phone, or Google's stock ROMs (Nexus or GPE devices), signals will always drop to the 3G signal during calls. Your Note 2 shows 4G because that's what your carrier wants you to think you're at. It's all plain trickery and there's no transparency whatsoever.

    TL;DR: You're fine. You're getting what you're supposed to be getting and I don't see anything wrong from what you've described.
     

    zomgwtfbbqxd and WJenness like this.
  6. PushkarRavi
    Froyo Jul 24, 2014

    PushkarRavi , Jul 24, 2014 :
    T
    Thanks a ton buddy. I had read later about signal representation; however I was amazed reading last part that carrier does the trick to fool me in believing its still 4G and not 3G.

    I am hoping T-Mobile to launch VoLTE in my city soon. It has good benefits.
     

  7. f30
    Gingerbread Jul 24, 2014


  8. dosonzzz2
    Jelly Bean Jul 24, 2014

    dosonzzz2 , Jul 24, 2014 :
    thanks for helpful information, I just changed the APN on my OPO, was not able to get LTE, only H+.
    Do I need to wait a little longer for it to pick up the LTE? I am in San Francisco where LTE should be everywhere.
     

  9. crushingyen
    Gingerbread Jul 24, 2014

    crushingyen , Jul 24, 2014 :
    Were you able to get LTE on your prior phone? If so, putting the OPO in airplane mode for around 10 seconds and taking off that should do the trick to grab the signals again.

    I've seen instances on other phones i.e. the HTC One M8 Google Play Edition where it would be stuck at H because it thinks it provides the stronger signal.
     

  10. dosonzzz2
    Jelly Bean Jul 24, 2014

    dosonzzz2 , Jul 24, 2014 :
    I was using Nexus 4 and no LTE, but I have tried many spot in SF and no luck, I also phoned TMo CS this morning and register my OPO IMEI number. I just rebooted it, no luck, also did the airplane mode, still only pick up H+ and H.
     

  11. dosonzzz2
    Jelly Bean Jul 24, 2014

    dosonzzz2 , Jul 24, 2014 :
    It should show 4G if it picks up LTE right?
     

  12. crushingyen
    Gingerbread Jul 24, 2014

    crushingyen , Jul 24, 2014 :
    Yeah, if your phone is picking up LTE, your signal icon on the OPO should show 4G.
     

  13. dosonzzz2
    Jelly Bean Jul 24, 2014

    dosonzzz2 , Jul 24, 2014 :
    I phoned TMo to register my IMEI since I am not able to pick up the LTE this morning, so far still not able to pick up the LTE yet after 2 hours
     

  14. nash859
    Jelly Bean Jul 24, 2014


  15. dosonzzz2
    Jelly Bean Jul 24, 2014

    dosonzzz2 , Jul 24, 2014 :
    when I type #06# to get my IMEI, its giving me "Connection problem or invalid MMI code", any idea how to fix it?
     

  16. crushingyen
    Gingerbread Jul 24, 2014

    crushingyen , Jul 24, 2014 :
    Settings --> About Phone --> Status

    The IMEI should be under there.
     

  17. dosonzzz2
    Jelly Bean Jul 25, 2014

    dosonzzz2 , Jul 25, 2014 :
    Finally got it worked by remove and put back the sim, thanks for the tutorial
     

  18. johnwayne
    Eclair Jul 25, 2014

    johnwayne , Jul 25, 2014 :
    Thank you. This didn't work for me; however, I'm guessing it's because I'm not on LTE--just 4g. Would you happen to know how to adapt this for just straight 4g?
     

  19. crushingyen
    Gingerbread Jul 25, 2014

    crushingyen , Jul 25, 2014 :
    Does your phone only show 4G as the signal icon, or H+?
     

  20. jpdagdag
    Gingerbread Jul 26, 2014

    jpdagdag , Jul 26, 2014 :
    This might be a little off the topic but have you guys experienced mms message not being downloaded in group chats using hangouts? I've read that this only happens with T-Mobile. It happened to me this morning using my OPO. I read somewhere that changing the apn would do the trick but I can't confirm. Thanks.