0
TWRP in OPT fail to decrypt phone

  1. FUSION_MASTER
    Froyo Sep 21, 2015

    FUSION_MASTER , Sep 21, 2015 :
    This is a problem I encountered when trying to flash the Oxygen 2.1 through TWRP (well, the 2.0.2 full zip + the smaller 2.1 OTA).
    The phone is encrypted.
    Restarting into TWRP recovery (from here: OnePlus 2 TWRP Recovery) you're prompted to enter the decryption password (similar to when I'd boot the phone). Regardless of the user input, The following error message is recieved: E: unable to mount storage
    You'll be able to acces the phone if you decide to boot normally.
    This is eerily similar to a problem encountered with OPO and TWRP 2.8.6.0 which has since been resolved so I'm hoping it won't take long for someone to sort this out (assuming it is a similar issue).
    If this is also similar to the aforementioned OPO problem, I think one should still be able to flash OTAs either through ADB sideload or USB OTG (but I haven't tried either yet).
    Anyone has similar problems?
     
    Last edited: Sep 21, 2015

    #1
  2. FUSION_MASTER
    Froyo Sep 21, 2015

    FUSION_MASTER , Sep 21, 2015 :
    p.s. for the record the provided TWRP v 2.8.7.0 is by a "ydss.cn". looking at the official TWRP website, OPT is not yet supported so I'm guessing this is a recompile for the OPT?
    Dees-Troy @Dees_Troy kindly crushed the previous bug with bacon and I wonder if this is the same Qualcomm hardware encryption problem just roaring its head again in OPT.
     
    Last edited: Sep 21, 2015

    #2
  3. FUSION_MASTER
    Froyo Sep 21, 2015

  4. agodo
    Ice Cream Sandwich Sep 21, 2015

    agodo , Sep 21, 2015 :
    this happend to me when i decided to encrypt my phone in the android settings. Some say the password is related with the pattern code you have or de pin number , but really this didnt work for me i had to do a factory reset via adb. real shit....
     

    #4
  5. FUSION_MASTER
    Froyo Sep 22, 2015

    FUSION_MASTER , Sep 22, 2015 :
    Update: offical TWRP 2.8.7.0 installed (https://twrp.me/devices/oneplustwo.html)
    Now I no longer get prompted to enter my encryption password and I poroceed straight to TWRP GUI. The log does show however that
    E: Unable to mount storage
    E: Unable to mount /data/media during GUI startup
    E: Unable to mount /data/media/TWRP/.twrps when trying to read settings file.

    ...and yes /sdcard is not mounted.

    The good folks at XDA are looking at this (hopefully!). If anyone encounter issues decrypting their phone whilst in recovery head to: http://forum.xda-developers.com/
     

    #5
  6. Nutzomo
    Froyo Oct 12, 2015

    Nutzomo , Oct 12, 2015 :
    In this case the greater problem is the fact, that you not able to make a factory reset. The phone is bricked.

    In the XDA-Forum is published a workaround for bricked phones. This works perfect.
     

    #6
  7. FUSION_MASTER
    Froyo Oct 12, 2015

    FUSION_MASTER , Oct 12, 2015 :
    Actually all I did is reformat the internal /data as i couldn't decrypt it. Phone was reset and I just reinstalled my Titanium backup. But as far as I can tell, TWRP still is unable to decrypt internal storage.
     

    #7
    Nutzomo likes this.
  8. catull
    Cupcake Nov 9, 2015

    catull , Nov 9, 2015 :
    I have a similar problem.

    I have an OPT, un-rooted phone, no attempt was made to change that.
    And I did not activate the phone encryption.

    I can't log onto the phone, meaning after I enter the SIM PIN code, I see an dialogue stating that the encryption is interrupted and that the only way to use the phone is to reset it.

    Clicking on the 'reset phone' does nothing.
    A recovery wipe cache/data does not change anything.

    What else can I do ?
     

    #8
  9. FUSION_MASTER
    Froyo Nov 10, 2015

    FUSION_MASTER , Nov 10, 2015 :
    What recovery are you using. In my case from TWRP I was able to reformat data and cache (NOT just wipe them). Lost everything in the phone but I had a backup. This may be your only option although I'd wait out a bit maybe someone has better solution (particuarly as you did not attempt to encrypt the phone).
     

    #9
  10. catull
    Cupcake Nov 10, 2015

    catull , Nov 10, 2015 :
    I have the stock recovery. Tried the formatting, too. It returns rather quickly, after 3 seconds or so.
    The "encryption unsuccessful" is still there.
     

    #10