0
TWRP Issue with LineAgeOs 16.0

  1. N1581759644872
    Cupcake Feb 15, 2020 at 10:07 AM

    N1581759644872 , Feb 15, 2020 at 10:07 AM :
    Hallo!

    One week ago I installed LineageOs. Everything worked great. No I tried to update to the most recent build and TWRP was not able to complete. I used LineageOs Updater. After each try to reboot to system, the device booted again into recovery. I guess the problem was the encrypted data partition. I think the message was "unable to mount storage". I reinstalled everything and lost all data (- not really bad, but a lot of configuration to do again -). Not it is working again (with unencrypted data partition), but I need some help for the next time...

    My setup looks like this:

    Device: Oneplus 3T
    TWRP for Oneplus 3 (twrp-3.3.1-1-oneplus3.img)
    Lineageos 16.0, nightly build (february, 14)
    OpenGApps nano (open_gapps-arm64-9.0-nano-20200215.zip)
    Magisk 20.3

    Has this version of TWRP a general problem with encrypted data partitions? Is there another one without this problem?
    If I encrypt the data partition, is there an option in LineAgeOs to decrypt it again (permanently) before I start the next update?
    Should I prefer ADB to update LineAgeOs to bypass this problem?
    I there another way to update avoiding this problem, maybe the TWRP-App ?

    I know "Starting Points" is not the best place for this topic, but I just registered here and can't post somewhere else for 14 days.
     

    #1