Guide Ubuntu & OnePlus One: unlock the bootloader, install TWRP and SuperSU.

  1. nschong Honeycomb Jul 23, 2014

    nschong, Jul 23, 2014 :
    No OTA without stock recovery? Is it verified?

  2. gatenosix KitKat Jul 23, 2014

  3. cyablo Gingerbread Jul 23, 2014

    cyablo, Jul 23, 2014 :
    Same Problem to me, TWRP will not stay permanently.

  4. nguser KitKat Jul 23, 2014

    nguser, Jul 23, 2014 :
    Can you tell me the steps you follow to install TWRP? Lots of people that follow the guide as it is are not having problems at all. Thanks

  5. grav3h3art Jelly Bean Jul 24, 2014

    grav3h3art, Jul 24, 2014 :

    Cool mate! Thanks for the info!

  6. cyablo Gingerbread Jul 24, 2014

    cyablo, Jul 24, 2014 :
    Got it, there is a Option "CM-Recovery update" (dont know the Original english Title cause im on German Language) in Developer Options which has to be unchecked. As longs as its checked, it overwrites the Recovery on every Boot.

    Made me nearly got Nuts... :)
    Last edited: Jul 24, 2014

  7. dbahn25 Honeycomb Jul 24, 2014

    dbahn25, Jul 24, 2014 :
    it's called CM update, not CW update :)
    nope, only when an OTA update is installed. Yesterday i installed TWRP and it is still there after a reboot this morning (just checked) :)

    nguser likes this.
  8. cyablo Gingerbread Jul 24, 2014

    cyablo, Jul 24, 2014 :
    1. Typo 2. Mine behaved different. For testing I rechecked the Option, rebooted and the Stock Recovery was back again.

    Edit: This als also described in thew XDA Unlock HowTo: Disable CM Recovery Protection - On your phone go to Settings > Developer options. Then disable the 'Update recovery with system updates' option.

    So the Option i mentioned seems to be called: 'Update recovery with system updates' in Eng.
    Last edited: Jul 24, 2014

    dbahn25 likes this.
  9. hadbabits Donut Aug 5, 2014

    hadbabits, Aug 5, 2014 :
    Glad I found this, I pick up my One Plus today :) I'll let you know if it works on Linux Mint 17; though since it's based on Ubuntu 14.04 I can't imagine why it wouldn't ;)

  10. hadbabits Donut Aug 5, 2014

    hadbabits, Aug 5, 2014 :
    Yup, went just as expected :D Thanks for the guide!

  11. nguser KitKat Aug 6, 2014

    nguser, Aug 6, 2014 :
    Thanks for your precious feedback, glad you enjoyed the walkthrough :)

  12. nigelhealy Jelly Bean Aug 12, 2014

    nigelhealy, Aug 12, 2014 :
    (Edit don't know why but possibly it was just very slow in installing in fastboot? I now got TWRP Recovery installed - I guess just leave it a good couple of minutes?)

    Doesn't work for some reason. I did a temporary TWRP to root the phone last week and now its simply not responding to either the temporary nor the flash install.

    This is what I did

    adb reboot-bootloader
    That works I see a CM logo and "Fastboot mode"


    sudo fastboot boot openrecovery-twrp-
    It did work last week but not now odd.

    What I get is the command seems to work

    sudo fastboot boot openrecovery-twrp-
    downloading 'boot.img'...
    OKAY [  0.390s]
    OKAY [  0.021s]
    finished. total time: 0.411s
    The OPO screen lights up to show some life then it does nothing.

    I've tried installing too same non-working type reaction.

    Last edited: Aug 12, 2014

  13. clyde Cupcake Aug 14, 2014

    clyde, Aug 14, 2014 :
    thank you. it works. i have the same linux set up as you though. :)

  14. dbahn25 Honeycomb Aug 14, 2014

    dbahn25, Aug 14, 2014 :
    Same when I did that. I just waited some minutes and it booted all right

  15. nschong Honeycomb Aug 14, 2014

    nschong, Aug 14, 2014 :
    It took forever to boot... Not exactly how long that good-couple-of-minute wait actually is.
    Strange that previously it boot just fine until 30O update removed SU from my OPO.

    Anyway, I tried PhilZ Touch and it booted right away
    Last edited: Aug 19, 2014

  16. hadbabits Donut Aug 14, 2014

    hadbabits, Aug 14, 2014 :
    So I randomly lost root. Not sure what the cause is. There was a OTA update a day or so ago, but I didn't install TWRP or install a custom ROM, so I thought that shouldn't affect me. The only other cause I can think of is that my phone froze last night and I had to shut it down by holding down the power button (which I didn't realize you could do with phones).

    The problem is I don't know when exactly I lost root. I only noticed today because I couldn't connect my PS3 controller to my phone. I guess I'll install a custom ROM and disable OTA updates.

  17. cliffwong Cupcake Aug 19, 2014

  18. QuaqSim Gingerbread Aug 19, 2014

    QuaqSim, Aug 19, 2014 :
    Was there anything meaningful you can think of that you might have done to get it booting? I'm having the exact same issue here but I've left it for several hours over three attempts and it hasn't successfully booted the recovery, just sits with the brightened fastboot mode screen.

  19. stchad Ice Cream Sandwich Aug 19, 2014

  20. QuaqSim Gingerbread Aug 19, 2014

    QuaqSim, Aug 19, 2014 :
    An error made me realise that I had installed the Android SDK prior to a major system update so I decided to take a punt at uninstalling and reinstalling the SDK. That did the trick for me, TWRP booted within a second of running the command.