Guide Ubuntu & OnePlus One: unlock the bootloader, install TWRP and SuperSU.

  1. vpakg Cupcake Oct 3, 2014

    vpakg, Oct 3, 2014 :
    I've just rooted mine, however when trying to run the supersu linked on this post I was getting a "invalid signature" error. I had to download it from the play store and run the binary updates and execute "normal mode", instead of through TeamWin. But then everything worked fine. Thanks again for the tutorial.

  2. nguser KitKat Oct 3, 2014

    nguser, Oct 3, 2014 :
    Not that I know. Users are following this guide without problems so maybe that post will remain "reserved" without any specific reason.

    You're welcome.

  3. vpakg Cupcake Oct 3, 2014

    vpakg, Oct 3, 2014 :
    You will probably be able to dual boot Ubuntu and Android on a OPO soon (hopefully). I'm a full time linux user, both at home and work and I don't even have Windows / OSX installed in any of my machines. I'm not overly excited about the Ubuntu Phone to be honest...I feel like android is very solid and it will take a while for Ubuntu to catch up. However I can help but to be curious on where this will take the OS.

    I'm one of the thousands of people who pledged 800+ dollars on the Ubuntu phone that promised 64gb (indiegogo campain). Who would have imagined that Oneplus one would manage to offer similar hardware (maybe even better) with a much more reasonable price?

    mydroid likes this.
  4. mort_ Gingerbread Oct 6, 2014

    mort_, Oct 6, 2014 :
    Worked like a charm. :)
    I used the OPO Toolbox v3 to simplify the unlocking and manually booted into CWM for installing super-su. Thank you for all your help and advices. Now, I understand the whole process a lot better than before.

    nguser likes this.
  5. ashoktvm Ice Cream Sandwich Oct 7, 2014

    ashoktvm, Oct 7, 2014 :
    if i install 33R using fastboot method. Do i need to unlock bootloader again?

  6. rahulraimarine Eclair Oct 13, 2014

  7. mangatinanda Gingerbread Oct 15, 2014

    mangatinanda, Oct 15, 2014 :
    When i give this command sudo fastboot boot twrp.img I am getting this error. FAILED (data transfer failure (Value too large for defined data type))
    Same with flashing recovery too with sudo fastboot flash recovery twrp.img.
    Recently updated to 38R..

    No clue what this error is...even google could't help me :( Please reply

  8. mort_ Gingerbread Oct 16, 2014

    mort_, Oct 16, 2014 :
    If you once unlocked the bootloader and kept the stock recovery you can install the official system update. Your phone will stay oem unlocked.

    PS: I figure you mean the 38R and not really an old 33R?

  9. CiCC Cupcake Oct 18, 2014

    CiCC, Oct 18, 2014 :
    Hi, thanks for the tutorial. It is working on Arch (the package to install is android-sdk-platform-tools from AUR).

  10. BogdanIvanovici Eclair Oct 21, 2014

    BogdanIvanovici, Oct 21, 2014 :
    My Oneplus One stuck's when i press the power button for startup and just vibrate every 2 seconds. Nothing on the screen, i cannot connect it to PC, i cannot start it in fastboot or recovery, the computer will not recognise the phone. I need a method that connect the phone to computer, because if i have it connected i can flash the rom and restore all aditional files. PLEASE HELP !!!!

  11. mort_ Gingerbread Oct 21, 2014

    mort_, Oct 21, 2014 :
    If you don't get into fastboot at all, that sounds like an RMA to me.

  12. kellrobinson Cupcake Oct 27, 2014

    Last edited: Oct 27, 2014

  13. sirabhinav Froyo Nov 8, 2014

  14. kellrobinson Cupcake Nov 8, 2014

    kellrobinson, Nov 8, 2014 :
    You say, "Open Software & Updates." What's that? I found Ubuntu Software Center but I don't see anything called a Universe repository. Can you please explain like I'm five?

  15. kellrobinson Cupcake Nov 8, 2014

    kellrobinson, Nov 8, 2014 :
    Never mind, turns out I could just skip that step. Completed the root. Would still like to know how to check on the repository though.

  16. lnxpro Jelly Bean Nov 8, 2014

    lnxpro, Nov 8, 2014 :
    Thanks @nguser , awesome tutorial for GNU/Linux users like me

  17. Afzal Khan Jelly Bean Nov 8, 2014

    Afzal Khan, Nov 8, 2014 :
    can i also do this?? i mean its pretty much self explanatory but the problem is in the chair (hope u'll get it, as i dont want to appreciate myself on this forum :rolleyes:)

  18. nguser KitKat Nov 8, 2014

    nguser, Nov 8, 2014 :
    Thanks for this precious feedback. I going to put this information in the first page.

    And of course thanks to all of you guys giving feedbacks on my tutorial.

    lnxpro likes this.
  19. lnxpro Jelly Bean Nov 9, 2014

    lnxpro, Nov 9, 2014 :
    Will try on my Linux mint tomorrow I recieve my preorder OPO

  20. Kisu Froyo Nov 15, 2014