1
OxygenOS Unable to Boot after OOS 5.0.1 OTA - PLEASE HELP

  1. DashIt Donut Jan 12, 2018

    DashIt, Jan 12, 2018 :
    Last night I got the OTA update notification and updated to OxygenOS 5.0.1 before I went to bed. I woke up today with a non-functional phone. After booting, all I get is a black screen and a message saying "system UI has stopped." It then attempts to reboot and fails, eventually booting into the recovery.

    I am on the stock recovery, no root, no unlocked bootloader, but I do have ADB debugging enabled.

    I have never experimented with custom ROMs so I am not very experienced with using the recovery, but I do have some idea what I am doing. Is there any way for me to fix the issue without loosing all my files? Will I be fine simply flashing 5.0.1 again from recovery?

    Thanks in advance.


    Edit: I now know with almost certainty it was my (rootless) Substratum theme causing the issue (*facepalm*). If you make sure to remove your themes before you update you won't have this issue. If you did the same thing as me, just use the 'Reset system setting' option in the stock recovery. You will lose your apps but not your files.

     
    Last edited: Jan 13, 2018

    #1
  2. ncardell Cupcake Jan 12, 2018

    ncardell, Jan 12, 2018 :
    I am having the same problem. I accepted the update notification and then my phone kept crashing and rebooting 5 seconds after it booted into the OS. I tried deleting cache and restoring to factory settings and nothing works.
    I even tried redownloading the latest ROM and installing it with ADB sideload and it keeps crashing. Older ROMs are failing to install with adb sideload.

    The latest update essentially bricked my phone and I have tried so many things and nothing fixes it!!
     

    #2
  3. francybenati Honeycomb Jan 12, 2018

  4. DashIt Donut Jan 12, 2018


    #4
  5. Hydra Bob Lollipop Jan 12, 2018

    Hydra Bob, Jan 12, 2018 :
    Reboot into recovery mode and do a factory reset. Since you have ADB enabled you can pull your files first if you want. If that doesn't work download the full ROM from the OP support site and sideload it through adb.
     

    #5
    Ash645 likes this.
  6. DashIt Donut Jan 12, 2018

    DashIt, Jan 12, 2018 :
    Thanks a bunch! Are there any steps in between these a noob would need to know? I've heard of issues caused when you don't clear your cache at the right time or things like that.

    Would I just copy my files in ADB by navigating my file system and copying the folder(s)?
     

    #6
  7. Hydra Bob Lollipop Jan 12, 2018

    Hydra Bob, Jan 12, 2018 :
    No problem, glad to help.

    A factory reset will wipe the cache as well but it's always a good idea to wipe it after every update. You won't lose any data and it will help things run smoothly.

    If your phone isn't booting then you probably won't be able to just copy paste from Windows or whatever. You'll probably have to use the command "adb pull" from command prompt, so you'll have to know a little bit about the locations of the files your trying to get. /sdcard/DCIM would be the location of your photos, /sdcard/Download would be your downloads and so on. If you're familiar with navigating CLI then adb shell might help you explore your files and find what you're looking for.

    And finally if you wind up having to sideload you might run into a memory allocation issue as well. If you do just let me know and I'll post a link to fix it.

    Good luck and don't hesitate to ask if you need any clarification or get stuck anywhere along the way.
     
    Last edited: Jan 12, 2018

    #7
    Ash645 likes this.
  8. DashIt Donut Jan 12, 2018

    DashIt, Jan 12, 2018 :
    Thanks so much for all the help. I am trying to get my files with adb and I think I know how, but I can't get
    Code:
    adb devices
    to find it when the phone is in the recovery (yes the PC does have permission to debug this phone I've done it before). Do I need to reboot to fastboot or something?
     

    #8
  9. Hydra Bob Lollipop Jan 12, 2018

    Hydra Bob, Jan 12, 2018 :
    Start by making sure you have the latest USB and ADB drivers and that Windows is able to find and correctly identify your phone in the device manager.
     

    #9
    Ash645 likes this.
  10. G_trinadh_kolisetty_VQUK Cupcake Jan 12, 2018

  11. DashIt Donut Jan 13, 2018

    DashIt, Jan 13, 2018 :
    I'm on adb 1.0.32 and not exactly sure how to update or what the latest version is. I don't think I see the phone in device manager but maybe it has a weird name or something.
     

    #11
  12. DashIt Donut Jan 13, 2018

    Attached Files:


    #12
  13. DashIt Donut Jan 13, 2018

    DashIt, Jan 13, 2018 :
    When I am ready to factory reset, do I choose 'reset system setting' and/or 'erase everything' from the recovery? Or do I need to clean install the latest version instead?
     

    #13
  14. Hydra Bob Lollipop Jan 13, 2018

    Hydra Bob, Jan 13, 2018 :
    If you just have the sdk tools then the command

    sdkmanager "platform-tools" "platforms;android-26"

    should get you the latest version, if you have the whole Android Studio then you should have a nice convenient GUI to help you update.

    And just reset system setting should be enough.
     

    #14
    Ash645 likes this.
  15. ncardell Cupcake Jan 13, 2018

    ncardell, Jan 13, 2018 :
    OMG I finally fixed my phone! Thanks francybenati!

    What I did was:
    1) I downloaded the tool listed on this site (I used the Oxygen Version Download):
    https://forum.xda-developers.com/oneplus-5/how-to/unbrick-tool-oneplus-5-t3648169
    2) I followed these instructions to connect my phone to my win10 pc as a Qualcomm HS-USB QDLoader 9008 device:
    https://forums.oneplus.net/threads/guide-oneplus-3-3t-unbrick.531047/
    (I was lucky because I didn't actually have to install the drivers, it was already correctly recognized by windows as that device)
    3) I ran the "MsmDownloadTool V4.0.exe" tool as administrator I just clicked "Start" and it flashed my phone with a working OS
    4) The phone rebooted by itself and it went into the OS without crashing/freezing and the phone is basically reset so it's like brand new

    Thanks everyone.
     

    #15
    Hydra Bob likes this.
  16. DashIt Donut Jan 13, 2018

    DashIt, Jan 13, 2018 :
    Great! I'll try this if I can't get other solutions to work.
     

    #16
  17. ncardell Cupcake Jan 13, 2018

    ncardell, Jan 13, 2018 :
    Dashit, I tried like every other solution before and nothing else worked! I even tried installing twrp and custom ROMs to see if it would fix it. But the phone kept freezing no matter what I tried; it would even randomly freeze inside the twrp recovery.

    Something about that 5.0.1 update fundamentally messed up the phone so that it will keep freezing unless you completely wipe out everything and unbrick your phone using the unbrick tool posted above!
     

    #17
  18. G_Isidro_Penhalvel_WlTE Donut Jan 13, 2018

    G_Isidro_Penhalvel_WlTE, Jan 13, 2018 :
    I fixed by flashing the OTA with the recovery and it wasnt booting. i chatted with the support and they said that i have to erase everything (the option in the recovery). so i did that and worked. try it
     

    #18
  19. DashIt Donut Jan 13, 2018

    DashIt, Jan 13, 2018 :
    I will most likely try this, but I'm still trying to save my pictures in full resolution (they are backed up but compressed). You did lose everything, right? I can't seem to get at my files over adb or even get my computer to recognize the phone at all.
     

    #19
  20. DashIt Donut Jan 13, 2018

    DashIt, Jan 13, 2018 :
    So all you did to fix the issue was boot to stock recovery, and select 'Wipe data and cache' > 'Erase everything(Music, pics, etc)'? Or did you have to flash something in addition?
     

    #20