4
Unable to connect to QPST / PDC / EFS Explorer on Android 11 via OnePlus 8 Pro

  1. hiroglifix
    Eclair Oct 13, 2020

    hiroglifix , via OnePlus 8 Pro , Oct 13, 2020 :
    After update to Android 11,
    QPST DOESNT CONNECT.

    i cannot use VoLTE and 5G.

    before i was able to use after changing EFS files since OnePlus device doesnt have Korean telecom carriers modem files. i needed to switch some files on QPST.

    now it doesnt recognize my phone on Android 11.

    please fix this issue asap. unless you will add official support for carriers to enable VoLTE, VoWIFI, AND 5G !!!!!!!!!!
     

    #1
  2. POIZ
    Gingerbread Oct 19, 2020


    #2
    AbbasiG likes this.
  3. AbbasiG
    Froyo Oct 20, 2020

    AbbasiG , via OnePlus 8 , Oct 20, 2020 :
    Same here in KSA, cant connect to PDc, volte is working fron last settings(android10), but whenever someone calls, number shown as unknown,while on Volte ....
     

    #3
  4. seb1003
    Eclair Oct 24, 2020

    seb1003 , Oct 24, 2020 :
    I'm in Switzerland too, I have a Oneplus 8T, of course, same problem....
     

    #4
    AbbasiG likes this.
  5. seb1003
    Eclair Oct 26, 2020

    seb1003 , Oct 26, 2020 :
    I solved the problem. I just did a video to explain how to solve the problem. At the moment it's only in French, but I think it can help anyway :
     

    #5
    TrymoCore likes this.
  6. AbbasiG
    Froyo Oct 26, 2020

    AbbasiG , via OnePlus 8 , Oct 26, 2020 :
    Will sure try tomorrow and give feedback if it works or not
     

    #6
  7. POIZ
    Gingerbread Oct 26, 2020

    POIZ , Oct 26, 2020 :
    i had to take the second COM (port) but it worked fine thanks

    but i changed (like last time) carrier_policy.xml and lte_feature_restrictions.xml. I have no file named **subscribtion01 on my 8 Pro

    and i looked into the new android 11 carrier file. and 5G is enabled. i didnt need to change somthing. i drove to an 5G area and it worked lol :D
     
    Last edited: Oct 26, 2020

    #7
  8. AbbasiG
    Froyo Oct 27, 2020

    AbbasiG , via OnePlus 8 , Oct 27, 2020 :
    Thanks for this wonderful update,i was able to connect with QPST and changed carrier policy etc, but unable to connect my phone with PDC inorder to change the modem profile to any modem that works with volte without having incoming calls as UNKNOWN.

    Currently i am able to use VOLTE service,but all incoming calls are coming as UNKNOWN!!!!!
     

    #8
  9. AbbasiG
    Froyo Oct 27, 2020

    AbbasiG , via OnePlus 8 , Oct 27, 2020 :
    Bro what did you change for lte restrictions file??? İ copied it to my pc ,but i don't have any replacement file for it
     

    #9
  10. POIZ
    Gingerbread Oct 27, 2020


    #10
    AbbasiG and hiroglifix like this.
  11. G_sujan_aryal_uhbi , via OnePlus 8 Pro , Oct 30, 2020 :
    Same here in Japan. But if you had already enabled VoLTE previously before updating to OS 11 then you probably can still use it. I had enabled it in both sim card slots before but after updating Sim slot 1 couldn't use VoLTE so I tried slot 2 and I was able to use it. I did check the PDC but it doesn't show my device.
     

    #11
  12. AbbasiG
    Froyo Oct 31, 2020

    AbbasiG , via OnePlus 8 , Oct 31, 2020 :
    Yes my VOLTE working on both aims,but the banner/modem/profile that i selected is somehow showing incoming calls as UNKNOWN after @Android 11 same problem i faced while trying some different profile in Android 10,but chang d to Germany profile and UNKNOWN incoming calls issue wa solved.

    But the problem this time is cant connect with PDC, though i can easily connect with QPST nowz but PDC is not picking up the device!!!!!

    Need assistance if somebody figured it out....
     

    #12
    hiroglifix likes this.
  13. POIZ
    Gingerbread Dec 6, 2020


    #13
  14. sephstyler
    Gingerbread Dec 7, 2020

    sephstyler , Dec 7, 2020 :
    No. Same boat. OOS11, can get to QPST, but not PDC.

    OnePlus - you really need to sort out your support for VoLTE, VoWIFI and 5G networks around the world.

    I appreciate the fact that you don't expect many users to use them on networks that you don't work directly with, and thus, lack support, however, your product is a MOBILE phone, expect it to be MOBILE, and be used with a myriad of SIM cards and networks.

    When the biggest networks in some countries cant work, you've got some explaining to do.
     

    #14
    W1635877312520 and POIZ like this.
  15. POIZ
    Gingerbread Dec 11, 2020

    POIZ , Dec 11, 2020 :
    Found a way.
    worked for me just fine!
    Follow the steps in order and on your own risk.
    Just try if you know adb

    1. install Logkit v1.0.apk, and Engineering Mode v1.01.0.171117173719.apk
    2. Open Phone and type *#800# select Engineering Mode
    3. Oneplus Logkit ---> Function Switch ---> enable VoLTE, VoWifi
    4. Reboot
    5. Open settings and enable VOLTE and voWi-fi
    6. Open Phone and type *#801# select Engineering Mode
    7. Switch to full port switch
    8. Open settings and enable debugging by usb mode
    9. adb reboot ftm
    10. adb shell
    11. setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb
    12. Open PDC and select profile ( sub0 and sub1 then click activate for VoLTE PTCRB for example)
    13. Close PDC
    14. adb reboot

    My VoLTE is back.

    InkedScreenshot_20201211-222417_LI.jpg
     

    #15
  16. Mitchell_Leitman
    Cupcake Jan 22, 2021

    Mitchell_Leitman , Jan 22, 2021 :
    I'm stuck at step 10 or 11. I get the splash screen with the OnePlus logo and "Powered by android", but it doesn't go beyond. But I hear it reconnect, so I try "adb shell" and get my device shown. But after entering "setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb" nothing else happens. I go into PDC and my device doesn't show up in the dropdown menu. Any ideas?
     
    Last edited: Jan 22, 2021

    #16
  17. hiroglifix
    Eclair Jan 26, 2021

    hiroglifix , via OnePlus 8 Pro , Jan 26, 2021 :
    are you rooted?

    because what seems to be the cause of the problem is that the below property setting was enabled by default before. but now, it's not.

    on non-rooted phones, we do not have access to change and set below command to work.

    setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb
     

    #17
  18. POIZ
    Gingerbread Jan 26, 2021

    Last edited: Jan 26, 2021

    #18
  19. POIZ
    Gingerbread Jan 26, 2021

    POIZ , via OnePlus 8 Pro , Jan 26, 2021 :
    Sounds like you're not really in ftm mode.
    When you type adb reboot ftm. It turns after some Chinese symbols complete black, than adb shell works for me.

    I can try make a video.

    EDIT
    I made a video (not by best work, and it just shows that it worked for me)
    DOnt know if it is any help for you :(


    Screenshot_20210126-225407__01.jpg
     
    Last edited: Jan 26, 2021

    #19
  20. S1616276547926
    Cupcake Apr 8, 2021

    S1616276547926 , Apr 8, 2021 :
    I tried to do what you did, but I'm at PDC and when I select Qualcomm I get " ******pdc connect to device failed"

    Where did you downloaded your Qualcomm and QPST program? I have turned on Engineer mode and full port switch
     

    #20