Unable to do any online bank transaction after Oxygen OS 4.0 update on OnePlus 3T

  1. saurabhjain1986
    Cupcake Jan 13, 2017

    saurabhjain1986 , Jan 13, 2017 :
    After I updated my oneplus 3T to oxygen OS 4.0, I am not able to do any online bank transactions into any of the apps. Example- If I need to make a purchase on Amazon app, when I enter my card details and try to make payment, it keeps.on waiting for payment gateway reply but nothing happens. Same behavior with every app where online transaction can be done. However, if I open Amazon in my browser and from there I do payment using my card, it goes through successfully. So, I am sure its something to do with my phone and not my card. Any ideas or thoughts anyone?

    G_T._A._CxNO likes this.
  2. stijnonlijn
    Ice Cream Sandwich Jan 13, 2017

  3. Kiran.a.joseph
    Jelly Bean Jan 13, 2017

    Kiran.a.joseph , Jan 13, 2017 :
    Thats correct, try reinstalling amazon app.

  4. Krishna2142
    Honeycomb Jan 13, 2017

  5. stijnonlijn
    Ice Cream Sandwich Jan 13, 2017

  6. Krishna2142
    Honeycomb Jan 13, 2017

    Krishna2142 , Jan 13, 2017 :
    yup I did tried reinstalling and also my card details in the app but not able to perform transaction

  7. jerrymilton
    Jelly Bean Jan 13, 2017

    jerrymilton , Jan 13, 2017 :
    so basically the name of this thread should be "can't get Amazon app to work correctly" a far cry from "any online banking". you might try installing a previous APK of that app.

  8. saurabhjain1986
    Cupcake Jan 14, 2017

    saurabhjain1986 , Jan 14, 2017 :
    Thanks for your suggestions. So, I have already tried the following :

    1. Reinstalling all apps that are having issue with online payments.
    2. Wiped cache.
    3. Made sure that I don't have AVG antivirus, paytm installed.

    Basically, when I enter my card details and proceed, the payment gateway page keeps on loading forever.

    P.S. - I started getting this issue after upgrade to oxygen OS 4.0. As Indian customers are still waiting to get the OTA, I forcefully received the OTA via VPN from germany. Could that be a culprit?

  9. saurabhjain1986
    Cupcake Jan 14, 2017

  10. Kumar Praharsh Rakheja
    Cupcake Jan 24, 2017

    Kumar Praharsh Rakheja , Jan 24, 2017 :
    After going for my OP3 N update, I am unable to complete any transaction from my phone. The app never goes to the payment page (just freezes on the authenticate payment page), even the OTP messages are not coming through. I am not able to use Paytm and other banking services, even my WhatsApp is not getting started as I am not getting the OTP within time.

    I have factory reset my phone many times, but the problem still persists.

    Can anyone help me out on this?


  11. anandatnet
    Cupcake Jan 28, 2017

  12. Parikshit_Das
    Cupcake Feb 1, 2017

    Parikshit_Das , Feb 1, 2017 :
    The above link didn't work for me.
    It is redirected to Android System Webview in play store. It gives option to click on enable. No matter how much we click on it, it does not work.

    Khwabtrikha likes this.
  13. G_Trijya_Singhal_ZkRK
    Cupcake Feb 9, 2017

  14. G_Trijya_Singhal_ZkRK
    Cupcake Feb 10, 2017

  15. ujjwalk308
    Gingerbread Feb 10, 2017

  16. gubro
    KitKat Feb 10, 2017

    Petjitsu and Kiran.a.joseph like this.
  17. padmakumarnair
    Cupcake Feb 10, 2017

    padmakumarnair , Feb 10, 2017 :
    same issue with Paytm transactions which is prompting for Android we view which is disabled.. any solutions?!

  18. G_Preetam_Jain_cxCG
    Donut Feb 10, 2017

  19. Khwabtrikha
    Cupcake Feb 28, 2017

    Khwabtrikha , Feb 28, 2017 :
    Hi Need help on the same! Unable to get the solution to it!

  20. bhushancbz
    Cupcake Feb 28, 2017