0
Unable to send text messages & Message centre number

  1. rahulraimarine
    Froyo Sep 16, 2014

    rahulraimarine , Sep 16, 2014 :
    Guys can someone help me with this.
    I am not able to send text messages with my OPO. I never used it till yesterday....I have the phone for last 2 months. I can't enter or check the message centre number in message settings. I installed GO SMS PRO as someone told me to try on XDA but that didn't work either even after entering the message centre number. I can receive but can't send.

    Would appreciate any help.
     

    #1
  2. haastile
    Eclair Sep 27, 2014

    haastile , Sep 27, 2014 :
    I just got my OBO. Had the same problem. Turned out it was the Voice+ app. During setup, there's a prompt to allow Voice+ to authorize all SMS messages to be encrypted (and send through Google Voice.) That's what disabled outgoing text messages from Hangouts and Messages. Once you disable Voice+, texting works again. Go to: SETTINGS > WIRELESS & NETWORKS > MORE... > VOICE+
     

    #2
  3. aphillabaum
    Cupcake Oct 25, 2014

    aphillabaum , Oct 25, 2014 :
    I wish there were a better solution than this. I'd love to use encrypted txt when the other device supports it... but c'est la vie.
     

    #3
  4. lofteeuk
    Cupcake Dec 6, 2014

    lofteeuk , Dec 6, 2014 :
    Hey,

    Having the same issue with sms. Tried the voice+ settings but they don't exist and can't find the settings anywhere.

    Can't find message center number either. Is there an option for this? How do i check/change it?

    Thanks
     
    Last edited: Dec 6, 2014

    #4
  5. d24jul04knmw
    Cupcake Feb 19, 2015

    d24jul04knmw , Feb 19, 2015 :
    Thank you for this information...It was very helpful....It solved my problem.
     

    #5
  6. amit.avit
    Cupcake Sep 19, 2015

    amit.avit , Sep 19, 2015 :
    To chage sms centre (smsc)...
    go to dialer -> enter *#*#4636#*#* -> Phone Information -> scroll down to smsc -> enter number -> click update
    P.S. Please enter the number in double quotes
     

    #6
    pidow likes this.
  7. naag007
    Cupcake Sep 25, 2015

    naag007 , Sep 25, 2015 :
    Thanks for the tip. I am able to fix sms outgoing issue with my One Plus Two mobile.
     

    #7
  8. charanchakravarthi
    Honeycomb Oct 2, 2015

    charanchakravarthi , Oct 2, 2015 :
    Thanks a ton this fixed the issue. So actually do not have a straight forward way to change the message center number? I did the same thing in my friends OP2 and his smsc was empty as well but he did not face this issue of not being able to send messages
     

    #8
  9. abhisheksarda
    Cupcake Oct 12, 2015


    #9
    X1572463231835 likes this.
  10. Sparth
    Cupcake Oct 14, 2015

    Sparth , Oct 14, 2015 :
    Hi,

    The Message Center number is not recognised by some android OS. The solution to this to remove the sim and insert in the normal phone and update the SMSC no. try to send the sms from that phone and if goes through remove the sim and insert into the OPO. this works .

    Other method is to go to the nearest mobile service provider showroom and handover the sim for updation of the SMSC no. once this is done SMS will work. I had the same issues with my OP2 and got it resolved

    thanks
     

    #10
  11. sha.aga
    Cupcake Oct 30, 2015


    #11
    X1572463231835 likes this.
  12. Champaklal
    Cupcake Nov 11, 2015


    #12
  13. jaysmoke
    Gingerbread Apr 14, 2016

    jaysmoke , Apr 14, 2016 :
    Having this same problem and I dunno what to do! Done everything here including removing the sim and inserting into another phone! Sends alright there but not when I put it in the OPT
     

    #13
  14. Ssaint
    Cupcake Jul 30, 2016

    Ssaint , Jul 30, 2016 :
    jaysmoke, did you ever fix this on the OP3? I'm having same prob, doesn't seem to be saving the SMSC in the testing screen..
     

    #14
  15. Dd5150
    Cupcake Aug 25, 2016

    Dd5150 , Aug 25, 2016 :
    @Ssaint and Jaysmoke
    I just resolved my sms problems on the op3 using the above method. Just get the no from customer care and update it. :)
     

    #15
  16. liayj
    Cupcake Dec 14, 2017

    liayj , Dec 14, 2017 :
    So i had a lot of problems with this exact issue on the OP5 and after much tinkering I found the number you have to enter into teh SMSC field is based on your carrier. You can find this info by googling your carrier and then SMS center number. This worked for AT&T which uses the number “+13123149810“ (be sure to use the quotes around this number). Then press update and refresh and there should be a comma followed by 145 after that number. We tried changing APN and voLTE settings and this was the only thing that worked.

    This issue seems to be especially prevalent if you use dual sim cards for different countries.
     

    #16
  17. X1508116302136
    Cupcake Feb 10, 2018


    #17
  18. Aarushi mathur
    Cupcake Jul 19, 2019


    #18
  19. farid.shirvani
    Cupcake Oct 24, 2020

    farid.shirvani , Oct 24, 2020 :
    I am using Spectrum Mobile on OnePlus 8T and everything works except receiving text messages. Does anybody know how I can fix this since Spectrum refuses to even answer since OnePlus is not being offered by them.
     

    #19