0
Unable to update to 30O after unlocking boatloader?

  1. oneeyedhobbit
    Gingerbread Sep 11, 2014

    oneeyedhobbit , Sep 11, 2014 :
    Hey everyone,

    I just got my OPO today! Since unlocking the boatloader wipes everything, I figured I should do this first, and that I might as well root my device. This went along swimmingly thanks to the guide at https://forums.oneplus.net/threads/...oader-install-custom-recovery-and-root.64487/. However, I've now unable to update Cyanogen mod. I'm getting a message that XNPH 30O is ready to be installed, and pushing the OTA "install now" button reboots and takes me into TWRP, which fails to install the zip.

    I figured this might be due to a non-stock recovery partition, so I tried to manually install the update from TWRP. In both cases I'm getting an "Error executing updater binary in zip'myziphere'" where myziphere == the OTA update in /cache/ as well as one I found on AndroidCentral.

    Any ideas? I'm wondering if my only fix would be to flash the stock recovery (and if so, where can I find the stock recovery), fully update, and then install TWRP, or if there is something I'm missing to make it so that I can at least manually install these updates via TWRP.
     

    #1
  2. Lys10101
    Ice Cream Sandwich Sep 11, 2014

    Lys10101 , Sep 11, 2014 :
    I could not update to 33, even when trying with twrp. I then found the file on xda forum (oneplus one) and that particular file worked with twrp with no problem... You should check there...
     

    #2
  3. Aaahh
    Marshmallow Sep 11, 2014


    #3
    kp1234 likes this.
  4. oneeyedhobbit
    Gingerbread Sep 11, 2014

    oneeyedhobbit , Sep 11, 2014 :
    Oh yeah, I forgot I can just flash directly to 33R. Thanks. I'm guessing there is no way to restore CM's OTA upgrades with a custom recovery?
     

    #4