1
Guide UNBRICK YOUR ONEPLUS 2.

  1. shashik008
    Froyo Mar 28, 2016

    shashik008 , Mar 28, 2016 :
    Hi guys.

    CAUTION== if u are planning to install custom rom like cm13 or any other just DISABLE SECURITY features like FINGERPRINT , PATTERN LOCK, etc.. YOUR device will be bricked if u plan to flash a custom rom with password protection on previous ROM.this feature is added by google in lollipop and it continues.

    COMING to the solution:

    METHOD 1 didnt work for me
    i got it by using method 3.

    your bootloader will be locked if ur device is bricked, dont worry.
    if u can enter fastboot mode, its okay it is a soft brick.. if u cannot turn on device at all then it is hard brick

    just download oneplus drivers and the recovery tool which is 1gb from the link given in mehtod 3.

    switch off ur phone by long pressing the power button for 20 sec,

    connect ur mobile to pc and hold VOL+ , VOL- , power all 3 at once to enter qualcomm mode. u will get a sound when recognised.

    go to device manager (if u r using windows) , go to PORTS> IF u see "Qualcomm HS-USB diagnotics 9008." , then u are in right path my friend.

    IF your device is showing Qualcomm HS-USB diagnotics 900E(COM4)/(COM3) , then you are not in qualcomm mode.

    for getting into qualcomm mode, u should press all 3 buttons V+,V-, power buttons simultaneously after connecting to usb.

    if u connect ur device directly to PC u will not get into qualcomm mode.

    IF your device shows Qualcomm HS-USB diagnotics 9008 ,u r succesful in setting up drivers

    AFTER that just unzip the RECOVERY TOOL which is around 1GB and run the MSM..recovery tool as administrator ,press start U are done.

    u will be directly boot into the HYDROGEN OS not oxygen.

    ENJOY.
    IF u want to get into oxyegen

    go to settings developer options

    1) enable usb debugging
    2)enable oem unlocking

    same process as u unlock bootloader and flash twrp and flash supersu. u can restore any rom backups if u have...

    YELLLAAH, BYE .
     

    #1
    domecamm likes this.
  2. dinjesk
    KitKat Mar 28, 2016

    dinjesk , Mar 28, 2016 :
    Thats why you should always do a clean install when changing between roms.

    Always wipe everything exept internal storage, before flashing the rom
     

    #2
    Multiplatform Gamer and Tokolozi like this.
  3. Tokolozi
    Marshmallow Mar 28, 2016

    Tokolozi , Mar 28, 2016 :
    Well TBH I'm sometimes guilty of trying to dirty flash, and only do a clean flash if it doesn't work. (say moving between CM based ROMS)
     

    #3
    dinjesk likes this.
  4. dinjesk
    KitKat Mar 28, 2016

    dinjesk , Mar 28, 2016 :
    You bad boy:eek::eek:
     

    #4
    Tokolozi likes this.
  5. Tokolozi
    Marshmallow Mar 28, 2016

    Tokolozi , Mar 28, 2016 :
    Well, It's rather easy to fix. But bought TiBackup so it happens less.
     

    #5
  6. anupritaisno1
    KitKat Mar 28, 2016

    anupritaisno1 , Mar 28, 2016 :
    I never disabled password protection, fingerprint, etc before flashing roms

    It's an Android lollipop feature that is DEACTIVATED when you unlock the bootloader

    For getting to Qualcomm mode, press and hold only volume up, not all 3 buttons. 900e is due to Windows incorrectly recognizing the device

    Hey ! Wait ! You don't just download some random Qualcomm unbrick package and flash it without integrity checks. First you press the Chinese button.... Don't ask me which one..... There's only one Chinese button there. Then you wait, it will check of files are OK and give you OK/failed

    You forgot to put PC in test mode

    You forgot to disable driver signature enforcement

    You forgot to install the test certificate

    1 more thing, device doesn't need to be detected as 9008
    If it is 900e but if it was detected as qhsusb_bulk before driver installation, it should technically still work

    And last thing

    This is not your file

    It belongs to oneplus and Naman Bhalla uses it

    Please give credit to @Naman Bhalla
     

    #6
    dinjesk likes this.
  7. dinjesk
    KitKat Mar 28, 2016

    dinjesk , Mar 28, 2016 :
    I always make backup in twrp and then make a clean flash when i switch roms. I only dirty flash when updating rom versions
     

    #7
    Tokolozi likes this.
  8. Tokolozi
    Marshmallow Mar 28, 2016

    Tokolozi , Mar 28, 2016 :
    With Ti, It's like doing a dirty flash when doing a clean one, all apps where you left them and installed in one click on the pro version. And before switching I do also have a nandroid (twrp) jsut in case.
     

    #8
    dinjesk likes this.
  9. anupritaisno1
    KitKat Mar 28, 2016

    anupritaisno1 , Mar 28, 2016 :
    Well I was a bit busy updating my post

    What are we upto here ?
     

    #9
    dinjesk likes this.
  10. anupritaisno1
    KitKat Mar 28, 2016

    anupritaisno1 , Mar 28, 2016 :
    It works on RR

    Only backup APKs, dirty flash RR and then only install the APKs
    No need to backup data
     

    #10
  11. monell81
    Cupcake Mar 28, 2016

    monell81 , Mar 28, 2016 :
    Hi guys,
    my OPT A2001 it's bricked...
    i flash the rom miui v7 and was ok,i check new update,download and install
    after reboot the phone it's with black screen,but not properly,with little bit brightness and soft key blu
    now if i connect to pc result installed driver mi note pro...??!!
    and in vol + and power my PC finds a new hardware but only MTP,
    i don't have name of ‘QUALCOMM-HS USB only device mtp...
    help me...thank
     

    #11
  12. anupritaisno1
    KitKat Mar 28, 2016

    anupritaisno1 , Mar 28, 2016 :
    Please follow up in our PM
     

    #12
    monell81 likes this.
  13. monell81
    Cupcake Mar 28, 2016


    #13
  14. Fzaman90
    Eclair Mar 29, 2016

    Fzaman90 , Mar 29, 2016 :
    Hey @anupritaisno1

    So I managed to get through all the steps and I can now successfully get to the Opo Stock recovery. problem is I don't have a ROM or my data partion may have been wiped.

    How do I proceed from here to flash an image so I can boot up a rom and turn on the OEM Bootloader unlock option in the settings. Anytime I have tried to flash anything it says I cannot flash because my boot loader is locked again. I have gone through a few threads and I see where they get to this part but am I missing something here?

    If someone can point me into the right direction or PM me for assistance, I would greatly appreciate it. I have seen where it says to ADB Sideload a rom but I am not familiar with this.

    Edit: followed this video link .


    but I am still getting an issue where I cannot unlock the bootloader and/or get an OS to launch :(. See attached image.
     

    Attached Files:


    #14
  15. domecamm
    Gingerbread Jul 5, 2018

    domecamm , Jul 5, 2018 :
    Hello, for method A2001 only method 1 works?
    After finishing the procedure, the green text comes out but the phone remains locked on the 1+ logo and the writing powered by andoird, does not start in recovery even by pressing the keys.
    It is recognized in fastboot mode, but it is not possible to flash because the bootloader is locked.
    I also tried the modified version of the tool with english recovery, but nothing to do ...
    Can you help me? Thanks
     

    #15