4
[UNIFIED] 90hz Display discussion thread

  1. InLineR
    Cupcake Aug 16, 2019

    InLineR , Aug 16, 2019 :
    Hi! After installing chrome 76.0.3809.111 i have 60hz only in chrome. Reverting back to stock version solves the problem. Do you have the same issue? OOS 9.5.11

    And it will be great to have an option in future updates to select Hz mode for applications.
     

    #1
  2. sonnyhaze
    Eclair Sep 13, 2019 at 12:12 PM

    Stickied Post
    sonnyhaze , Sep 13, 2019 at 12:12 PM :
    How the OnePlus 7 Pro’s 90Hz can be set to be on constantly, and this is how it's done.

    As the title suggests, yes you can run 90hz all the time. The process is quite simple really. The developer C3C076, was developing a Quick Setting tile to switch the screen refresh rate when he discovered that there are actually 3—not 2—refresh rate modes in OxygenOS.

    The 60Hz mode in the Screen refresh rate settings makes the device run at a constant 60Hz like most other smartphones, but the 90Hz mode is actually internally the “auto” mode. Lastly, there’s a third, hidden true 90Hz mode that enables 90Hz at all times in all apps.

    1568372116411.jpg

    To change the refresh rate mode to this hidden full-time 90Hz mode, that runs constant for every app.
    Now all you need to do is enter a simple ADB command:

    adb shell settings put global oneplus_screen_refresh_rate 0

    Once enabled, both toggles in Screen refresh rate settings will become unchecked and the option summary text in Display settings will show “60Hz” – but that’s just a bug because OxygenOS doesn’t expect users to be able to select this hidden refresh rate mode. IF WANT TO REVERT BACK to the way things they were? Simply change the toggle in the Screen Refresh.


    If you'd like to confirm that it's running 90hz constant just go to UFO Test on two browsers that don’t support 90Hz on the OnePlus 7 Pro. For instance, Brave Browser and Samsung Internet. When the Screen refresh rate toggle for “90Hz” is enabled, UFO Test reports that Brave Browser and Samsung Internet are running at 60Hz. However, with the hidden, true 90Hz mode enabled via ADB, both browsers are reported to be running at 90Hz.

    Your Done!
     

  3. Alcides Castro
    Cupcake Aug 16, 2019


    #2
  4. Z1565940709320
    Cupcake Aug 17, 2019

    Z1565940709320 , Aug 17, 2019 :
    Same here, the program that identify the apps that can run 90 hz mode works really bad, the animations and the overall system smoothness is gone!
     

    #3
  5. Z1565940709320
    Cupcake Aug 17, 2019


    #4
  6. Matt 80
    Lollipop Aug 17, 2019

    Matt 80 , Aug 17, 2019 :
    Why? This isn't a oneplus issue, google removed 90hz support in the last chrome update, it's down to them.
     
    Last edited: Aug 17, 2019

    #5
    Chr1s101 and Ven96 like this.
  7. Z1565940709320
    Cupcake Aug 17, 2019

    Z1565940709320 , Aug 17, 2019 :
    The "home" gesture animation is aswell 60 hz, so it's super noticeable when your refresh rate chosen 90 hz. When you closing Chrome its 60 hz, and when closing any other app the animation is 90 hz, noticeably smoother. Just saying so, but overall scrolling in oneplus is feeling a bit more laggy, maybe caused by frames dropping.
     

    #6
  8. DeathMoJo
    Gingerbread Aug 17, 2019

    DeathMoJo , Aug 17, 2019 :
    You can restore it by forcing 90hz all the time via the adb command.

    I hope Google did not remove this to only implement in the new Pixel 4 that will have a 90hz display.
     

    #7
  9. Z1565940709320
    Cupcake Aug 17, 2019

    Z1565940709320 , Aug 17, 2019 :
    I rather wait for some updates. Hopefully they will fix this ASAP.
     

    #8
  10. DeathMoJo
    Gingerbread Aug 17, 2019


    #9
  11. MrRampage777
    Cupcake Aug 17, 2019

    MrRampage777 , Aug 17, 2019 :
    Okay sick I thought I was the only one here. Like the post above me I sincerely doubt it was an accident. I just tried chrome beta too and that's stuck in 60 as well. This phone has really spoiled me so now anything under the 90 is just... eugh. Hopefully it comes back. I miss it.
     

    #10
  12. Ven96
    Froyo Aug 17, 2019

    Ven96 , Aug 17, 2019 :
    Meanwhile Opera Touch is still perfectly fine. Use that instead. I was having the very same problem and found Chrome "began to be exceptionally slow" but now I confirmed it's just the 60Hz refresh rate. Well, that's a bummer, but if they don't fix it I guess their browser has got to go. Not sure if we should report it to OnePlus, but I'll leave some Feedback as well as a review on PlayStore. Maybe something'll happen.
     
    Last edited: Aug 17, 2019

    #11
    kblbn86, Matt 80 and MrRampage777 like this.
  13. abhinavgupta476
    Cupcake Aug 17, 2019

    abhinavgupta476 , Aug 17, 2019 :
    It's better to uninstall the chrome updates and restore it to the factory version. Then it will run on 90hz
     

    #12
  14. Swejuggalo
    Jelly Bean Aug 17, 2019

    Swejuggalo , Aug 17, 2019 :
    Better to use something else that works in 90Hz. I would not recommend anyone to stop updating a browser if you are conserned about security
     

    #13
  15. P1566117077146
    Donut Aug 18, 2019

    P1566117077146 , Aug 18, 2019 :
    same here, I updated the chrome yesterday. I test it with testufo.com and it says 60hz in latest chrome version. I worked all fine until I updated.
     

    #14
    DivyanshKumar333 likes this.
  16. MrRampage777
    Cupcake Aug 18, 2019

    MrRampage777 , Aug 18, 2019 :
    Just downloaded Opera. I'll have to give it a shot untill Google puts it back, which hopefully is soon. Thanks for the suggestion.
     

    #15
    Ven96 likes this.
  17. i_zeeky
    Cupcake Aug 20, 2019

    i_zeeky , Aug 20, 2019 :
    Hello,

    I have a question regarding 90 hz refresh rate. I have tested various sites with my Oneplus 7 pro Nebula blue 12 GB ram, and the site used to test the refresh rate with my chrome browser was https://testufo.com/refreshrate.

    Having my phone selected on 90 hz it only caps at 60 fps and 60 hz. But on an opera browser the phone will cap at 90 fps and 90 hz. Why is this happening on a browser that was stocked with the phone? And giving different results on another browser app?

    Now I have already heard tweaks from XDA to cap your phone at 90 hz all the time, which helps. But let's say for the average consumer who doesn't know about tweaking and just wants to use the standard setting for 90 hz. Why is it different for each browser and only showing 60hz for the main browser app?

    Can someone test my theory on this?
     

    #16
  18. George_Arwnis
    Cupcake Aug 23, 2019

    George_Arwnis , Aug 23, 2019 :
    i dont know what they change but i have 60hz in every browser...or at the start of the browser i have 90 after 2 refresh or another site 60
     

    #17
  19. xnutzii
    Lollipop Aug 23, 2019

    xnutzii , Aug 23, 2019 :
    Firefox should be in 90hz.
    Chrome has failed with an update, which led the phone to only use 60hz while browsing.
     

    #18
    Matt 80 and Discostu like this.
  20. George_Arwnis
    Cupcake Aug 23, 2019


    #19
  21. xnutzii
    Lollipop Aug 23, 2019

    xnutzii , Aug 23, 2019 :
    Have you tried forcing the 90hz via adb?
     

    #20
    Matt 80 likes this.