[UNIFIED] Widevine support is downgraded from L1 to L3 - No HD Streaming via OnePlus 8 Pro

  1. anilkigal
    Ice Cream Sandwich Oct 1, 2020

    anilkigal , via OnePlus 8 Pro , Oct 1, 2020 :
    Moderator edit:
    Please read and use this thread for any widevine DRM downgrade from L1 to L3 related discussion. Please do not create duplicate threads.
    If you want to infor your issue to oneplus, please use the feedback section on the community app or this link

    After this update DRM apps shows L3 instead of L1

    Last edited by a moderator: May 25, 2021

    flanker37, Jigs218, Kishan_k and 13 others like this.
  2. Dresa91
    User of the Year 2016; Most Active User 2020 Community Expert Jan 11, 2021

    Stickied Post
    Dresa91 , Jan 11, 2021 :
    Did you contact support via www.oneplus.com/support?
    You can try this:
    • In the Google PlayStore: settings -> biometric authentication -> enable, if disabled (enter password if needed)
    • Then reboot the phone once and check the Widevine Status -> use DRM Info App from Google PlayStore (check some minutes or hours later, if still a wrong status) -> it should be L1 then
    • Netflix still SD? Clear cache and data of Netflix and uninstall updates, then reboot and update Netflix -> after this check playback specification again
    Last edited: Jan 16, 2021

  3. Punit_Patni
    Gingerbread Mar 31, 2021

    Stickied Post
    Punit_Patni , via OnePlus 8T , Mar 31, 2021 :
    Today finally the day came when my Widevine changed from L3 to L1. This only works for OS version. Following steps required - (all steps must)

    Uninstall Netflix, Amazon Prime , DRM Check(if you have installed any) App from playstore

    Delete the cache of Netflix app.

    Enable biometric authentication in play store.

    Change display calibration to Vivid.

    Reboot the phone to recovery mode and wipe cache.

    After reboot update netflix app.

    Reboot and check and if it doesn't change, reboot 2/3 times.

    I am really happy and thankful to all other users for giving their solutions for the issue. Only thing I did is that I combined all the solutions.

    This might not work for everyone, nevertheless do try this and provide your feedback.
    Last edited: Apr 6, 2021

  4. blahq7
    Froyo May 11, 2021

    Stickied Post
    blahq7 , May 11, 2021 :
    Edit: this bug is apparently fixed by the new OnePlus update:
    https://www.androidpolice.com/2021/...ine-l1-issue-but-you-may-have-to-work-for-it/ said:
    Thanks, @Liehjan, your solution worked. My Widevine Level is back to L1, but I'm not sure if it'll stay like that, as the problem manifested itself about a week after updating, so we'll have to wait and see.
    These are the instructions I followed (this didn't wipe any data by the way):

    ▪️ On my computer I downloaded the latest stable build, (currently, from here. It'll be different if you have a different phone; choose the correct one for your phone here.
    ▪️ Then I plugged in my phone to my computer and transferred the .ZIP straight into Internal Storage.
    ▪️Then I went to Settings > System > System Updates > Click the little settings icon on the top right > Local Upgrade.
    ▪️Then I clicked the file shown there, and clicked Install, then when it was done, clicked Reboot.
    ▪️After it rebooted, I checked the Widevine Level with the DRM Info App, and it was back to L1:
    Note: As @pconleynms mentioned, you might also have to clear the storage/cache on Netflix for it to work again as normal. I did not have to clear the cache on Prime Video though, but I did have to enable the Hardware Acceleration feature in Prime Video's settings for it to work again as normal.

    If that doesn't work...or you don't have time to download the update...or the update is lower than your phone's current version, you can try this solution, which worked for me after the problem re-manifested itself about a month and a half later. It sounds ridiculous, but it worked, so 🤷‍♂️.
    Go to settings
    Search for "Screen Calibration"
    Set it to "Natural"
    Search for "Dark Mode"
    Disable Dark Mode
    Clear the cache and storage for Netflix and/or Prime Video, or whatever streaming apps you use
    Open the Play Store
    Tap the user icon in the search bar, then click on Settings > Authentication
    Disable "Biometric authentication"
    Re-enable it...you will probably need to enter your password again
    Power off your device
    Boot to recovery mode by holding the Volume Down and Power buttons at the same time, until a keyboard shows up.
    Enter your password/pin
    Click Wipe Data and Cache (note that this WILL NOT WIPE YOUR PHONE'S DATA, it's just a bad name for a menu)
    After you click that, it should bring you to a menu where you can select "Wipe Cache." Do so.
    It'll ask if you want to reboot, do so.
    Change your Screen Calibration/Dark Mode settings back to their original settings.
    Hopefully the problem should be resolved again.

    Attached Files:

    Last edited: Jul 29, 2021

    P1570586637713, McJader and Liehjan like this.
  5. Brian Cohen
    Honeycomb Jul 28, 2021

    Stickied Post
    Brian Cohen , Jul 28, 2021 :
    Hi, someone on reddit gave this solution and it worked for me.

    What I did was download the full update through Oxygen Updater (2.44 GB) and before installing it I UNINSTALLED the Netflix app (try uninstalling all DRM apps just in case) and THEN I installed the update and got L1 certification back!

    Hope this helps someone.

  6. drmartin
    Moderator Moderator Aug 4, 2021

    Stickied Post
    drmartin , Aug 4, 2021 :
    Please use this thread:

    mad_mak, the_o2 and KluGe like this.
  7. Ash31095
    Donut Aug 13, 2021

    Stickied Post
    Ash31095 , via OnePlus 7 , Aug 13, 2021 :
    Just Update to the latest version..
    After that..
    Clear storage of Netflix and delete it
    Clear Amazon Prime Videos storage and delete it..

    Go to Recovery Mode
    Clear Cache of phone..
    And done

    That's how i fixed it..

    OnePlus service center people doesn't know anything.
    How to fix it or not.

    mihir19agarwal, broyke and Kranthid87 like this.
  8. johnnedel
    Cupcake Sep 5, 2021

    Stickied Post
    johnnedel , via OnePlus 7 Pro , Sep 5, 2021 :
    If you're like me who have been forced to settle for SD resolution on Netflix for several months now, you can stream Netflix in HD by using Rave.

    If you haven't known already, there's this app called Rave, which is basically a watch party app and also supports Netflix. Surprisingly, this app can stream at 1080p max. Only sad thing is that it doesn't fetch/update your watch history and so you won't be able to continue on where you left off.

    I just saw this app yesterday so... yay!

  9. anilkigal
    Ice Cream Sandwich Oct 1, 2020

  10. N1592634344586
    Cupcake Oct 8, 2020

    F_Peter_Florea_udnp likes this.
  11. F_Peter_Florea_udnp , via OnePlus 8 Pro , Oct 8, 2020 :
    i've had this issue twice now. It got fixed after a month's wait. Now it happened again after upgrading to android 11 beta and I hope we wont have to wait a month again. I already posted about this and there has been no update. i wish they could tell us at least why this is happening. It's a ridiculous issue.

    N1592634344586 likes this.
  12. __RAYZAR__
    Gingerbread Oct 8, 2020

    N1592634344586 likes this.
  13. madhavagal
    Eclair Oct 20, 2020

    madhavagal , via OnePlus 8 Pro , Oct 20, 2020 :
    I recently bought a OnePlus 8 pro around a week back. Yesterday I got the oxygen OS 11 upgrade (11.IN11DA). I am happy with the new features but while watching Netflix I found that my phone supports only SD content now. Before the update I was able to watch HD and even HDR content without a problem. I downloaded DRM Info app and saw that the widevine level has been downgraded to level 3. This is a shame because one of the main reasons I bought this phone was to use it's big beautiful display in streaming content. Anyone else facing the same issues? Will there be a fix soon or should I return the phone while I have the time?
    I have attached screenshots from the Netflix app and DRM Info below.


    Nilay17 and antnyhills like this.
  14. Bruno Lugnani
    Ice Cream Sandwich Oct 20, 2020

  15. Swejuggalo
    OnePlus 9 Series Expert Community Expert Oct 20, 2020

  16. madhavagal
    Eclair Oct 20, 2020

  17. madhavagal
    Eclair Oct 20, 2020

    madhavagal , via OnePlus 8 Pro , Oct 20, 2020 :
    I'm not using beta version, I just got the OTA update. I will report it via feedback, thanks for your advice.

  18. Neusso45
    Eclair Oct 20, 2020

  19. madhavagal
    Eclair Oct 20, 2020

  20. Bruno Lugnani
    Ice Cream Sandwich Oct 20, 2020

    Bruno Lugnani , via OnePlus 8 Pro , Oct 20, 2020 :
    Well strange, mine is not rooted and Widevine is L1 with Android 11

  21. madhavagal
    Eclair Oct 20, 2020

    madhavagal , via OnePlus 8 Pro , Oct 20, 2020 :
    Okay I changed the screen calibration to AMOLED wide Gamut and rebooted the phone. This seems to have done the trick and the widevine level is back to L1. Thanks everyone who responded

    Bruno Lugnani and Swejuggalo like this.
  22. Swejuggalo
    OnePlus 9 Series Expert Community Expert Oct 20, 2020

    Swejuggalo , via OnePlus 8 Pro Ultramarine Blue , Oct 20, 2020 :
    And if you change back to whatever you really want it goes back to L3?
    Mine is on Natural. (but since I'm on beta and you stable it could be different....)

  23. madhavagal
    Eclair Oct 20, 2020

    madhavagal , via OnePlus 8 Pro , Oct 20, 2020 :
    No it stays L1. Looks like it was just a bug and rebooting fixed it.

    Swejuggalo likes this.
  24. Doppel11
    Donut Oct 26, 2020

    Doppel11 , Oct 26, 2020 :
    Hi, got the same problem,
    UNIT : OP8pro
    OS : Android 11 - 11.IN11AA

    updated my unit since it was released, netflix fHD was working but suddenly my netflix crash, then tried uninstalling/ re-updates, cleared storage/cache. and then I checked the widevine level and now it's L3.

    base on comments, also tried setting calibration to amoled wide gamut and reboot, still the same - L3.
    my last option is to factory reset. will update soon here.

    Hoping for the devs. to fix this immediately.

  25. Prakash_Bhanushali
    Cupcake Oct 28, 2020

    Prakash_Bhanushali , via OnePlus 8T , Oct 28, 2020 :
    Hi anyone else has this problem in their 8t? I had full hd support n widevine l1 when I bought 8t.Today I checked and it only shows l3 and SD capabilities.
    Did they downgraded it in 330mb patch when they sent? Help please.

    V218 and Y1602937040480 like this.
  26. Jaffaruchiha
    Cupcake Oct 31, 2020

  27. Jaffaruchiha
    Cupcake Oct 31, 2020

    Jaffaruchiha , via OnePlus 8T , Oct 31, 2020 :
    I tried this. Didn't help. It is still showing L3.
    View attachment 1476388