2
[UNIFIED] WiFi calling for Oneplus devices

  1. j c shivaprasad
    Donut Dec 11, 2020


  2. pablofg1978
    Nougat Head Moderator Dec 11, 2020

    pablofg1978 , Dec 11, 2020 :
    Thread merged
     

  3. drfumes
    Donut Dec 12, 2020

    drfumes , via OnePlus 8T , Dec 12, 2020 :
    Funny how your sending me to support & support now sending me back here!

    if OnePlus doesn't have the answer, they need to admit z rather than playing ping pong.

    Think I'll switch over to Samsung; rather than having to deal with this idiosyncrasy with OnePlus & their rather 'special' support team.
     

  4. Deniskurian
    Donut Dec 15, 2020

    Deniskurian , via OnePlus 8 Pro , Dec 15, 2020 :
    I'm being trying to get my wifi calling disabled, but it seems to be greyed out. I had contacted customer service of my network provider, that is , T-Mobile, but they do not have the settings.. The issue I have with having my WiFi calling"greyed ON" is my calls either go straight to voicemail or I can not hear the caller, even thou they can hear me.. I've tested this issue with having wifi oN, with calls from my other phone, to narrow the reason of calls going straight to voicemail, or caller can not hear..

    also, when my wifi is disabled, I have a vo LTE logo.. is this the reason why my internet is slow, and always have to restart my phone to get the internet going..


    1608056536901.jpg
     

  5. pablofg1978
    Nougat Head Moderator Dec 15, 2020

    pablofg1978 , Dec 15, 2020 :
    Thread merged
     

  6. H1608548981694
    Cupcake Dec 21, 2020

    H1608548981694 , Dec 21, 2020 :
    I also have same problem: I do not possibility to enable Wi-Fi Calling. I so so disappointed.

    I'm in Romania and I'm using Vodafone Romania. I have an Oneplus 7T phone.

    Is it any way to enable this? I love spec of all Oneplus but if they do not manage to make deals with carriers it is a big problem.
     

  7. G_Kieran_Hansford_fzWi
    Cupcake Dec 21, 2020

    G_Kieran_Hansford_fzWi , Dec 21, 2020 :
    As the title says, every time I'm on a call using VoWiFi (which I use because mobile signal isn't good in my apartment) the call ALWAYS silently drops out after exactly 2m 35s. (Silently as in I regularly continue talking before realising the call is no longer running). I have a great WIFI signal. Are there any fixes for this? Any help please?
     

    YehudaRosenthal likes this.
  8. Tokolozi
    Most Original Avatar Dec 21, 2020

    Tokolozi , Dec 21, 2020 :
    It could be that it's dropped carrier side. Did you try with other devices or contacting your provider as well?
     

  9. pavickers
    Cupcake Dec 23, 2020

    pavickers , Dec 23, 2020 :
    My network provider supports this feature but I can't see how to enable it. My network at home is extremely poor on Virgin mobile so need to get this working through my broadband provider. I managed to get this working on my previous oneplus(5) but when I get into the logkit menu I can't see where to enable the wifi calling feature. Any help will be apricated. TIA
     

  10. Shailender Sharma
    Lollipop Dec 23, 2020

    Shailender Sharma , Dec 23, 2020 :
    Settings.
    Tap Wi-Fi & internet -SIM and Network - Tap Sim 1 - Enhanced Communications - Enable Wi-Fi Calling
    Also tap Calling preferences - Enable Call over Wi-fi
     

    Tokolozi likes this.
  11. pavickers
    Cupcake Dec 23, 2020

    pavickers , Dec 23, 2020 :
    Nope, no Enhanced communications in my sub system. I've looked everywhere for enable calls over WiFi, I had to go into a root system on my Oneplus 5 to enable this function, is there a way to do it on the 8T?
     

  12. Ganymede25
    Gingerbread Dec 23, 2020


  13. G_Mr_....
    Jelly Bean Dec 23, 2020


  14. pablofg1978
    Nougat Head Moderator Dec 23, 2020

    pablofg1978 , Dec 23, 2020 :
    Thread merged
     

  15. G_Alan_Wilson_VElP
    Cupcake Dec 24, 2020


  16. M1575948781999
    Cupcake Dec 24, 2020

    M1575948781999 , Dec 24, 2020 :
    I have no settings in my phone and have tried with OnePlus with no help ...... how do I get wifi calling to work on my Oneplus 7 Pro with AT&T? I have tried several "solutions" on Youtube but I never find any of the settings on my phone to deal with wifi calling.
     

  17. Vansh99
    OnePlus Accessory Tester Dec 24, 2020


    pablofg1978 likes this.
  18. pablofg1978
    Nougat Head Moderator Dec 24, 2020

    pablofg1978 , Dec 24, 2020 :
    thread merged
     

  19. sqidinc
    Cupcake Dec 26, 2020