5
Network/Connectivity Unstable 4G (LTE) or lack of thereof on Rogers (Ontario, Canada) - solution

  1. name777
    Donut Nov 28, 2016

    name777 , Nov 28, 2016 :
    If you're like me, switching from good old Nexus 5 to OnePlus 3t, you may run into the situation when you'll be unpleasantly surprised by the quality of data reception. The phone stays in H+ where Nexus 5 used to give you stable LTE, sometimes it switches to 3G icon, etc. Don't fret - there is a solution:

    1. When the phone says "4G" - you're good. 4G is LTE.
    2. Make sure that Settings > SIM & Network > Preferred Network Type is set to 2G/3G/4G (automatic).
    3. Go to Settings > SIM & Network > SIM 1 (ROGERS) > APNs. You'll see a bunch of APNs available, and by default the phone will be connected to Rogers. Switch to Rogers LTE (ltemobile.apn).
    4. Go to Settings > SIM & Network > SIM 1 (ROGERS) > Network Operators. You'll see a warning about temporary disconnection of your data. Hit OK. After a minute or so you'll see the list of available in your area operators. Choose ROGERS 4G (not Rogers Wireless 3G or Rogers Wireless 2G).
    5. Go to fast.com and check now. I'm getting my 40Mbit/s in areas with full signal meter and 15Mbit/s in an area where signal meter is only 2 bars.
     

    #1
    evtooms, Lyheather, Henninge and 2 others like this.
  2. jfrancois.pilon
    Cupcake Nov 28, 2016


    #2
  3. Henninge
    Eclair Nov 28, 2016

    Henninge , Nov 28, 2016 :
    Thanks for that tip - way better speeds now! Couple of things....

    Will this still default to the other standards when we choose the Rogers 4G operator on Sim 1? And what about SIM 2, which would be the best settings for that?

    Im thinking for Sim 2 this would be correct:
    APN Rogers (rogers-core-app1.apn) and then Network Operator Rogers 3G.

    let me know it he APN should be Rogers LTE on that 2nd Sim - thanks in advance!
     
    Last edited: Nov 28, 2016

    #3
  4. name777
    Donut Nov 29, 2016

    name777 , Nov 29, 2016 :
    As much as I would like to answer, you're going to have to try it yourself. I had no intention to use both SIM cards, so I won't be able to try it myself in the near future.
     

    #4
  5. G_Bing_Wu_FZgh
    Cupcake Nov 29, 2016

    G_Bing_Wu_FZgh , Nov 29, 2016 :
    The settings work for me in Roger's LTE, only label as 4G, 34Mbps down, 27Mbps up in more than 75% signal strength area.
     

    #5
  6. Lyheather
    Cupcake Dec 1, 2016

    Lyheather , Dec 1, 2016 :
    I'm having this same issue with my 3T. I have just done what you've recommended so hopefully this will fix the problem. I switched from the One and had no problems with cell service on my One. What Mbps is considered 'LTE' speed?
     

    #6
  7. evtooms
    Cupcake Dec 7, 2016


    #7
  8. Synaptx
    Cupcake Dec 23, 2016

    Synaptx , Dec 23, 2016 :
    This is great! I wish i saw this earlier when I got my phone!

    Since you guys here are Rogers users, do you have any problems with SMS or muting of your microphone during calls (after a 10-15 minutes of talk time in the call)?
     

    #8
  9. RizzH
    Cupcake Dec 23, 2016

    RizzH , Dec 23, 2016 :
    Hi Guys , I just received my 3T but FIDO sim in not getting LTE only 4G or 4G+ I read 4G+ is LTE but I use to have oneplus 1 and was able to get LTE no problem . plus I am notable to see VOLTE my S7 EDGE had no issue connecting with LTE or VOLTE. my APN is fine ltemobile.apn. so far I am not to please with this phone just wondering if you guys have same issue or just my phone .any help is great.
    Thanks
     

    #9
  10. name777
    Donut Dec 23, 2016

    name777 , Dec 23, 2016 :
    4G is LTE. The icon you see on the screen is just an icon - it may vary from one OS to another or even from one version of OS to another (exactly your example - comparing 1+1 and 1+3t). It doesn't change the fact that you are on LTE.
    I don't know about Fido, but VOLTE is not open on Rogers for everyone. Only for the phones they sell. I hope that will change soon, since they are shutting down Rogers One Number in a week.
     

    #10
    RizzH likes this.