Guide [UPDATED :- 28/06/2016] Mega Unbrick Guide for A Hard Bricked OnePlus 2

  1. doveoscar
    Froyo Mar 3, 2016

    doveoscar , Mar 3, 2016 :

  2. doveoscar
    Froyo Mar 3, 2016

    doveoscar , Mar 3, 2016 :
    Many,many thanks, you've saved my phone twice. I installed TWRP 2.87 on an encrypted OPT and it appeared completely dead. Method 1 revived it but it came to life with all its data still intact and more oddly yet with TWRP still present. The only peculiarity is that afterwards factory reset does not work, after entering the PIN nothing happened.

    Recently I decided to try and replace TWRP 2.87, which was completely useless as it can't read the encrypted storage, with TWRP 3. Refused to flash, fastboot just said device not unlocked (it was, though) so used adb to relock, intending to unlock again. Mistake. The locked phone was immediately in a boot loop. I could turn it off or get to fastboot, but I couldn't do anything else and adb could not see the phone. Every time I powered up or plugged in a charger, boot loop. Method 1 worked again, again the data was still intact but this time TWRP has gone and the phone has gone back to stock recovery.

    When I feel stronger I will try factory reset in the hope I can get rid of encryption - more trouble than it's worth. All I wanted to do was root my phone.

    dilo00o likes this.
  3. Metamist
    Donut Mar 4, 2016

    Metamist , Mar 4, 2016 :
    I've been sitting here for a couple of hours trying to unbrick my phone after a very stupid mistake I did, but the issue I had, like some others, was that Windows detected it as "Relink HS-USB QDloader 9008" which MSMDownloadTool could not detect. I saw someone suggest forcing it to qualcomm, but I couldn't get it to do that.

    So, instead, since my stationary computer did not recognize it properly, I tried with my laptop. To my surprise, it actually detected it as QHSUSB_BULK. I restarted the computer and turned off driver signature enforcement, installed the driver and finally, it was detected as QUALCOMM-HS USB Diagnostics 9008 which MSMDownloadTool could detect.
    After that it worked smoothly and phone successfully unbricked.

    I want to thank OP for this thread and all the effort he has put down to help people out, with TeamViewer and everything. I really appreciate people like OP that does this in their free time. So again, thank you for being awesome, OP!
    Last edited: Mar 4, 2016

    Tyco_ likes this.
  4. atlac
    Cupcake Mar 6, 2016

    atlac , Mar 6, 2016 :
    Hi, OP can add one more method for identification of phone drivers. All three methods did not work for me. They are showing my phone as "...........900E" instead of "9006 or "9008". Hence no method is able to work.
    I finally got it worked with the method given in "https://forums.oneplus.net/threads/fix-qhsusb_bulk-bricks-on-the-op2.409644/". After following this method my device was able to unbrik. Hope this will help for somebody for whom all the three methods given in OP fails.

  5. santiago67
    Froyo Mar 6, 2016

    gopinathr likes this.
  6. santiago67
    Froyo Mar 6, 2016

    santiago67 , Mar 6, 2016 :

    gopinathr likes this.
  7. salehsm2
    Cupcake Mar 7, 2016

    salehsm2 , Mar 7, 2016 :
    Hey me too my op2 stuck in fastboot mode it doesn't open bootloader and no recovery , i triyed everthing i connected it to the pc and have updated the drive but the mm-download-tool is not working with me ..! !! please help !

  8. gopinathr
    Honeycomb Mar 7, 2016

  9. gopinathr
    Honeycomb Mar 7, 2016

  10. gopinathr
    Honeycomb Mar 8, 2016

    gopinathr , Mar 8, 2016 :
    My PC recognises the OP2 device, "Qualcomm HS-USB Diagnostics 900E (COM3). But when I click "Start" in MSM8994DownloadTool.exe tool, i see some 8 rows, but it do not progress. I tried in another two PCs, I see 14 rows and i got 41 rows.

    But it do not see the green progress bar. Still i am unable to unbrick. Any suggestions please. Am stuck

    Attached Files:

  11. gopinathr
    Honeycomb Mar 8, 2016

    gopinathr , Mar 8, 2016 :
    dynamic_nvbk.bin: OK
    emmc_appsboot.mbn: OK
    gpt_backup0.bin: OK
    gpt_main0.bin: OK
    userdata.img: FAILED open or read
    userdata_64G.img: FAILED open or read
    rawprogram0.xml: FAILED
    rawprogram0_64G.xml: FAILED
    NON-HLOS.bin: OK
    rpm.mbn: OK
    sbl1.mbn: OK
    sdi.mbn: OK
    static_nvbk.bin: OK
    tz.mbn: OK
    boot.img: FAILED open or read
    cache.img: FAILED open or read
    persist.img: OK
    recovery.img: FAILED
    system.img: FAILED open or read

    After waiting, nothing happens. When I click exit, this is what I get :(

  12. rahulnegi1409
    Eclair Mar 8, 2016

    rahulnegi1409 , Mar 8, 2016 :

    after the green texts my phone went into boot loop .
    continuously .
    tried all 3 methods

  13. gopinathr
    Honeycomb Mar 8, 2016

    gopinathr , Mar 8, 2016 :
    Unfortunately, no method worked. Thanks for the suggestions. Tried for almost three days now.

    My OP2 is just 2 month old. Will the warranty cover me for soft bricked device?

  14. rahulnegi1409
    Eclair Mar 9, 2016

    rahulnegi1409 , Mar 9, 2016 :
    Ok working now , 2nd 3rd not working for me . and No data Loss for 1st Method

    in first method when you see green text's then your phone will reboot (might be in boot loop )vol - and Power button keep holding it .You will get a Chinese recovery , called H2OS recovery .
    Use it to flash signed ROM's by pushing via sideload then wipe data and cache in advance and then It will flash the ROM and then phone will Boot Up , do OEM unlock in Dev mode then unlock bootloader (data wont wipe off , /data/sdcard wont be formatted ,99.99% sure.)
    then if your have nandroid just unlock bootloader and flash your respective recovery and then restore all things .

    also make sure when flashing custom rom in 6.0 :-
    READ THIS !!!!!!!!!!!!!!!!
    Disable the lockscreen's lock options eg :- swipe , pattern , code . Just set it to none and do OEM unlock in dev option (to be on safe side).
    There is a security feature in 6.0 that if lockscreen options are enabled and you flash custom zips via custom recovery , your boot loader will get "RELOCKED"

    Thanks .

    gopinathr likes this.
  15. gopinathr
    Honeycomb Mar 10, 2016

    gopinathr , Mar 10, 2016 :
    at last, third method worked for me. But my media files are still inside. :)
    IIt looked like it is frozen for sometime. but left it as is. after sometime, clicked on the right most button. it said ok in green :))))))

    Entered "fastboot continue"

    But my recovery is still tampered..

    I removed the security option and unlocked from dev option too. But i couldn't flash a new twrp recovery.

    C:\Android>fastboot flash recovery C:\Android\twrp-3.0.0-oneplus2-regalstreak.im
    target reported max download size of 536870912 bytes
    sending 'recovery' (30356 KB)...
    OKAY [ 0.693s]
    writing 'recovery'...
    FAILED (remote: device is locked. Cannot flash images)
    finished. total time: 0.717s

    Any suggestions.....?

    Edit: fixed :)
    Last edited: Mar 10, 2016

  16. gopinathr
    Honeycomb Mar 10, 2016

    gopinathr , Mar 10, 2016 :
    third method worked for me. use some other system. it will look like, it is not working. but after sometime. go to fastboot mode and type fastboot continue.
    worked for me after 10-12 hours of work

  17. gopinathr
    Honeycomb Mar 10, 2016

    gopinathr , Mar 10, 2016 :
    third method worked for me. use some other system. it will look like, it is not working. but after sometime. go to fastboot mode and type fastboot continue.
    Last edited: Mar 10, 2016

  18. BadFlyOne
    Cupcake Mar 11, 2016

    BadFlyOne , Mar 11, 2016 :
    Hi guys! I have the same problem as some persons. My OPT is bricked : No recovery, fastboot or rom ..
    I tried on win 7, win 10, win XP , 64 bit 32 bit, everything with the drive of Qualcomm and the A2001_14_A.03_150805 tool .. The tool copy the file but the OPT doesn't react. Someone can help me ?

  19. captsakis
    Gingerbread Mar 11, 2016

  20. gopinathr
    Honeycomb Mar 11, 2016

    gopinathr , Mar 11, 2016 :
    https://forums.oneplus.net/threads/mega-unbrick-guide-for-a-hard-bricked-oneplus-2.347607/ Third method worked for me. There is a small folder QHSUSB_BULK, and run dpinst.exe which is inside that. and run OnePlus_USB_Drivers_Setup.exe. This fixed my issue and the tool worked like a charm. ping me through hangouts if you have any doubts.