204
Guide [UPDATED :- 28/06/2016] Mega Unbrick Guide for A Hard Bricked OnePlus 2

  1. anandsabne
    Cupcake May 17, 2016

    anandsabne , May 17, 2016 :
    I tried 1st method, but unlike you said, in the device manager, I see my device as 'RELINK HS-USB QDLoader 9008 (COM 9)'. When I try to update the drivers as you said from qc folder, it says that the drivers are already installed but the name of device remains as it is. And then MSM also doesn't work.
    Please help me Bhai:disappointed:. I got frustrated. All this happened because of Unofficial CM 13. :(
     

  2. anirax
    Cupcake May 17, 2016

    anirax , May 17, 2016 :
    can someone help me with this my opo keeps inifitly rebooting itself and i have no clue what to do
     

  3. Gaurav Rohilla
    Lollipop May 17, 2016

    Gaurav Rohilla , May 17, 2016 :
    q1.PNG
    q2.PNG
    q3.PNG
    q4.PNG
    q5.PNG
     

    AidanGee likes this.
  4. lordofmud
    Eclair May 17, 2016


  5. Gaurav Rohilla
    Lollipop May 17, 2016

    Gaurav Rohilla , May 17, 2016 :
    update the drivers as told. also, I think your case may not need this hard brick guide.
     

    lordofmud likes this.
  6. Gaurav Rohilla
    Lollipop May 17, 2016

    Gaurav Rohilla , May 17, 2016 :
    full wipe via recovery. if this doesn't solve your issue, start a conversation with me.
     

  7. lordofmud
    Eclair May 17, 2016

    lordofmud , May 17, 2016 :
    Never mind thanks for the help anyway:)
    Followed this guide and finally got my phone working without any problem:cool:
    Now way to custom roms :p
     

    AidanGee and Gaurav Rohilla like this.
  8. fredrikskjei
    Eclair May 17, 2016

    fredrikskjei , May 17, 2016 :
    how did you manage it? i have same error as you i think... i got the 900E qualcom and the recovery tool doesn't work. nothing happend when i start it
     

  9. stefanop2
    Cupcake May 18, 2016


  10. Gaurav Rohilla
    Lollipop May 18, 2016

    Gaurav Rohilla , May 18, 2016 :
    disable driver signature enforcement. Start a conversation with me for any more help.
     

  11. Gaurav Rohilla
    Lollipop May 18, 2016

    Gaurav Rohilla , May 18, 2016 :
    also, keep it disconnecting and reconnecting back and forth for about 4-6 trails(volume up method). it might come up as 9008 if the drivers are installed correctly. start a conversation with me for more help.
     

  12. farzan2
    Cupcake May 18, 2016

    farzan2 , May 18, 2016 :
    Hi there. I get an error of "driver is not intended for this platform" when trying to do this. I've downloaded the drivers but windows will not let me install them for that reason. I have a OP2 A2003. Please help
     

  13. shaktishekhar
    Donut May 20, 2016

    shaktishekhar , May 20, 2016 :

    Unbrick Using QCOM Download Tool In English Translated by Me ;) Link https://docs.google.com/uc?id=0B_qkJGXx6zg-LVJScEx6bVppeDg&export=download

    [​IMG]
    Enjoy
     

    Gaurav Rohilla and AidanGee like this.
  14. Cyril James
    Cupcake May 20, 2016

    Cyril James , May 20, 2016 :
    hey try replacing the recovery.img with the official recovery form Oneplus Download Oxygen Recovey (Optional) << hit the link and it will download... rename the file to just "recovery.img" and replace it with the recovery in .../A2001_save_brick_mini before u start MSM8994DownloadTool.exe as admin! and ur good to go...
     

  15. Deactivated User
    May 21, 2016


  16. gamsurslick
    Honeycomb May 22, 2016

    gamsurslick , May 22, 2016 :
    Thanks a lot for this guide! It saved me.
    I tried the first method at first but it didn't work so I went over to the third method and it worked right away.
     

  17. yuva_cool
    Gingerbread May 22, 2016

    yuva_cool , May 22, 2016 :
    Shows up as Diagnostics 900E (COM3) and MSM file dsnt start the process
    tried many drivers. none worked
     

  18. Naman Bhalla
    Recognized developer Recognized Developer May 22, 2016

    Naman Bhalla , May 22, 2016 :
    Select 9008 manually from list of devices in the driver
     

  19. Mikavski
    Cupcake May 23, 2016

    Mikavski , May 23, 2016 :
    i had similar problem. (Latest TWRP and OOS 3.0 beta and then i lost recovery) i got it back running Oneplus 2 firstaid, but now i have access to fastboot and recovery which is official TWRP 3.0.2 but i dont have OS or any other ROM. in some point i did this: Oxygen OS 2.2.0: OnePlus2Oxygen_14_OTA_011_all_1512111634_fastboot. zip but it didn´t help..if i remember right, all what it did was Stock recovery and i didnt find any flashable zips etc. been struggling with this almost 2 days, followed all kinds of tutorials and run bunch of softwares etc and i still dont have OS :/
     

  20. Mikavski
    Cupcake May 23, 2016

    Mikavski , May 23, 2016 :

    Wow! cheers buddy. it took 2 days, dozens of tutorials and useless softwares and drivers, but your Method 1 nailed it. now OPT is back online :)
     

    Naman Bhalla likes this.