202
Guide [UPDATED :- 28/06/2016] Mega Unbrick Guide for A Hard Bricked OnePlus 2

  1. sourabhkumra253
    Cupcake Nov 25, 2016


  2. Jitesh Saitawadekar
    KitKat Nov 25, 2016

    Jitesh Saitawadekar , Nov 25, 2016 :
    Assuming that you are with TWRP and fastboot working try the first method of this thread or try flashing OOS again if it's in your internal storage and revert back.
     

  3. F_Rafael_Morais_fNVQ
    Cupcake Nov 28, 2016

    F_Rafael_Morais_fNVQ , Nov 28, 2016 :
    I guess i have a different problem then everyone else or im too stupid. i'll describe my problem.

    When i press power button my phones goes to Cyanogen logo forever. When i press Vol Up or Vol Down + Power button my phones goes to Cyanogen logo forever.

    When i plug it to my laptop, it is recognized as "MTP Device", when i try one of above options it is recognized as ADB Interface.

    If i try to access it by ADB devices on cmd, it says [my dispositive] unauthorized.

    I tried to unbrick it by Qualcomm HS-USB Qdloader 9008 driver, but never toast any qualcomm or any COM connection on my Device manager, so i cant even proceed to use Color OS...

    Im tired of searching, and get nothing positive.
     

    Praty_28 likes this.
  4. Majaiga
    Cupcake Nov 28, 2016

    Majaiga , Nov 28, 2016 :
    Hi Naman, thank you so much for the guide- it's the best I found.
    I've tried your method 1 and method 2 yet still after following all steps all I can see is the Flashboot Mode and no further options. Could you help please?
     

  5. abose08
    Cupcake Dec 1, 2016

    abose08 , Dec 1, 2016 :
    im stuck in the twrp with no rom to flash...dunno what to do ...im stuck there... is there a way to flash rom on my phone whil there's no stock rom file present in the phone to flash with ? please help me out guys
     

  6. farzan2
    Cupcake Dec 2, 2016

    farzan2 , Dec 2, 2016 :
    Hi
    I have bricked and unbricked my phone using method 1 before, but this time, everything seems a bit different. My phone says that it needs to be charged, whilst continuously rebooting to the android logo. Once, plugging it in to my laptop and pressing up and down for a while made it work, but it was on 0% battery (as the laptop does not provide enough charge) so when i unplugged it it stopped working again. This makes me think there is a way without reflashing the stock ROM, but i'm unsure. Any help is greatly appreciated.
     

  7. ABzU93
    Cupcake Dec 5, 2016

    ABzU93 , Dec 5, 2016 :
    @Naman Bhalla
    Hi, I was trying to root my OP2 and got everything working correctly. OEM unlocked, installed custom (TWRP) recovery, factory reset my phone, downloaded and installed OxygenOS 3.1.0 from OP support. Uptil these steps, the phone boots up fine. But after I install SuperSU package, the boot gets stuck on Red and White dots animation. Can I get some help?
     

  8. MOSHE TVITO
    Eclair Dec 5, 2016

    MOSHE TVITO , Dec 5, 2016 :
    Thank you friend
    You saved my smart phone
    I use you post of
    Unbrick oneplustwo
    and it was very helpfull
    Again thanks
     

  9. vivek.rijal
    Donut Dec 8, 2016

    vivek.rijal , Dec 8, 2016 :
    Hi @Naman Bhalla ! I tried your procedure. But the problem is I do not have an installed ROM nor do I have the recovery currently and stupidly I ended up locking my bootloader. So now even if I do this procedure I'm not able to flash and bot into the recovery and then again flash the ROM. Do you have any other way to go around this process? Can I somehow remotely unlock the bootloader in fastmode?
     

  10. chandulal
    Froyo Dec 9, 2016

    chandulal , Dec 9, 2016 :
    my one plus two is only showing boot logo. which method is suitable for me
     

  11. jainish270582
    Cupcake Dec 11, 2016

    jainish270582 , Dec 11, 2016 :
    hii sir, @Naman Bhalla i have done every thing perfect but phone boots up in every 0.2sec!! why?and any guideline for for upcoming steps .. i have followed step 1 ,,ditto to ditto every thing is perfect ..but phone run into continuous boot loop(0.2sec )too fast .
    waiting for ur replay,
    thx adv,4
     

  12. shashankgowdad
    Cupcake Dec 14, 2016

    shashankgowdad , Dec 14, 2016 :
    I followed your guide in one plus forum to unbrick OP2 and successfully booted my device.

    But after booting my IMEI number was gone and no signal detection in sim slots.


    I ran

    Fastboot erase modemst1.bin

    Fastboot erase modemst2.bin

    Fastboot erase persist


    And this gave imei on sim slot 1 but still sim slot 2 is not detecting and imei is 0 for slot 2.



    Could you please guide me regarding this ASAP , iam not using my phone for past 2 weeks


    Thanks in advance. J
     

  13. error123404
    Honeycomb Dec 15, 2016

    error123404 , Dec 15, 2016 :
    plz plz help i just used meathod 1 and now there is no wifi available ,no cellular signal ,and i am not able to compleate setup the device
    @namanbhalla @@Naman Bhalla @Naman Bhalla
     

  14. manishsalian16
    Cupcake Dec 17, 2016

    manishsalian16 , Dec 17, 2016 :
    My oneplus two isn't booting up it shows the bootlogo n then the screen turns black...the only thing i can acess is the fastboot mode.. tried method 1 it completes sucessfully but dosent booot into recovery...the bootloader is locked when tried to unlock it say oem unlock disabled....can someone please help me to get my phone back to life
     
    Last edited: Dec 17, 2016

  15. rohitn6a
    Cupcake Dec 17, 2016

    rohitn6a , Dec 17, 2016 :
    hi @Naman Bhalla .today morning while wiping the cache I deleted the system also .I am using twrp 3 and marshmallow .Since then I am stuck with bootloop because there is no OS .ADB is also not working it shows unauthorised fastboot mode is working .I tried your method 1 and was able to install the driver qualcomm but then i ran the MSM8994 but nothing is happening Please help me as I dont know how to proceed now
     

  16. nipunx1999
    Froyo Dec 17, 2016


  17. rohitn6a
    Cupcake Dec 17, 2016

    rohitn6a , Dec 17, 2016 :
    Hi..when I run the download tool it does not download but com line becomes red ..also Under port and com i got relink qshub rather than qualcomm then updated the driver software to qualcomm and it is showing also qualcomm but then that download tool is not installing anything.Please help me I am in great mess
     

  18. rohitn6a
    Cupcake Dec 17, 2016

    rohitn6a , Dec 17, 2016 :

    I am also stuck on same screen it turns red ..what different you did
     

  19. subaash
    Gingerbread Dec 19, 2016

    subaash , Dec 19, 2016 :
    I've completed the steps using method 3 and in the end it booted yet my sim card is not detected and no wifi detected either. What should i do i can't go pass the Name setup.
     

  20. Jitesh Saitawadekar
    KitKat Dec 19, 2016

    Jitesh Saitawadekar , Dec 19, 2016 :
    Did you flashed h2os?