202
Guide [UPDATED :- 28/06/2016] Mega Unbrick Guide for A Hard Bricked OnePlus 2

  1. subaash
    Gingerbread Dec 20, 2016

    subaash , Dec 20, 2016 :
    i did flash h20s even after this problem occured and even in h20s i still have the same problem..
     

  2. nithinjadhav
    Cupcake Dec 20, 2016

    nithinjadhav , Dec 20, 2016 :
    Thank you so much, this saved my phone.

    I bricked my phone, it was stuck in installing OS. Searched all across and was finally able to bring it to life using this guide.

    Method 3 worked. for me.

    But the problem is, now the SIM cards are not detecting.
     
    Last edited: Dec 20, 2016

  3. paelscrit
    Cupcake Dec 20, 2016

    paelscrit , Dec 20, 2016 :
    Awesome, thanks a lot. Method 2 worked for me. Everything seems okay and I was able to OTA update.

    Edit: Hope my GPS stops cutting out now.
     

  4. _unearth
    Cupcake Dec 20, 2016

    _unearth , Dec 20, 2016 :
    i
    i bricked my op2 and i try all method, but it still bootloop. otherwise, if i manage to bypass bootloop, there is no sim detected or wifi. maybe software or hardware problem ? can you help me ?
     

  5. F_Fabian_Robinson_eJqa
    Cupcake Dec 22, 2016

    F_Fabian_Robinson_eJqa , Dec 22, 2016 :
    I flashed the A2001 Software on my A2005 phone (did not know at the time) and some Chinese software got installed, ever since then I've lost the IMEI, wifi mac and Baseband. I currently have 5.1.1 (Oxygen 2.1.1) installed but i'm getting a heavy battery drain issue. When I try to install the latest OxygenOS 3.1.0 I get bootloops every 3-5 mins. I'm also unable to flash twrp recovery even though the bootloader is unlocked.

    C:\adb>fastboot flash recovery recovery.img
    target reported max download size of 536870912 bytes
    sending 'recovery' (19348 KB)...
    OKAY [ 0.444s]
    writing 'recovery'...
    OKAY [ 0.164s]
    finished. total time: 0.610s

    (Is it me or did it flash too fast which would indicate that it did not flash?)

    When trying to accessing custom recovery it would just freeze on the 1+ logo. I would then reboot the phone to the OS, reboot into recovery again and the stock recovery shows up. I've also tried HybridRecovery v3.4.
    I've used a different version of A2001 to restore my phone when it got bricked a few months ago and it was fine. This is just awful, I did not know or recalled nothing that stated that it was the Chinese OS and that it's not recomended on the A2005, or it was fine but I just got dumb unlucky.

    I also just noticed that when i try to charge my phone completely off, it turns itself on and off again(does not load OS) every 10 seconds and sometimes it will give me a voltage error using the stock usb cable and anker charger.
     

  6. 01234567890
    Cupcake Dec 23, 2016

  7. raj378
    Cupcake Dec 23, 2016

    raj378 , Dec 23, 2016 :
     

  8. raj378
    Cupcake Dec 23, 2016

    raj378 , Dec 23, 2016 :
    please help me with my one plus two which is hard bricked
    i followed the steps u mentioned in the mega unbrick guide for unbricking...but somewhere it went wrong
    the process i followed is....
    at first i pressed vol up and connected usb... then it shows qualcomm device and then i updated the driver as u said in the guide..and it updated ..and showed there like qualcomm9008
    then i had run the msm tool as administrator..
    it worked fine ... greeen text appeared...then in my phone oneplus logo appeared and stuck there.
    then i switched off the phone forcedly and pressed vol down +power and it entered stock recovery mode..
    mean while after switching off the phone ...in the device manager...the qualcomm 9008 disappeared and another unknown device showing as android which needs troubleshooting.
    i even tried to update those drivers but it didnt found any drivers from online
    so i left it
    then i entered into phones recovery and clicked english language
    then i clicked install from usb
    then opened command prompt in the folder where my original file of oxygen os which i downloaded from the link given by you is located...then adb sideload filename.zip
    it says error : cant find the device.
    thats it!
    nothing more...i tried this process several times..every time msm tool works fine but in sideload mode it says error cant find the device
    can u say me where the process is wrong?
    is it normal that the device qualcom9008 will be disappeared after i entering into recovery mode?
    if it is normal...then where did i do wrong
    if its not normal... then what to do.. please reply a fine solution to me
    ....for information...i am using windows7... and i didnt turned on the usb debugging before unbricking..also boot loader is not unlocked.
    i would be very thankful to u..please reply me the solution
    i am trying to unbrick my phone since 2 days:(
     

  9. Nirmal Ashwinsarrathi
    Gingerbread Dec 29, 2016

    Attached Files:

    • c1.PNG
      c1.PNG
      File size:
      115 KB
      Views:
      68
    • c2.PNG
      c2.PNG
      File size:
      80.1 KB
      Views:
      71

    G_hitham_salim likes this.
  10. G_hitham_salim
    Cupcake Jan 7, 2017

    G_hitham_salim , Jan 7, 2017 :
     
    Last edited: Jan 7, 2017

  11. G_hitham_salim
    Cupcake Jan 7, 2017

    G_hitham_salim , Jan 7, 2017 :
    I think you forget to disable driver signature < but look, follow the steps step by step and you will got your Qualcomm 9008 driver

    go to How to Make the device show as Qualcomm 9008 in the same boost

    good luck,
     

  12. G.B.S.
    Gingerbread Jan 8, 2017

    G.B.S. , Jan 8, 2017 :
    I have a really big problem.
    Can enter TWRP - but I cant copy CM13 and Gapps to flash!
    I earlier have CM13 and make a unlocking bootloader once again.

    please help! how to copy Last version of CM13 to internal storage and flash.
     

  13. TILAK92
    Gingerbread Jan 11, 2017

    TILAK92 , Jan 11, 2017 :
    Hey Naman can you make unbrick method that will clean install OxygenOS 3.5.6 please try to make it asap
     

  14. nirajmopari
    Gingerbread Jan 13, 2017

    nirajmopari , Jan 13, 2017 :




    how much time it take to complete STEP 8?
     

  15. SuperHure
    Cupcake Jan 15, 2017

    SuperHure , Jan 15, 2017 :
    Ok, so i tried all what was said in this guide, but it seems i'm stuck when it comes to use adb sideload. I tried all version of OxygenOS, but all i get is "adb sideload total xfer 0.00x" on my Windows 10 command prompt, and "installation failed" on my phone.

    I don't know why this occurs, but i have other things that doesn't follow "exactly" the guide
    • My device is named "Qualcomm HS USB 9008" instead of Qualcomm 9008.
    • When i run MSM Download Tool as administrator, the text goes green as it should do, but the phone reboot by itself and when i click on the big button on the upper right corner of MSM Download Tool, i have a big red "failed".

    Before following this guide my phone was soft bricked with only fastboot, and i could boot the phone with the command "fastboot continue". Now i have access to both fastboot and recovery but "fastboot continue" don't boot the phone anymore.

    EDIT: Ok for some reason now the adb sideload works. Still waiting if the whole system will load.

    EDIT2: Ok nevermind, it worked after like 5 or 6 tries. Thanks a lot for this guide :)
     
    Last edited: Jan 15, 2017

  16. sakyb
    Cupcake Jan 19, 2017

    sakyb , Jan 19, 2017 :
    can someone help me please
    i have an OPT stuck on boot logo. The phone is fully stock, bootloader is locked and has stock recovery.
    I can access fastboot mode and stock recovery, i'm sideloading the OTA zip
    I have tried my best to follow this guide but get stuck on step 14 i get an error message adb failed to read argument invalid command.

    I think if I can somehow unlock boot loader I should be able to get the phone up and running.

    Am I doing something wrong?
     

  17. superrajj
    Eclair Jan 20, 2017

    superrajj , Jan 20, 2017 :
    Hello @Naman Bhalla ,

    First of all, a big thanks for this thread. It's a life saver! Next, I downgraded to OOS 2.2.1 from OOS 3.5.6 and then flashed SuperSU and the modified H2OS modem to enable VoLTE. Almost everything is OK except for Settings > Security. When I go to Settings > Security, the settings crashes and exits. Could you or anybody around who faced the same thing help me on this?

    Thanks.
     

  18. superrajj
    Eclair Jan 20, 2017

    superrajj , Jan 20, 2017 :
    Hello, you need to unlock bootloader by <code> fastboot oem unlock </code> command from your PC. This is assuming that you have fastboot and adb drivers as well as adb package installed on your PC. Remember, the phone user data will get formatted once you go for OEM unlock.
     

  19. sakyb
    Cupcake Jan 21, 2017

    sakyb , Jan 21, 2017 :
    I can't unlock use OEM fastboot unlock as USB debugging was never enabled.
    phone is fully stock
     

  20. sakyb
    Cupcake Jan 23, 2017

    sakyb , Jan 23, 2017 :
    Solved with method 3
    Thanks