201
Guide [UPDATED :- 28/06/2016] Mega Unbrick Guide for A Hard Bricked OnePlus 2

  1. cdisxm
    Jelly Bean Jan 30, 2017

    cdisxm , Jan 30, 2017 :
    Hi Naman, It seems you took on a subject that gets plenty of replies.
    It's not bricked but does not load since flashing SuperSU-2.74. I still have Fastboot access through PC, but TeamWin does not load. So I did not try any of your methods because it's not hard bricked, but partly soft-bricked. I did a "adb backup -all" prior to anything. There is more I can tell you. Please help. Thanks.
     

  2. monckk
    Eclair Jan 31, 2017

    monckk , Jan 31, 2017 :
    I have a question. My device manager doesnt get my OPT with the Qualcomm 9008 driver. It gets me error.
    It only let me the Oneplus ADB Interfece or Google ADB interface driver.
    But with that even Fastboot or the Recovery tool dont recognize the OPT. Any ideas?
     

    The Icky Stickie likes this.
  3. monckk
    Eclair Jan 31, 2017

    monckk , Jan 31, 2017 :
    Hi. Without oem unlock i formated with the original recovery. Now i stucked. I could instal this Qualcom driver but when i push START even on method 1 or 2 nothing happened. I tried tu change the port number (COM3 or COM5) but still nothing happens. Im lost. Can you help me?
     

  4. vrc007
    Gingerbread Feb 2, 2017

  5. vrc007
    Gingerbread Feb 2, 2017

    vrc007 , Feb 2, 2017 :
    @Naman Bhalla & @Reboot101


    I was talking on a phone and suddenly my OP2 got restarted and what I see is "Encryption Unsuccessful".
    I don't know what has gone wrong, maybe when on call it just got mistakenly browsed into encryption option or something?

    I am on Oxygen OS 3.5.6 and rooted with TWRP 3.0.2-2.
    Now whenever I boot my phone it shows
    "Encryption unsuccessful
    Your phone storage has been damaged, please download the firmware package to brush".


    It appears that some part of OS is loaded because when I change the volume the android styled indicator bar and the settings gear appears but nothing happens when I tap it.

    I entered TWRP to erase data (again because I'm sure had checked it) and it says (in red):
    E:Unable to load '/twres/languages/en-US.xml'
    Could not mount /data and unable to find crypto footer.
    Failed to mount '/cache' (Invalid argument)
    Failed to mount '/cache' (Invalid argument)
    ...done
    Unable to mount storage.
    Failed to mount 'data' (Invalid argument)
    Failed to mount '/cache' (Invalid argument)
    Full SELinux is present.
    Failed to mount '/cache' (Invalid argument)
    Failed to mount '/cache' (Invalid argument)
    Unable to mount /data/media/TWRP/.twrps
    MTP Enabled
    Failed to mount '/data' (Invalid argument)
    Formatting cache using make_ext4fs...
    Failed to mount '/cache' (Invalid argument)
    Updating partition details...
    Failed to mount '/data' (Invalid argument)
    Failed to mount '/cache' (Invalid argument)
    ...done
    Unable to mount storage

    When I go to Wipe / Repair File System selecting Data partition it shows me:
    Present: Yes
    Removable: No
    Size 0MB
    Used: 0MB
    Free: 0MB
    Backup Size: 0MB

    When I select Internal Storage and tap Repair or Change File System it says Invalid partition selection (in red).

    Tried this: https://forum.xda-developers.com/oneplus-2/general/guide-official-op2-stock-reset-to-oos-3-t3402020

    but I am stuck at recovery tool. After clicking the square button it shows ok and then pressing start it starts some procedure and then stuck on something called FirehoseCheckRSPE and some Chinese thing written ahead of it.

    https://drive.google.com/file/d/0B_l...ew?usp=sharing

    Tried fastboot comands to check whether it works and it does work.
    Like when entered comand fastboot devices, it does shows the device.
    I tried to flash stock recovery by --> fastboot flash recovery recovery.img
    It succeeds like this
    target reported max download size of 536870912 bytes
    sending 'recovery' (17013 KB)...
    OKAY [ 0.400s]
    writing 'recovery'...
    OKAY [ 0.086s]
    finished. total time: 0.490s

    But when i restart to recovery it still shows TWRP.

    What should I do?
    I just need my phone to work.
    Please help me out
    I really don't know how it even happened suddenly.

    Thank-you in advance.
     

    Praty_28 likes this.
  6. osrox
    Gingerbread Feb 3, 2017

    osrox , Feb 3, 2017 :
    Hello,

    I'm facing a weird problem with my OnePlus 2,

    If i flash OOS (be it 2.2.1 or 3.1.0 or 3.5.6)
    with TWRP 3.0.2-2 or Hybrid 3.4.
    Result = boots properly.

    But whenever i flash any Custom ROM, be it Tesla/RR/Slim/Lineage rom (old 6.0.1 or even new 7.1.1 builds)

    On first boot, every ROM gets stuck on its boot logo.

    I have tried, formatting, wiping, every partition.
    Clean flashed, even used sftrim command on system,data partitions using TWRP terminal.
    But no solution.

    OP2 only boots with OOS.

    If any OP2 user, has ever faced this sitiuation, & got it solved. Kindly tell me the fix.

    I will be really grateful.
     

  7. phaniboddu
    Cupcake Feb 4, 2017

    phaniboddu , Feb 4, 2017 :
    I have trying 2nd method,but in device manager,it is showing as android composite adb interface.Is this same as Unknown Device,QHUSB_BULK (under Unknown Devices) or Qualcomm HS USB ...... (under COMs and Ports. Please help me
     

  8. si2
    Cupcake Feb 12, 2017

    si2 , Feb 12, 2017 :
    I am stuck, Bricked after flashing MIUI on my OP2.
    Used to have latest CM and wanted to try MIUI. It flashed and started well. Then I left phone on charger and in the morning it turned to a brick - no response.
    Tried all possible unbrick oprions. On different laptops (Win10x64 + Win7x32).
    On both PCs device manager sees the phone as QDLoader 9008. MSM8994DownloadTool does not show a green bar. Tried English language version from OPX thread and it stucks on "Setting firehose communication data transmission" with no device (looses COM device).

    QFIL fails with
    Download Fail:System.Exception: Unable to download Flash Programmer using Sahara Protocol
    at QC.QMSLPhone.Phone.QPHONEMS_SaharaArmPrgDownload(S tring sFileName)
    at QC.SwDownloadDLL.SwDownload.QPHONEMSSaharaDownload ArmPrg(UInt64& version, String armPrgPath)
    Download Fail:Sahara FailSahara Fail

    Please help to unbrick my OP2. Thanks in advance.

    PS. Can not PM the moderator. Plz contact me.
     

  9. Afjal
    Cupcake Feb 12, 2017


  10. Kriomos
    Cupcake Feb 14, 2017

    Kriomos , Feb 14, 2017 :
    Guys, I am almost done with the method 1 of hard unbricking, but my telephone isn't saw during the sideload process by the ADB prompt. (I used adb devices as a command). Could anyone help me please? I am almost done in fixing it... :rolleyes::(
     

  11. Reddie308
    Eclair Feb 23, 2017

    Reddie308 , Feb 23, 2017 :
    Hi @Naman Bhalla thanks for the guide..
    i've success unbrick my OP2..
    And want to ask your opinion, do you think the MSM8994tool work to unbrick Nexus 6P?
    Because they have same SD810..
    I have Nexus 6P hardbrick,stuck on google logo's, can't boot to recovery...fasboot mode only.
    Thank you very much.
     

  12. Anujr5
    Cupcake Feb 23, 2017

    Anujr5 , Feb 23, 2017 :
    Hello, I typed wrong password too many time and my company's remote management reset my phone to factory mode as I have company email on my phone. I tried to start the phone but I am unable to get past "checking connection" stage after connecting to wifi. "Skip" option is disabled. Per One plus two support, I did volume down+power and did erase of data+cache. But still the same problem...

    Got One plus two level 2 support, but the person could not flash the phone after doing something on the phone using the device manager on PC.......

    I continue to have a dead phone, it boots up and gets stuck in checking connection stage. Can you please help to resolve the issue?

    Thank you!
     

  13. si2
    Cupcake Feb 24, 2017

    si2 , Feb 24, 2017 :
    Any suggestions for me? Tried all methods. Tool does not uploads data.
     

  14. TEALOCK_Wu
    Cupcake Feb 25, 2017

    TEALOCK_Wu , Feb 25, 2017 :
    Hi,
    Could you please help me with the situation?
    I unlocked the OEM locker with adb tools and unfotunately lock it again. Now I can't unlock it again with both the ulock tool and adb tool.
    I tried to use the method you mentioned in this title but failed. The OP2 doesn't show as Qualcomm 9008 but show as Android Composite ADB Interface.
    Is there any method to unlock my OP2 again or to make OP2 to show as Qualcomm 9008 so I can turn the phone into a factory software?
     

  15. petri.eerikainen
    Cupcake Apr 9, 2017

    petri.eerikainen , Apr 9, 2017 :
    Hello,
    I have gotten my OP2 in to a state that it only boots to fastboot mode. Power + volume- does nothing and normal boot stays forever in OP logo.

    "sudo fastboot device-info" gives me the following:
    ...
    (bootloader) Device tampered: false
    (bootloader) Device unlocked: false
    (bootloader) Device is_verified: false
    (bootloader) Charger screen enabled: false
    (bootloader) Display panel:
    (bootloader) console_locked: 1
    (bootloader) exec_console_unconsole: 0
    OKAY [ 0.073s]
    finished. total time: 0.073s

    "sudo fastboot oem unlock" gives
    ...
    OKAY [ 0.002s]
    finished. total time: 0.002s


    Still when I try

    "sudo fastboot flash recovery OP2_recovery.img" the answer is

    target reported max download size of 536870912 bytes
    sending 'recovery' (31381 KB)...
    OKAY [ 1.783s]
    writing 'recovery'...
    FAILED (remote: device is locked. Cannot flash images)
    finished. total time: 1.800s

    Is there something that can be done? How to oem unlock successfully?

    Thanks in advanced!

    BR. Petri
     

  16. piyushsoni24
    Gingerbread Apr 9, 2017

    piyushsoni24 , Apr 9, 2017 :
    It's bootloader cannot be unlocked now. First you have to recover your device using recover tool. What did you do that your device came to this state?
     

  17. anupritaisno1
    KitKat Apr 9, 2017

    anupritaisno1 , Apr 9, 2017 :
    That means your storage chip died and is working in read-only mode
     

  18. anupritaisno1
    KitKat Apr 9, 2017

    anupritaisno1 , Apr 9, 2017 :
    First mistake: the person you're trying to help is on Linux
     

    Sam Nakamura likes this.
  19. anupritaisno1
    KitKat Apr 9, 2017

    anupritaisno1 , Apr 9, 2017 :
    You need windows for this tool btw

    It won't work on Linux

    An emulator is fine like virtualbox? or qemu i guess
     

  20. anupritaisno1
    KitKat Apr 9, 2017

    anupritaisno1 , Apr 9, 2017 :
    Can you give it a few minutes just for it to do its work?