202
Guide [UPDATED :- 28/06/2016] Mega Unbrick Guide for A Hard Bricked OnePlus 2

  1. piyushsoni24
    Gingerbread Apr 9, 2017

    piyushsoni24 , Apr 9, 2017 :
     

  2. anupritaisno1
    KitKat Apr 9, 2017

  3. petri.eerikainen
    Cupcake Apr 12, 2017

    petri.eerikainen , Apr 12, 2017 :
    Thanks guys. I got Windows working trough VirtualBox and got my phone back to normal. It seems a bit much to have to install windows to recover your phone..?! anyways it's working again. Thanks again.
     

  4. Rishik999
    Honeycomb Apr 14, 2017


  5. vikramanananda
    Cupcake Apr 19, 2017

    vikramanananda , Apr 19, 2017 :
    Hi I tried to unbrick my oneplus 2 by using your method
    But i am stuck in Setting firehose communication data transmission do u have any idea what went wrong
    thanks
     

    Attached Files:


  6. vikramanananda
    Cupcake Apr 23, 2017

    Attached Files:


  7. gladiator9120
    Cupcake Apr 26, 2017


  8. dsmugiwara
    Cupcake Apr 27, 2017

    dsmugiwara , Apr 27, 2017 :


    none of the methods work for me , can you help me with it , or i have to throw the phone away which is heart breaking :'(
     

  9. Ankit Antony
    Cupcake May 1, 2017

    Ankit Antony , May 1, 2017 :
    Could anyone please help me out? I try to install the driver, but i cannot find 9008 in the entire list! What do I do? I'm stuck in the bootloader which is locked. OEM unlock is not enabled in the developer options and the phone does not boot into TWRP nor does it boot into the OS (cyanogenmod flashed). HELP!!
     

  10. benjy1985
    Donut May 2, 2017

    benjy1985 , May 2, 2017 :
    Do you know if this will work for op3t? I don't how I've done it but i have deleted recovery partition and the bootloader seems to be locked so I cannot get any access to the phone? I the rom still appears to be on there as it does the little oxygen os animation on start up, then it will say "android is starting, please type PIN" I use my pin that I have used for years and years but tells me the pin is incorrect. So. I can't even get into the os to re-unlock oem unlocking. I tried to do a remote session with one oneplus the other day but they couldn't her access to my computer. Please can you help at all?
     

  11. vanderson moreira
    Cupcake May 4, 2017

    vanderson moreira , May 4, 2017 :
    Boa tarde


    Tentei instalar uma TWRP no meu Lenovo A7010 e fiz algo de errado que agora é tão apagado sem sinal de conexão nem nenhum Fastboot e quando não há nenhuma conexão de computador. Ele dá um som que avisando que conectou no computador e logo em seguida outro som avisando que desconectou como se estivesse reiniciando de 0,5 em 0,5 segundos mas não aparece nada na tela smartphone. Por favor me ajuda.


    Agradeço já.
     

  12. Kirppu21
    Donut Jun 3, 2017

    Kirppu21 , Jun 3, 2017 :
    Used 1st method, cannot install updates or anything else above android 5
     

  13. Kirppu21
    Donut Jun 3, 2017

    Kirppu21 , Jun 3, 2017 :
    i finally managed to fix it
    What i did was the following
    Used Qfil from this site: https://androidmtk.com/download-qualcomm-flash-image-loader-qfil
    And used this firmware: https://forums.oneplus.net/threads/...ck-guide-for-a-hard-bricked-oneplus-2.347607/
    Basically i used the steps from method 1 but instead of the firehose i used Qfil
    with the qfil however it's extremely important that your folder where you load the .MBN files do NOT have spaces like "new folder" instead use underscore like this "new_folder" and qfil should work.
    Also you can use the Mega un-brick guide's MBN, and it works wonders

    MBNs being the firmware files, be extremely careful with them as you can FUBAR the phone with wrong file

    and as always do not blame me for bad files, and this may/may not work for you
    all damage is on you and you only, this is just a sidenote
     

  14. jaivaghela
    Ice Cream Sandwich Jun 19, 2017


  15. pinkcode
    Gingerbread Jun 25, 2017

    pinkcode , Jun 25, 2017 :
    For Oneplus 2 , ROM should be A2003 not A2001. Due to this unbrick always fails.
     

  16. randadp
    Cupcake Jun 29, 2017

    randadp , Jun 29, 2017 :
    Hey Naman,

    I am using method 1 to unbrick my OPT. Qualcomm drive is showed up. Then I open MSM Firehose Tool and run it as administrator, the problem starts here, it doesn't show any progress bar after I start the tool, but the "alien" text is running until row 6. Is this something usual that i have to wait until it finishes (already waiting for 30 minutes) ? is there any suggestion ?
     
    Last edited: Jun 29, 2017

  17. Kaushik.bansal
    Cupcake Jul 1, 2017

    Kaushik.bansal , Jul 1, 2017 :
    Bro my oneplus two is not turning on even its not showing the boot logo and and charhing led is also not showing.. Please help me to recover my phone.
     

  18. Lump91
    Cupcake Jul 1, 2017

    Lump91 , Jul 1, 2017 :
    hey guys, I´m getting this:
    dynamic_nvbk.bin: OK
    emmc_appsboot.mbn: OK
    gpt_backup0.bin: OK
    gpt_main0.bin: OK
    userdata.img: OK
    userdata_64G.img: OK
    rawprogram0.xml: FAILED
    rawprogram0_64G.xml: FAILED
    NON-HLOS.bin: OK
    rpm.mbn: OK
    sbl1.mbn: OK
    sdi.mbn: OK
    static_nvbk.bin: OK
    tz.mbn: OK
    boot.img: OK
    cache.img: OK
    persist.img: OK
    recovery.img: OK
    system.img: OK

    i deleted the rawprogram "userdata" lines as mentioned.
     

  19. cdisxm
    Jelly Bean Jul 9, 2017

    cdisxm , Jul 9, 2017 :
    If I had that problem, I would make a support ticket and ask OnePlus Support to make an appointment to remotely unblock it. Of course they will only do stock installations--no rooting. Hope it helps your decision.

    Michael
     

  20. aivarasvis
    Cupcake Jul 17, 2017

    aivarasvis , Jul 17, 2017 :
    Hi I tried all of your guides and non of them worked, after rooting my phone started charging very slowly, then after few hours it died and when I tried to charge it, it displays the low batter icon and says to keep the phone charging, yet it never charges, then sometimes it enters the rebooting cycle and I can't access the recovery, I can see qualcomm in device manager yet non of the methods in this guide worker as they would all say that the filles have been tampered with.

    Essentially I can't get past step 6. I can see the drivers but they always fail no mater what.

    Made some progress beyond step 6 (I think) then I tried method one and I got this [​IMG]and then I tried method 2 and got this [​IMG][​IMG]
    Update #3 I can't get past the drivers part again...[​IMG][​IMG]
     
    Last edited: Jul 17, 2017