200
Guide [UPDATED :- 28/06/2016] Mega Unbrick Guide for A Hard Bricked OnePlus 2

  1. Loars
    Cupcake Apr 2, 2018

    Loars , Apr 2, 2018 :
    I'm having the same problem, TWRP 3.2.1-0 and lineageos-15.1, lineageos-14.1 and even flashing a twrp-backup from before bricking my OP2 gets me stuck in the boot logo while OOS in whatever version boots properly.

    Anybody got a solution for that? Staying on OOS isn't really an option for me.
     

  2. Sam Nakamura
    Ice Cream Sandwich Apr 3, 2018

    Sam Nakamura , Apr 3, 2018 :
    Sure you did go to TWRP'S advanced wipe option to wipe everything except internal storage?
    Sure you flashed for the device suitable ROM & GApps (maybe wait with Magisk till it successfully booted up once)?
     

  3. Loars
    Cupcake Apr 3, 2018

    Loars , Apr 3, 2018 :
    Yes, I wiped everything in advanced options.
    I tried flashing lineageos with and without GApps from sdcard and via sideload, no Magisk or SuperSU at any time and also tried to flash my Full TWRP-Backup (LOS17.1) from a few days ago and I always ended stuck in bootscreen for multiple hours. :-(

    Following this Guide https://forums.oneplus.net/threads/...ed-op2-oxygenos-2-1-1-fastboot-images.388967/ gives me a working OOS 2.1.1, then flashing OOS 3.6.1 from OnePlus Homepage via adb sideload ends in OOS booting forever. I'm not sure about that, but I kinda expected it to be working
     

  4. Sam Nakamura
    Ice Cream Sandwich Apr 3, 2018

    Sam Nakamura , Apr 3, 2018 :
    Fashing from working OOS 2.1.1 to OOS 3.6.1 via internal OTA updater doesn't work either?
    Depending on the fastboot version you're using it might flash any (bootloader, etc.) file incorrectly, not sure but exactly this happened lately with the Pixel device, where certain fastboot versions led to a "brick" because some partitions weren't flashed correctly - fastboot isn't a guarantee...

    Alternatively:

    Also check Spannaa's xda thread, maybe you have luck by flashing the "firmware only" packages - check https://forum.xda-developers.com/oneplus-2/general/rom-mirrors-official-oxygen-os-roms-ota-t3209863, especially post 2 with the mentioned files...

    Or:

    Check the Oxygen Updater from Playstore
     

  5. Lancelot_69
    Lollipop Apr 3, 2018

    Lancelot_69 , Apr 3, 2018 :
    Which twrp and which gapps
     

  6. Loars
    Cupcake Apr 6, 2018

    Loars , Apr 6, 2018 :
    twrp 3.2.1-0 https://eu.dl.twrp.me/oneplus2/twrp-3.2.1-0-oneplus2.img.html
    gapps 8.1 aroma, but as I said, I went over to try flashing without gapps to make sure gapps are not causing my problems

    Updating to OOS 3.6.1 from the OOS 2.1.1 OTA-Updater does not work either. I get stuck at the boot logo. Then I flashed the 3.6.1-firmware from https://forum.xda-developers.com/oneplus-2/general/rom-mirrors-official-oxygen-os-roms-ota-t3209863, formatted data and cache and voilà, OOS 3.6.1 boots up. Sadly, LineageOS is still stuck at the boot logo after flashing 3.6.1-firmware and formatting data & cache
     

  7. Sam Nakamura
    Ice Cream Sandwich Apr 6, 2018

    Sam Nakamura , Apr 6, 2018 :
    You're using ext4 or f2fs on data?
    A various version of lineageOS (maybe older ones)?
    Re-downloaded the file?
    Tried a compatible custom kernel?
     

  8. Sam Nakamura
    Ice Cream Sandwich Apr 6, 2018

    Sam Nakamura , Apr 6, 2018 :
    *tried various versions of lineageOS?
    (can't edit with the App as it kills quotes)

    Last option is to use the unbrick tool again, you can check xda-developers before, there's a unbrick thread for the OP2 too, maybe there's a newer version available or someone with a similar problem..
     

  9. Lancelot_69
    Lollipop Apr 6, 2018

    Lancelot_69 , Apr 6, 2018 :
    Not sure were you got your twrp but maybe for giggles try here
    https://dl.twrp.me/oneplus2/
     

  10. Loars
    Cupcake Apr 6, 2018

    Loars , Apr 6, 2018 :
    Tried it and I am still stuck in the boot-logo. Guess my version was just the europe-mirror or something

    ext4
    I tried

    lineage-15.1-20180402-nightly-oneplus2-signed.zip

    lineage-15.1-20180326-nightly-oneplus2-signed.zip
    and

    lineage-14.1-20180324-nightly-oneplus2-signed.zip
    Re-downloaded the files and verified the sha-fingerprint

    No, as I have no experience with custom kernels so far...


    I also tried https://forum.xda-developers.com/oneplus-2/development/rom-pixel-experience-t3730059 again ending in a boot-loop after clean flash
     

  11. Lancelot_69
    Lollipop Apr 6, 2018

    Lancelot_69 , Apr 6, 2018 :
    Do f2fs as @Sam Nakamura pointed out. Good catch.
     

    Sam Nakamura likes this.
  12. Sam Nakamura
    Ice Cream Sandwich Apr 6, 2018

    Sam Nakamura , Apr 6, 2018 :
    Tough thing but I think there's something seriously wrong with the device... Maybe not a bad idea to use the unbrick tool / MSM-download-tool to start from square one as it is pure guessing atm, I suggest you to use these files:
    https://forum.xda-developers.com/oneplus-2/general/guide-official-op2-stock-reset-to-oos-3-t3402020
     

  13. Loars
    Cupcake Apr 15, 2018

    Loars , Apr 15, 2018 :
    I finally found the solution for this during this weekend :)
    As I desperately needed my OP2 over the last days, I kept working with OOS-3.6.1. I noticed my rotation-sensors and proximity-sensor did not work at all and my camera was usually focussing very slowly (~2-3 sec) and randomly crashed. Googled a bit, found this Thread: https://forum.xda-developers.com/oneplus-2/general/recovery-teamwin-recovery-project-3-0-0-t3310713 I fastboot flashed persist.img fastboot and all sensors were alive again and the camera handled much better.

    During my investigation, I read in some thread, that lineageos is checking the rotation-sensor during boot and thus freezes when it does not respond. So I flashed lineage again and it bootet up immediately!

    I'm looking forward to setting it up with gapps now.
    Thank you very much for your great support @Sam Nakamura and @Lancelot_69
     

    Sam Nakamura likes this.
  14. Lancelot_69
    Lollipop Apr 15, 2018

    Lancelot_69 , Apr 15, 2018 :
    Glad to hear that you are up and running! Thanks for sharing your solution! Excellent
     

  15. Sam Nakamura
    Ice Cream Sandwich Apr 15, 2018

    Sam Nakamura , Apr 15, 2018 :
    Happy to hear from your well deserved success!
    Never would have connected the dods, very interesting and something I'll never ever forget again...
     

  16. G_Lokesh_Bhati_NSpx
    Cupcake Apr 18, 2018

    G_Lokesh_Bhati_NSpx , Apr 18, 2018 :
    i done all method i suucesfull detect portcom9008 and flash completly with green text but still my phone wont turn on
     

  17. Gonius
    Cupcake Apr 24, 2018

    Gonius , Apr 24, 2018 :
    hi everyone .When ill do 1-8 step method 1. Next Step is Reset with Logo Bootloop. And only can enter at Fastboot mode with Device Locked . Anyone Can Help me? Cant enter Recovery or anything. Only Fastboot mode or bootloop logo on reset :(
     

  18. Trevor.Hawkes
    Ice Cream Sandwich May 11, 2018

    Trevor.Hawkes , May 11, 2018 :
    I had this situation exactly. Couldn't sideload in Fastboot because the device was locked with no way to unlock it.
    I kept holding start button and volume down over and over to restart the device. Eventually I got into recovery and was able to select install from usb.
    With that I could use adb to flash rather than fastboot. It took ages to complete but got there in the end.
     

  19. ajembucika
    Eclair May 13, 2018

    ajembucika , May 13, 2018 :
    Hello!

    I hope this thread is still alive!

    I've brought a bricked OnePlus 2 today.. Guy said it got bricked when he flashed wrong ROM.. Not sure if I do believe him tho.
    Anyways I've tried to boot up the phone, it's stuck at powered by Android screen.. Tried to boot into fastboot.. It boots.
    So I've figured that it must be a software problem, as it boots into fastboot and powers up to the first screen.

    Phone does not bootloop - it stays on the screen forever.

    Ok.. Went home, searched for some help..

    I've done the methods posted here.. This is what I get:

    dynamic_nvbk.bin: OK
    emmc_appsboot.mbn: OK
    gpt_backup0.bin: OK
    gpt_main0.bin: OK
    userdata.img: FAILED open or read
    userdata_64G.img: FAILED open or read
    rawprogram0.xml: FAILED
    rawprogram0_64G.xml: FAILED
    NON-HLOS.bin: OK
    rpm.mbn: OK
    sbl1.mbn: OK
    sdi.mbn: OK
    static_nvbk.bin: OK
    tz.mbn: OK
    boot.img: FAILED open or read
    cache.img: FAILED open or read
    persist.img: OK
    recovery.img: FAILED
    system.img: FAILED open or read


    btw, I've typed in cmd unlock bootloader.. it's unlocked.. It also flashes the twrp fine, but it's like it's not flashed.. just not there.. Cant boot to it.

    I've also tried the method from XDA called firs aid (or something like that) It goes trough OK Kind fast tho. but it does not boot.

    Device is recognised as Qualcomm HS-USB QDLoader 9008 (COM4).

    Any help to get device up and runing I would really appreciate it.
     

  20. Sam Nakamura
    Ice Cream Sandwich May 13, 2018

    Sam Nakamura , May 13, 2018 :
    Have you tried to flash just the fastboot OOS files from hete:
    https://forum.xda-developers.com/oneplus-2/general/rom-mirrors-official-oxygen-os-roms-ota-t3209863
    {check the first posts, there're specific fastboot files)
    Not being specifically good in analyzing the output you posted but persist.img is fine, this can give you stupid issues, saw it time and time again, ESF looks good, only boot, system, cache is borked...
    If fastboot gives you an error, try fastboot erase (or format) cache, userdata, system and boot - but please google on how to do exactly, just writing from my fading memories...

    On the other hand, I think there's more than just one version os the MSM-download-tool / unbrick tool, you might try those to (just check xda-developers for "OP2 hardbricked")

    Have you tried to not flash TWRP but "fastboot boot recovery twrp.img"? Maybe booting works instead of flashing (there's also a possibility to fastboot erase (maybe format) recovery before an actual next flash attempt...

    Does ADB work?
     

    ajembucika and BeingIncog like this.