202
Guide [UPDATED :- 28/06/2016] Mega Unbrick Guide for A Hard Bricked OnePlus 2

  1. ajembucika
    Eclair May 13, 2018

    ajembucika , May 13, 2018 :
    Thanks for your answer!

    I'm downloading oos-3.6.0-oneplus2-fastboot-20170824.zip hope this will work...

    ADB works? I mean it says flash is OK when I've tried to flash twrp.. Tried booting.. then I get device status null..
    I've googled the output and the only hit I've got was one from XDA and that one was a bad one.. apparently a hardware defect..

    I hope I can get it up and running!
     

    Sam Nakamura likes this.
  2. ajembucika
    Eclair May 13, 2018


    Z1526540050382 likes this.
  3. Sam Nakamura
    Ice Cream Sandwich May 14, 2018

    Sam Nakamura , May 14, 2018 :
    Congratulations, happy to hear that!
     

    ajembucika likes this.
  4. Z1526540050382
    Cupcake May 17, 2018

    Z1526540050382 , May 17, 2018 :
    Would you have a magic toolbox like this for the 3T? I only have recovery available and adb sideload..
     

  5. Sam Nakamura
    Ice Cream Sandwich May 17, 2018

    Sam Nakamura , May 17, 2018 :
    That's more than enough to revive the device...
    You can just sideload the ROM zip from oneplus.net/downloads or copy the ROM to your internal storage and apply update via stock recovery...

    There's a unbrick tool for both devices, the 3 and 3t, just Google "oneplus 3t unbrick tool xda" and it should be in the very first search results
     

    Z1526540050382 likes this.
  6. dm_oneplus2
    Cupcake May 18, 2018

    dm_oneplus2 , May 18, 2018 :
    @Sam Nakamura and @bucika66, I've been struggling with a OP2 and I have a very similar issue.

    I can get TWRP on it and install a Lineage OS rom (tried 4-5 version and then moved on to other roms) I got into a boot animation loop.

    I can get the phone back to fastboot and need to use the unbricking tool to go back to OOS 3.0.2 which I can then upgrade to 3.6.1.

    I'm not sure why I can't install any other rom on the device besides TWRP and OOS. The TWRP log for installing a rom like LOS said it was 100% successful but when the phone boots it gets stuck in the animation loop. I can't figure out why it won't boot to the OS.

    I saw an issue a page ago regarding the camera preventing LOS from booting but not sure if that's the case or if there is something else preventing it. Since it's a new LOS build I am not sure how to get the LOS failed boot log.

    Thanks
     

  7. Sam Nakamura
    Ice Cream Sandwich May 18, 2018

    Sam Nakamura , May 18, 2018 :
    Did you clean flash lineageOS? Meaning wiping everything except internal storage before flashing lineageOS, GApps, magisk...

    If so try formatting each partition (system, cache, data), this will wipe everything from your storage, so you'll need to copy the relevant files onto your phone again...

    Taking logs while bootloop isn't the easiest thing, you'll need working ADB for this (adb shell cat/proc/kmesg or dmesg), please Google yourself as I can't remember 100%, might be incorrect...

    let me know about the results!
     

  8. Sam Nakamura
    Ice Cream Sandwich May 18, 2018

    Sam Nakamura , May 18, 2018 :
    Did you try to flash anything else than lineageOS, please try aosp extended (AEX) or resurrection remix (RR) too, just to be sure that it's not lineageOS borking your phone..
     

  9. dm_oneplus2
    Cupcake May 18, 2018

    dm_oneplus2 , May 18, 2018 :
    I did wipe everything and then formatted the partition.

    I was having the issue with ADB at that time because when I flash a new version of an OS ADB is generally disabled
     

  10. dm_oneplus2
    Cupcake May 18, 2018


  11. dm_oneplus2
    Cupcake May 18, 2018

    dm_oneplus2 , May 18, 2018 :
    Woot, I fixed it.

    Based on the past couple of pages, I tried to find a persist.img and flash it which worked.

    That's super weird because I've never run into this issue on a phone so far.
     

    ajembucika likes this.
  12. ravi.bigsun
    Eclair May 22, 2018

    ravi.bigsun , May 22, 2018 :
    Same issue here...whats the solution? @Naman Bhalla
     

  13. santhoshunnithan
    Froyo Jun 17, 2018

    santhoshunnithan , Jun 17, 2018 :


    Method 2 worked for me, thanks a million..!!!
     
    Last edited: Jun 17, 2018

  14. domecamm
    Gingerbread Jul 5, 2018

    domecamm , Jul 5, 2018 :
    Hello, for method A2001 only method 1 works?
    After finishing the procedure, the green text comes out but the phone remains locked on the 1+ logo and the writing powered by andoird, does not start in recovery even by pressing the keys.
    It is recognized in fastboot mode, but it is not possible to flash because the bootloader is locked.
    I also tried the modified version of the tool with english recovery, but nothing to do ...
    Can you help me? Thanks
     

    The Icky Stickie likes this.
  15. ulagandan
    Cupcake Jul 12, 2018

    ulagandan , Jul 12, 2018 :
    hi i try the same first method not work but second method work fine but my phonr only restart any help guys
     

  16. The Icky Stickie
    Cupcake Aug 8, 2018

    The Icky Stickie , Aug 8, 2018 :
    Hi! I had the same issue. I got the green text, and now it's JUST one the OnePlus logo, where as before it was the loading animation looped.. what do I do from here?
     

  17. website
    Cupcake Sep 8, 2018

    website , Sep 8, 2018 :
    Hello Naman,
    Trying to unbrick the Oneplus2, when I run MSM Download Tool and press "Start" it starts, but does nothing... I can only press "Stop", big button with something written in chinese language or just close the program.
    Any ideas? Could you please help me? :)
     

  18. anupritaisno1
    KitKat Sep 9, 2018

    anupritaisno1 , Sep 9, 2018 :
    /proc/last_kmesg has been removed. /sys/fs/pstore is used now
     

    Sam Nakamura likes this.
  19. Sam Nakamura
    Ice Cream Sandwich Sep 9, 2018

    Sam Nakamura , Sep 9, 2018 :
    Hey old friend! [e]263a[/e]️ Nice to hear from you and thanks for pointing this out!
     

    anupritaisno1 likes this.
  20. anupritaisno1
    KitKat Sep 9, 2018


    Sam Nakamura likes this.