1
USB-C Headphones

  1. stardomains
    Eclair Dec 13, 2019

    stardomains , Dec 13, 2019 :
    I have some USB-C headphones. I plug them in to an already-on OnePlus 7T phone and they don't work. I toggle USB-OTG on, still nothing. So, I need to leave them plugged in and then restart the phone and they will work. The icon is in the status bar too when it restarts.

    Is there anything I can do to make them work without having to restart the phone?

    I'm running the latest stable OS.
     

    #1
    Marozi likes this.
  2. stardomains
    Eclair Dec 13, 2019

    stardomains , Dec 13, 2019 :
    Solved?

    I updated to 10.0.7 today and it looks like it is fixed. Will test the next few days but so far every time I insert them it works.
     

    #2
  3. Marozi
    Cupcake Dec 27, 2019

    Marozi , Dec 27, 2019 :
    I got the exact same problem.
    Using Razer Hammerhead USB-C ANC on a OnePlus 7Pro
    OS vesion: 10.0.2.GM21BA
    OTG storage is turned on

    Only way i got it to work was directly after a reboot with the headset plugged in ... after removing it once, it will only work again after another reboot of the phone.
     

    #3
  4. Marozi
    Cupcake Dec 27, 2019

    Marozi , Dec 27, 2019 :
    After talking with OP Support i got the following solution that did work for me:

    Power off your device
    - Press the power key + volume down for a few seconds
    - Enter PIN for decrypting the volume
    - Select English
    - Tap on Wipe data and cache
    - Tap on Wipe cache
    - Tap on Yes to confirm cache wipe
    - Wait for the wipe process to complete
    - Reboot the phone

    This (for now) seems to work. I unplugged the headset, plugged it in again, testen with other devices inbetween to verify it kept working, and till now it did (though honestly it's only an hour testing after reboot).
     

    #4
  5. chbk
    Donut Dec 28, 2019


    #5
  6. carlopelio
    Cupcake Jan 22, 2020

    carlopelio , Jan 22, 2020 :
    I'm using the OnePlus USB C original headphones and I get the same results I got with other headphones.
    Sometimes they just are not recognized.
    The only way to get it working again is rebooting the device.
    It's very frustrating.
     

    #6
  7. katheria09
    Ice Cream Sandwich Jan 23, 2020


    #7
  8. Q1579869703923
    Cupcake Jan 24, 2020

    Q1579869703923 , via OnePlus 7 Pro , Jan 24, 2020 :
    I've just encountered this issue. I've been using the Oneplus headphones for the past 3 month. The phone still does charge, so not a problem with the port, and the headphones do work on another phone.

    I've tried rebooting the phone with the headphones plugged or not. Tried to wipe the cache as well, but no thing's been successful as of now.

    Any help is appreciated
     

    #8