0
Other USB-C port has become loose and lost its "click"

  1. Dimtuhop
    Cupcake Nov 16, 2018

    Dimtuhop , Nov 16, 2018 :
    I got my OnePlus 6 at the London pop-up and have been happy with it until recently.
    A couple weeks ago I noticed that my USB-C port no longer has a "click" when inserting a cable into it. This has deteriorated into the cable loosing connection randomly and leaving me with an uncharged phone when I don't notice this (made an even bigger issue by the noticeably reduced battery life after the android 9 update). I have tried using other cables and also checked that the OnePlus cable works fine on all other usb-c ports I have. The issue is definitely in the hole of the OnePlus no longer gripping the shaft of the usb-c connector. There does not appear to be anything in the hole blocking it and I have tried blowing into it with no effect.
    I have treated the phone with care and even if I hadn't, it is way too early for the port too be failing. I usually plug the phone in only once a day on most days, so it has not had excessive use.

    Any help is appreciated.
     

    #1
  2. retzer
    Cupcake Nov 16, 2018

    retzer , Nov 16, 2018 :
    That happens with those connections sometimes. Not good news but you'll most likely have to get it fixed, hopefully you are still under warranty.
     

    #2
  3. UngIued
    Honeycomb Nov 16, 2018

    UngIued , Nov 16, 2018 :
    Clean pocket lint out of charging port.

    Pocket lint can get packed inside the port from inserting the cable and over time builds up to the point that the cable is loose. I use a small sewing needle to clean out the debris.
     
    Last edited: Nov 16, 2018

    #3
    Kytharsis likes this.