0
USB-C Splitters no longer work after the latest 7T system update

  1. Jonny6pak
    Cupcake Dec 1, 2020

    Jonny6pak , Dec 1, 2020 :
    Ever since the latest update on the 7T, none of my USB-C charging/audio splitters work. I have three splitters. Two are generic from Amazon and have 2 USB-C ports. One port for charging and one port for USB-C audio. They always worked just fine. The other is a Belikin splitter that has 1 USB-C port for charging and one 3.5mm audio jack. This also worked without problem. Immediately following the update, audio will play through any of the splitters only if the power cable is not attached. This, of course, defeats the purpose. Any one else having this problem? Any suggestions beyond submitting a bug report?
     

    #1

  2. #2
  3. SRD.
    KitKat Dec 2, 2020

    SRD. , via OnePlus 7T , Dec 2, 2020 :
    There are common port for Charging & Audio output. ( Common Pins inside port)
    At the same time only one'll be functional. Using as many splitters can't split the common port of the master splitter.
     

    #3
  4. andrewgats
    Cupcake Dec 6, 2020

    andrewgats , Dec 6, 2020 :
    Hello there,

    This is my first comment on the forums, but I am also experiencing the same issue that Jonny6pak is seeing. Anyone know how to report a bug to OnePlus?
     

    #4

  5. #5
  6. the_o2
    User of the Year 2018; Community Scholar 2020 Dec 7, 2020

    the_o2 , Dec 7, 2020 :
    It actually a bug happened after the latest update with few devices,
    You can report this bug here
    https://forums.oneplus.com/feedback
     

    #6
    Caomhin likes this.
  7. U1608389055379
    Cupcake Dec 22, 2020

    U1608389055379 , Dec 22, 2020 :
    This problem looks very similar to what I am experiencing with an USB hub which is powered via an USB-C port itself. Once I connect the USB power cable to the hub for charging the hub plus all devices connected to it - including my 7T, the 7T loses access to all USB ports on the hub - independent of their types (storage, audio, keyboard, mouse). However, the 7T is charged via the hub in the same manner as directly connected to the charger.
    That means that my hub is useless - similar as the USB-C splitter above (actually the splitter above is nothing else than a hub). The result is that you can either have USB attached devices to the phone via a splitter/hub or charging the phone (not both at the same time).
    I have been trying to convince the support people that this a MAJOR PROBLEM but so far I believe nobody has bought into that yet.
    Helmut
     

    #7
    the_o2 likes this.
  8. the_o2
    User of the Year 2018; Community Scholar 2020 Dec 23, 2020

    the_o2 , Dec 23, 2020 :
    I think the next update gonna solve it, as I seen many people already reported.
     

    #8
  9. inferno0230
    Froyo Dec 23, 2020

    inferno0230 , via OnePlus 7T , Dec 23, 2020 :
    This isn't issue of device , This is the problem with OOS cause I tested my usb hub with different devices connected in OOS 7T but it doesn't works

    On the other hand
    When i tried the same but with custom roms available for 7T
    It works just fine.
    (Names of tested roms - AOISP OFFICIAL , RESURRECTION REMIX official, Evolution X Unofficial)

    I also use different devices via USB HUB at the same time and it all worked (Mouse , Keyboard , Gamepad , Pendrive )

    I also tried to install older versions of OOS (via MSM TOOL)
    From 10.3.2 to 10.3.7 STABLE / BETA 5 - BETA 8 and none of them supported USB HUB with Multiple devices attached

    So i think this is a problem residing within OOS

    Please fix this OOS team because no one likes to change roms just for a feature not there in OOS
     

    #9
    eduandebruijne likes this.
  10. KhanAamer
    Gingerbread Dec 23, 2020


    #10
  11. eduandebruijne
    Cupcake Jan 21, 2021 at 9:08 AM

    eduandebruijne , Jan 21, 2021 at 9:08 AM :
    Also having this issue, hoping it's fixed in the the new Open beta that just was released for the Oneplus 7T but didn't check it out yet.

    Factory reset won't fix it I think, because it will reset the phone but still use the same Oxygen OS version.
     

    #11
  12. eduandebruijne
    Cupcake Jan 21, 2021 at 11:25 AM

    eduandebruijne , Jan 21, 2021 at 11:25 AM :
    I just installed the new Open Beta 1, but unfortunately this bug is still present.. I'll install the stable version again and look for a downgrade ROM from 10.0.15 to 10.0.13 where is still works...
     

    #12