0
USB debugging

  1. JorgeA
    Eclair Sep 23, 2015

    JorgeA , Sep 23, 2015 :
    I'm trying to use the USB debugging (under Developer options, etc.) and when I plug the phone on to my laptop I am meant to get a message asking me to "authorize" the laptop so then I can do stuff with it. However, I don't seem to get this message at all, and the Bacon Root Toolkit I am trying to use does not "talk" to the device at all. This seems to be the only obstacle so far, so I am wondering if anybody can help me resolve it.
    Thanks a lot in advance.

    PS. I'm on YOG4PAS1N0 (LMY48B), not rooted.
     

    #1
  2. PaulF8080
    Gingerbread Sep 23, 2015

    PaulF8080 , Sep 23, 2015 :
    If it doesn't talk, I think you have to install the adb drivers on you PC by clicking the install drivers button.
     

    #2
  3. JorgeA
    Eclair Sep 23, 2015

    JorgeA , Sep 23, 2015 :
    I did, following their instructions to uninstall all existing drivers first and then installing them from their own software. Everything was "installed" but still no luck with the communication between devices... Thanks for your time Paul, really appreciated.
     

    #3
  4. #HYPEorGTFO
    KitKat Sep 23, 2015


    #4
  5. JorgeA
    Eclair Sep 23, 2015

    JorgeA , Sep 23, 2015 :
    Nor do I but the lack of communication between devices leads me to think there should be a request to "authorize" the device. Furthermore, there is a "Revoke USB debugging authorizations" option:
    Screenshot_2015-09-23-15-31-41.png
     

    #5
  6. sumii0626
    Ice Cream Sandwich Sep 23, 2015

    sumii0626 , Sep 23, 2015 :
    When I debugged and got developer access, mine didn't get any messages about authorization for a laptop. It just automatically opened up the stuff (mac air).
     

    #6
    #HYPEorGTFO likes this.
  7. #HYPEorGTFO
    KitKat Sep 23, 2015

    #HYPEorGTFO , Sep 23, 2015 :
    Mine works fine and says nothing about "authorize"... Where did you hear that anyway?

    Try the Samsung drivers, that's what I've been using

    Are you using adb or just have it on?
     

    #7
    sumii0626 likes this.
  8. JorgeA
    Eclair Sep 23, 2015

    JorgeA , Sep 23, 2015 :
    Here:
    Snip.JPG
    I don't get this message at all, and since there seems to be no communicaiton at all between devices I thought this may be an issue. I have installed adb as well but nothing changes....
     

    #8
  9. JorgeA
    Eclair Sep 23, 2015


    #9
  10. lakis3
    Gingerbread Sep 23, 2015

    lakis3 , Sep 23, 2015 :
    As I can see from your picture USB debugging mode switch is disabled. Enable it and reconnect.

    Like this post? Did it help? Please give a like to it. Don't be shy. I won't tell.
     

    #10
  11. JorgeA
    Eclair Sep 23, 2015

    JorgeA , Sep 23, 2015 :
    Hi Lakis, yes, when I took the screenshot it was disabled, but I've enabled it now and still no luck...
     

    #11
  12. lakis3
    Gingerbread Sep 23, 2015

    lakis3 , Sep 23, 2015 :
    On your PC try to unistall any usb drivers you might have installed and try a fresh install of ADB drivers. Lets take one step at a time.
     

    #12
  13. JorgeA
    Eclair Sep 24, 2015

    JorgeA , Sep 24, 2015 :
    So after uninstalling all the usb drivers for the OPO (including some I had left from a previous Samsung), then reinstalling them again, I managed to do a good back up, which was the main purpose of the exercise. I even got the "authorize computer" message!

    However, I am not entirely convinced the whole issue has been 100% resolved, but for now I will leave it as it is.

    Thank you all for your comments and suggestions!
     

    #13
  14. J1573263719248
    Cupcake Nov 9, 2019 at 1:45 AM

    J1573263719248 , Nov 9, 2019 at 1:45 AM :
    In my case I went to the developer options and changed the "Default USB configuration options" to FileTransfer. Then ADB prompted me the permission alert.
     

    #14