USB Disconnects/Reconnects every 2 seconds

  1. londonappdev
    Gingerbread Jun 28, 2016

    londonappdev , Jun 28, 2016 :
    Hey there.

    I am having a frustrating issue with my OnePlus One to my Windows 10 laptop. My phone runs CynogenMod 13.1.

    This is what happens:

    I connect the phone to the PC with the USB connector. It will then continuously connect and disconnect to the computer as if I am repeatedly inserting and removing the USB cable from the computer.

    If the phone is locked it happens very frequently (every 1-2 seconds). If the phone is unlocked it happens about every 15-20 seconds.

    I have tried:
    • Using a different USB cable.
    • Using a different USB port on the computer.
    • Enabling and Disabling developer mode.
    • All the different USB options (Charging, File Transfers, Photo Transfer, MIDI).
    • Putting the phone in Airplane mode.
    The only thing that seems to work is if I switch the phone off completely.

    Anyone else experienced this or have any ideas of things to test. Ideally I would like to avoid installing OxygenOS. Appreciate any help!

  2. pikota
    Marshmallow Jun 28, 2016

  3. londonappdev
    Gingerbread Jun 28, 2016

    londonappdev , Jun 28, 2016 :
    Unfortunately I don't have another PC to test but I did test on a Mac and it seemed to be working fine on that.

    Actually I should add that I started noticing the issue after my Motherboard was replaced in my laptop. I'll try and find another PC to test with.

  4. londonappdev
    Gingerbread Jun 28, 2016

    londonappdev , Jun 28, 2016 :
    Found a work-around. If I restart the phone after plugging it in the problem seems to go away.

    I should (and will) definitely test on another Windows PC but I still believe the issue is with the phone (because of the different when the screen is locked vs unlocked).

  5. U1545469922743
    Cupcake Nov 13, 2021

    U1545469922743 , Nov 13, 2021 :
    I have the same problem , not only with my oneplus 6t but a also with the oppo reno 2z. On other PC windows 10 works fine. On the laptop with the issue, if i connect huawei tablet, works OK....
    I tried re-intall usb drivers, disable energy savings on usb in pannel control.... no further ideas.... please any help is appreciated.