1
USB file transfer with Windows 10 pro via OnePlus 7 Pro

  1. Mikey_1273
    Gingerbread Oct 23, 2019

    Mikey_1273 , via OnePlus 7 Pro , Oct 23, 2019 :
    I am trying to connect my phone with my PC to copy over some photos and I can't seem to get connected. I have USB debug on in development options. I have selected file transfer in USB settings in the notifications when connected. all I see in file explorer on windows is a drive with a 1+ icon, windows think it's a CD drive. if I open it I see where I can install USB drivers. I did that and restart the computer but that's all I still see. I tried different USB ports and cables. when I connect the phone it is in file transfer mode but I can't see the internal storage. the phone is a OnePlus7pro with Android 10

    also having issue connecting a 6t as well.

    I know there are a few threads when I searched but no one seems to be seeing what I am.

    how do I get it to work?
    thanks
     

    #1
    K1587980645024 likes this.
  2. Horsault
    Nougat Moderator Oct 23, 2019

    Horsault , Oct 23, 2019 :
    Windows 10, king of surprises...

    Alternate real true operating system maybe would perform better.
     

    #2
  3. KeepTransisting
    The Lab - OnePlus 7 Pro Reviewer Oct 24, 2019

    KeepTransisting , Oct 24, 2019 :
    That's because OnePlus includes a virtual CD drive that installs the drivers. You won't see the OnePlus storage as a drive letter. You'll see it under This PC as a "media device"
     

    #3
    Mikey_1273 likes this.
  4. Mikey_1273
    Gingerbread Oct 24, 2019

    Mikey_1273 , via OnePlus 7 Pro , Oct 24, 2019 :
    ok now I see it as a media device after restarting 2x.
    thanks
     

    #4
    KeepTransisting likes this.
  5. K1587980645024
    Cupcake Apr 27, 2020

    K1587980645024 , Apr 27, 2020 :

    This is EXACTLY my problem too! I have had no answers yet! :-(
     

    #5
  6. K1587980645024
    Cupcake Apr 27, 2020

    K1587980645024 , Apr 27, 2020 :
    installed new system update 10.0.5 to my 7T PRO and rebooted everything.
    Still no 'media device' seen under my "This PC" ?
     

    #6
  7. Mikey_1273
    Gingerbread May 19, 2020

    Mikey_1273 , via OnePlus 7 Pro , May 19, 2020 :
    there should be a drive that shows up with the OnePlus logo in win10 file explorer. that will have the device storage drivers for the phone. install it then reboot. the phone should show up in the left pane of the file explorer window as media device. you should be able to get in and browse the files and transfer files to/from.

    you may also want to make sure file transfer is set in USB settings. go to settings. search USB. tap USB preferences.
     

    #7
  8. Akshay.chouhan
    Cupcake May 31, 2020

    Akshay.chouhan , May 31, 2020 :
    Just do one thing go to app& features .. Install "Media feature pack..." that's the only thing which will work... and surely it will work..
     

    #8
  9. B1541638393096
    Cupcake Aug 10, 2020

    B1541638393096 , Aug 10, 2020 :
    You're all wrong. Go to your settings and do a search for USB, select USB preferences, then you should see options for File Transfer, USB Tethering, MIDI, PTP and No data transfer. Select File Transfer then your Windows 10 machine will show an icon for the OnePlus that looks like a CD. Double click that to open and then you will have access to the files on your Oneplus 6t. No driver installation neccessary.
     

    #9
  10. phontao
    Donut Sep 12, 2020

    phontao , Sep 12, 2020 :
    This is weird but it worked.
    1. After plug in the USB cable from Oneplus 8 5G to windows 10 x64, do install USB driver
    2. On the phone choose the option 'PTP' first and then the 'File Transfer' cuz if I chose 'File Transfer' first then it will not work.
    If it work then you should see the phone's 'Internal Storage' box display on your pc screen.
    Note: While the phone plugging to PC, the phone mobile data WILL NOT BE AVAILABLE and IT STILL stay DISABLE for another few minutes AFTER cable been UNPLUGGED from the PC
     

    #10