0

USB not working anymore

  1. Raka936 Donut Jun 28, 2016

    Raka936, Jun 28, 2016 :
    Hi,

    I noticed yesterday that the USB on my OPO wasn't working anymore (charging works, but the phone isn't recognized on my PC, and doesn't recognize USB drive or any other storage)

    I have searched on hundreds of threads on hundreds of different forums, but nothing works for me

    Before you answer :

    Yes USB debugging is enabled
    Yes USB configuration is set to MTP
    No I don't have " three dots" in storage and USB to enable MTP or idk what
    No I don't have any notification when I plug my phone to enable MTP mode
    Yes OPO driver is installed
    Yes I tried to uninstall it
    Yes I rebooted my PC, my phone, tired on different PCs and different OSs.

    I think that's all.
     
    Last edited: Jun 28, 2016

    #1
  2. Tobikage Nougat Jun 28, 2016


    #2
  3. Raka936 Donut Jun 28, 2016


    #3
  4. Tobikage Nougat Jun 28, 2016

    Tobikage, Jun 28, 2016 :
    Hope you tried different cables and different computers too.

    Maybe the USB port has outlived it's useful life.
     

    #4
  5. Raka936 Donut Jun 28, 2016

    Raka936, Jun 28, 2016 :
    I tried OPO official cable and this cable, same result with both.

    I tried on a computer with Windows 10 and Linux Mint, and another with Windows 7, same result again.

    If the problem come from the USB port of my OPO, what can I do ?
     

    #5
  6. Tobikage Nougat Jun 28, 2016

    Tobikage, Jun 28, 2016 :
    A bit unlikely that the port will fail.

    If you can , and have backups already , factory reset to make sure it's not a software issue.

    If it doesn work even after a factory reset , then it's definitely a hardware issue.

    You can buy the USB ribbon port cable online from a 3rd party seller on eBay or Ali Express and get it changed locally from any mobile technician or DIY.

    Or get a quite from OnePlus service what it'd cost to get it changed.
     

    #6
    Raka936 likes this.
  7. Raka936 Donut Jun 28, 2016

    Raka936, Jun 28, 2016 :
    Okay thanks, I was thinking about doing a factory reset but first I need to find a way to transfer all my files to my computer (Airdroid, Dropbox, I know, but it will take much time).
     

    #7
    Tobikage likes this.
  8. Raka936 Donut Jun 28, 2016

    Raka936, Jun 28, 2016 :
    So I did a factory reset, I also installed last CyanogenOS because my OPO wasn't up to date, but that didn't change anything...

    I will contact OnePlus support now...
     

    #8
    Tobikage likes this.
  9. Tobikage Nougat Jun 28, 2016

    Tobikage, Jun 28, 2016 :
    Do update on what it costs after you get a quote from OnePlus.
     

    #9
  10. rajzen Cupcake Jul 1, 2016

    rajzen, Jul 1, 2016 :
    i have exactly same problem after latest update ....which i didnt wanted and instaled on my phone anyway when was in my pocket.
     

    #10
  11. rajzen Cupcake Jul 1, 2016

    rajzen, Jul 1, 2016 :
    ok so interesting things are happening with my phone.....the original cable which i wanted to throw out, dont recharge my phone from socket, but on the other side - this cable works with computer- i see data and everything.....second cable that i have, doesnt work with computer, but charge my phone from socket. Very weird.
     

    #11
  12. amarkenzon Froyo Jul 1, 2016

    amarkenzon, Jul 1, 2016 :
    After plugging in the USB into the computer, change the USB configuration (Halfway down the developer options in settings) from MTP to Charging and then back again. Should work after that, but you will need to do it every time.
     

    #12
    josefn24 likes this.
  13. brosoruler Cupcake Jul 1, 2016

    brosoruler, Jul 1, 2016 :
    (First of all I want to make my own thread but I can't because I need 5 replies :/)
    I have the same problem as you because I can't back up my files.
    One month ago my phone stopped working after a system update of cyanogen.
    The support service told me to backup my files and they would flash my phone.

    My problem:
    The pc cant read the files of my phone. (it says the file is empty)
    I tried different computers and system OS (windows xp, 8.1 and a Macintosh computer)
    I also tried different usb cables but nothing seems to work.
    I can't access my phone because the touchscreen doesn't respond so I can't enable USB debugging, or access bluetooth settings.
    And the files I'm trying to back up are unreachable for google so I can't get them from the dashboard.

    Unfortunatly the support service aren't answering my questions :/.

    I really hope someone on this forum can help me out or link me to a thread of someone with the same problem
     

    #13
  14. arjanvlek Honeycomb Jul 2, 2016

    arjanvlek, Jul 2, 2016 :
    Buy an OTG cable (search OTG cable on Google) and connect the mouse of your computer to your phone using that cable. That way you can turn on USB debugging to back up your files and reset your phone afterwards...
     

    #14
  15. dcam Cupcake Jul 2, 2016

    dcam, Jul 2, 2016 :
    If you are running the recent CM Android Marshmallow firmware releases then you need to know that USB to PC connectivity is completely broken in those and you can't copy music/photos to/from the phone over USB. However OTG cables do work. I had to flash my firmware back to the old Android version to get proper USB functionality back. My brother found exactly the same behaviour.
     

    #15
  16. Victor21v Cupcake Jul 2, 2016

    Victor21v, Jul 2, 2016 :
    Hello,

    my USB isn't working properly as well. When I connect my USB, some folders are shown and others not. In addition, my images aren't shown in DCMI folder, nor whatsapp Images, Videos, etc... Only new photos made since today can be shown in folders. Yesterday all images could be shown. What could be happening? :S
     

    #16
  17. brosoruler Cupcake Jul 5, 2016

    brosoruler, Jul 5, 2016 :
    I tried the OTG cable and I saw the cursor moving on the screen but unfortunatly nothing is working.
    I forgot to mention in my post but when I start the phone there is a notification that says: "System UI has stopped working" and "proces com.android.phone" has stopped :/

    Is there anything I can do?
     

    #17
  18. whatthelouis Froyo Jul 5, 2016

    whatthelouis, Jul 5, 2016 :
    you may have worn out the usb port with too many plug ins and unplugs. did you already try a new cable? the new stiffness of the usb connector may work.
     

    #18
  19. arjanvlek Honeycomb Jul 5, 2016

    arjanvlek, Jul 5, 2016 :
    That's a pretty nasty software error you got there. You can try to boot the phone without a SIM card and outside - or anywhere no known Wi-Fi network is available, to see if it stops crashing if no network connection and no cell signal is available, but I highly doubt it will work.

    A pretty safe way to try to get the phone to work is the following:
    - Go to https://cyngn.com/support
    - Scroll all the way down to OnePlus One
    - Download the topmost file for OnePlus One (that has fastboot in its file name).
    - After the zip file is downloaded, extract it by either using the extract function (win) or double clicking on it (mac)
    - Delete both the userdata.img and the userdata_64G .img files from the archive by pressing delete (win) or backspace (mac) on them.
    - Download "minimal adb and fastboot" for Windows from https://www.androidfilehost.com/?fid=24521665358595410 or for Mac from http://d-h.st/n5I
    - Install this by either clicking the downloaded file (windows) or extracting the archive and running the shell script (mac)
    - Open a command propmt (win) or a Terminal (mac)
    - Change directories to the extracted zip file folder
    - start the phone in fastboot mode by turning it off and holding [power] + [vol +] buttons pressed simultaneously
    - type the following in the command prompt / terminal: fastboot flash system system.img
    - Next, type: fastboot flash cache cache.img
    - The final one: fastboot flash recovery recovery.img
    - After this, restart your phone by typing fastboot reboot. The operating system should now be fixed and start up normally.
     

    #19
  20. PaulF8080 Gingerbread Jul 6, 2016

    PaulF8080, Jul 6, 2016 :
    I think turning on debug disables everything but the android debugger adb driver interface.
     

    #20