USB PC file transfer... Again!!

  1. AndyCoe1
    Donut Nov 27, 2017

    AndyCoe1 , Nov 27, 2017 :
    When I plug in the 5T to my windows 10 PC it shows up in windows explorer but no files are show. On my 5T is says 'USB Charging this device' when I select 'Use USB to: Transfer Files' nothing happens, the notification just changes back to charging.
    When I first plugged it in my pc wouldn't even recognize it (which I had with my 3T but selecting the correct MTP USB Drivers fixed that) I've tried USB debugging and updating the MTP drivers, nothing seems to work. Any ideas?

    pxndxdrian likes this.
  2. LLcdPH
    Eclair Nov 27, 2017

    pxndxdrian likes this.
  3. typo404
    Froyo Nov 27, 2017

    typo404 , Nov 27, 2017 :
    It should also display a "CD Drive: Oneplus Drivers" when you plug in your phone.
    In that you find OnePlus_USB_Drivers_Setup.exe
    I believe installing those should help you.

    Perhaps they had changed between 3 and 5T hence you need the ones from the 5T drive.

  4. AJ564
    Gingerbread Nov 27, 2017

    AJ564 , Nov 27, 2017 :
    Enable developer options (Settings>About Phone>Build Number and tap it 7 times)
    Now in Developer options enable USB debugging
    Connect your phone, pull down from the top and change from USB Charging this device to Transfer files and you should be good to go

    G_Polutropos_GVyu likes this.
  5. AndyCoe1
    Donut Nov 27, 2017

    AndyCoe1 , Nov 27, 2017 :
    Unfortunately I tried that and it didn't make any difference.

  6. AndyCoe1
    Donut Nov 27, 2017

    AndyCoe1 , Nov 27, 2017 :
    I've tried this as well and it didn't work either. It just goes straight back to USB charging.

  7. Roman_One
    Eclair Nov 27, 2017

  8. Roman_One
    Eclair Nov 27, 2017

    Roman_One , Nov 27, 2017 :
    I found a fix, that worked for me. First uninstall any drivers in Windows for this device in the Device Manager then:

    1. Go to developers options (unplugged)
    2. Change default USB configurations from charging to media transfer, you might need to click it a few times.
    3. Plug OP5t to computer, now it should instantly use media transfer mode and the drivers are properly installed.
    4. Evertything is working, when transferring files in the future the same steps must be followed.

    Chungtd and G_Polutropos_GVyu like this.
  9. pxndxdrian
    Cupcake Nov 28, 2017

    pxndxdrian , Nov 28, 2017 :
    I have the same problem. I done everything and nothing works. It doesn't even shows the CD to install drivers...

    the_reckoner likes this.
  10. dibon
    Froyo Nov 28, 2017

    dibon , Nov 28, 2017 :
    Anyone who still have issue on it, try deleting dalvik/cache memory from recovery mode.

  11. apka528
    Eclair Nov 28, 2017

  12. AndyCoe1
    Donut Nov 28, 2017

    AndyCoe1 , Nov 28, 2017 :
    Thank you, this kind of works. It is a workaround and there is still a serious issue that needs resolving but at least it's now possible to connect my phone.
    Step two takes two attempts before it will accept media transfer mode, and unfortunately when you disconnect the phone it goes back to not working and you have to follow these steps again.
    Is there any logical reason why a oneplus 3T would work fine but the 5T won't?

  13. Roman_One
    Eclair Nov 28, 2017

    Roman_One , Nov 28, 2017 :
    Glad, that it worked for you too. This is a serious issue, i hope they will fix it in the future

  14. No. 07428
    Jelly Bean Nov 28, 2017

    No. 07428 , Nov 28, 2017 :
    When your device is plugged in, look at your notifications and tap on the one that says something about charging or file transfer. Then choose the option you want from there.

    Wakatanka likes this.
  15. vducloux
    Donut Dec 6, 2017

    vducloux , Dec 6, 2017 :
    Hey guys,

    same issue here and I'm on Mac... Nothing of the solutions above are working !

  16. Fredman
    Gingerbread May 31, 2018

    Fredman , May 31, 2018 :
    USB debugging seems to be the way. Given that the problem can be sorted by simply changing a setting on the phone, it must be assumed that the problem lies with OnePlus/Oxygen OS/Android, rather than windows. I've seen the same problem on my wife's OP2, so clearly they got something wrong.

  17. vaugustov
    Cupcake Jul 31, 2018

    vaugustov , Jul 31, 2018 :
    hi guys, i cannot solve my problem, still cannot move files i get the same error "could not replace file"

  18. Chetan1836
    Froyo Jul 31, 2018

  19. vaugustov
    Cupcake Aug 8, 2018

    Attached Files:

  20. Barry_Mellors
    Cupcake Jan 6, 2019

    Barry_Mellors , Jan 6, 2019 :
    Hope you don't mind my butting in your message, but I've never been able to sync contacts from the phone to my Win 10 PC. I can sync contacts from the PC to the phone (or could) and back to PC, but not new contacts. At one point, Oneplus said "they aren't supposed to" ?
    2/ I don't see anything when I plug the phone via USB !
    I already have Developers section open. I tried the drag-down but don't see the USB Charging bit.