1. Ragul D
    Cupcake Sep 29, 2019

    Ragul D , Sep 29, 2019 :
    USB preference not showing while connecting to pc even though I tried developers option settings not worked just charging please help me need to transfer my files

  2. Lal1995Roshan
    Gingerbread Sep 29, 2019

    Lal1995Roshan , via OnePlus 5T , Sep 29, 2019 :
    I think your connection is having some problem. Try reconnecting the cable. If it is the same after multiple attempts go to settings search usb preferences and check whether you'll be able to choose any of them. If all of them are disabled try reinstalling Oneplus drivers on your pc.

  3. stark2991_PL
    KitKat Sep 29, 2019

    stark2991_PL , Sep 29, 2019 :
    Clean the USB port of your phone. This happens because there is no good connection between the phone and the cable.

  4. fabinho50270
    Cupcake Nov 14, 2019

    fabinho50270 , Nov 14, 2019 :
    Hi everyone,

    I have the same problem on my one plus 3. Seems like I am not the only one in this situation. Cable is clean (I red some suggestions about checking it but it is clean) and I have tried several ones, most of them are new so I don't think this is a cable issue. When I plug it to my computer it doesn't ask me to connect to the computer like it used to do before. Computer doesn't detect it either even when I am going to configuration. It charges but this is the only thing it does.

    Version is OxygenOS 9.0.5

    I really need to download files to my computer so I can free space without sending everything to Google drive and download again from the computer an so on, this is a big waste of time.

    Even in the settings I cannot change any USB preferences. Nothing works.

    I tried to reboot too, nothing is happening.

    Help please

    Thank you very much for your help

    saipavankanta likes this.
  5. stark2991_PL
    KitKat Nov 14, 2019

    stark2991_PL , Nov 14, 2019 :
    Dude, you can clearly see that your phone does not charge on the screenshot so either you have not plugged it in to the cable or the connection between the cable and USB port is unstable due to the dirty/damaged port.

  6. fabinho50270
    Cupcake Nov 14, 2019

    fabinho50270 , Nov 14, 2019 :
    My bad, it's just that I did the screenshot when it wasn't plugged. But it is exactly how the USB preference menu is when plugged to the computer, I just wanted to show how the USB preference appears. When plugged I can't change it and even when connected to the computer with many different cables. Tried different computers and cables

  7. stark2991_PL
    KitKat Nov 14, 2019

    stark2991_PL , Nov 14, 2019 :
    It can still be dirty/damaged USB port.
    I had the same issue.

  8. fabinho50270
    Cupcake Nov 14, 2019

    fabinho50270 , Nov 14, 2019 :
    Then it could from the USB port of the phone and not the cable as I tried several new cables, but it seems clean...
    Got a good technique to clean it?

  9. stark2991_PL
    KitKat Nov 15, 2019

    stark2991_PL , Nov 15, 2019 :
    Take a toothpick, make it thinner and try to gently scrap the dirt inside the port. That's all I can tell you.

  10. jboysdk
    Cupcake Jan 18, 2020

    jboysdk , Jan 18, 2020 :
    I had this issue with a 7 Pro and a 5T. Turns out the USB cable went to a USB hub. Once I plugged the USB cable directly into the PC USB port everything works. So definitely a connection issue

  11. vardhaman_03
    Cupcake Jan 28, 2020

    vardhaman_03 , via OnePlus 6 , Jan 28, 2020 :
    after upgrade to 10.3.0 even my one plus 6 gives me this issue.
    for me the led display .. sometimes the charging icon .. but usb preference is not visible in any case

  12. ron_huang
    Cupcake Mar 21, 2020

  13. Waveform Modifier
    Marshmallow Mar 21, 2020

    Waveform Modifier , Mar 21, 2020 :
    Good thing this isn't the OnePlus 6/6T forum.

  14. saipavankanta , via OnePlus 6T Mirror Black , Aug 3, 2020 :
    I have the same problem .. any one help me ..

  15. D1599469743864
    Cupcake Sep 7, 2020

    D1599469743864 , Sep 7, 2020 :
    I have the same problem with my oneplus 3. I'm using the original dash charging cable. All the drivers are installed on the pc since i've conntected it before (to transfer data) a few months ago.
    Now when i'm connecting my phone to pc, the phone goes to normal charging (slow) and no usb preferences. I am not able to find a sloution. Please help!

  16. E1606700945804
    Cupcake Nov 30, 2020

    E1606700945804 , Nov 30, 2020 :
    Everyone seems a little snippy here :)
    I thought I would let you know that none of the above solutions fixed my problem and the reason was fairly simple but may not be helpful for some of you.

    The computer I was using had 2 groups of USB ports connected via a USB hub internal to the computer The USB ports on the front reported as USB 1.1 the USB on the back was USB 2 but unfortunately when anything else was plugged in (IE my keyboard) My 7t did not show charge by usb.

    I plugged into my laptops usb with the same cable and not other changes or cleaning or anything and poof it worked So ultimately check all the variables, one of which could be the PC you are using.

    Oh One final thing I also learned. Some USB C type cables can be built cheaply and although they can plug in either way, sometimes they only have data on one side, so try reversing the phone side of the cable.
    Last edited: Nov 30, 2020

  17. Ekknathjujare
    Cupcake Dec 7, 2020

    Ekknathjujare , Dec 7, 2020 :
    First make sure your OnePlus phone has the latest OS.
    Then follow below steps

    Step 1:power off the device and press the volume down and power buttons simultaneously for 15-20 seconds
    Step 2:Select the Language as "English"
    Step 3:The recovery screen will appear on the display
    Step 4:Select "Wipe data & cache"
    Step 5:You will have three options stating “Reset system settings”, “Erase everything” and “Wipe cache”
    Step 6:Select "Wipe cache”
    Step 7:Select “Yes”
    Step 8:Select "Reboot"

    It has resolved the issue for my OnePlus 7T device.

  18. J1581155974910
    Cupcake Dec 7, 2020

    J1581155974910 , Dec 7, 2020 :

    This is also not working

  19. J1581155974910
    Cupcake Dec 7, 2020

    J1581155974910 , Dec 7, 2020 :
    Does that problem solved ?

  20. N1607401101522
    Cupcake Dec 8, 2020

    N1607401101522 , Dec 8, 2020 :
    Hey guys, I've been dealing with this issue and managed to solve it - The issue is 100% the connection via USB

    - Confirm the USB cable is OK -> Swap with another one and see if it makes a difference
    - Confirm the USB port is OK -> Try changing the port you are using in your computer. (This fixed it for me)

    Hope it helps