5
USB tethering and Hotspot not working.

  1. dishant22
    Cupcake Oct 2, 2018

    dishant22 , Oct 2, 2018 :
    My hotspot and USB tethering are not working properly after updating the OS to android 9.
    Though each mode connection is successful phone is not sharing data to the connected devices and hence the device/laptop shows "no Internet available".
     

    #1
  2. ciano1993
    Cupcake Oct 2, 2018


    #2
    dishant22 likes this.
  3. Sadhbh Kenny
    Cupcake Oct 2, 2018


    #3
  4. F_Kev_Davey_prFb
    Cupcake Oct 3, 2018


    #4
  5. montecarlo385
    Cupcake Oct 3, 2018

    montecarlo385 , Oct 3, 2018 :
    I too had an issue with hotspot but fixed it by changing the hotspot name to something other than OnePlus 6 and password of my own pick. Maybe give that a try. As for usb tethering, i have no issue with it, works just fine.
     

    #5
  6. F_Kev_Davey_prFb
    Cupcake Oct 3, 2018

    F_Kev_Davey_prFb , Oct 3, 2018 :
    I've just given this a try with no luck.
     

    #6
  7. hagegebenjamin
    Froyo Oct 11, 2018

    hagegebenjamin , Oct 11, 2018 :
    Same issue for me after update to Android 9.0. For me, it works only if I put the tethering in 2.4 ghz, not 5 ghz. Same for you guys?
     

    #7
  8. S1539532743130
    Cupcake Oct 14, 2018

    S1539532743130 , Oct 14, 2018 :
    I am also having this issue, however I have NEVER been able to get my hotspot to work through wifi, bluetooth or connecting with a USB cable! Have tried all the suggestions through endless blogs and other forums to no avail. Have tested my other devices and even contacted windows support and have narrowed down the issue to the Oneplus 6 handset. Can someone please fix this bug urgently :(
     

    #8
    L1593618356252 likes this.
  9. Dexter T
    Cupcake Oct 15, 2018

    Dexter T , Oct 15, 2018 :
    I've had Android Pie for weeks now and hotspot was working fine. However, it stopped working today as well.

    I can connect my other device to the hotspot but there will be no internet. Any suggestions?
     

    #9
  10. F_Kev_Davey_prFb
    Cupcake Oct 21, 2018


    #10
  11. deangilvin
    Jelly Bean Oct 22, 2018

    deangilvin , Oct 22, 2018 :
    Nope, because you're on the user side complaining. There's no OP devs on this side.
     

    #11
  12. jmich
    Cupcake Oct 27, 2018

    jmich , Oct 27, 2018 :
    Hi guys,
    I've experienced the same behaviour since one week, actually since my last android security update.
    I'm not on a OnePlus anymore (too expensive to change the broken screen, I switched to a xiaomi mi a1, cheaper than changing the screen).

    Anyway, I found a solution on some old OnePlus threads regarding tethering. It worked for me. I'm on vacation but it would have been a problem for me, as I'm working through my 4G connection.

    Change this setting with adb shell : https://forums.oneplus.com/threads/no-internet-access-over-tethering-wifi.530209/#post-16129196
    And don't forget to reboot your phone. I switched from the null value to 0 and it didn't work. I restarted the phone et voilà.

    Tell me if it worked on OP.
    regards
     

    #12
  13. hagegebenjamin
    Froyo Nov 28, 2018

    hagegebenjamin , Nov 28, 2018 :
    Hello,

    I'm still have issue for me after update to Android 9.0. For me, it works only if I put the tethering in 2.4 ghz, not 5 ghz. Could anyone help please?

    Thanks,
     

    #13
  14. E1545150765253
    Cupcake Jan 7, 2019

    E1545150765253 , Jan 7, 2019 :
    I'm having the same issue with my OnePlus 6T, latest update (Dec 2018). I have to set up my hotspot for 2.4GHz only as the 5GHz will work for 5-10 minutes and then disappear.
     

    #14
  15. kshetty0212
    Cupcake Jan 7, 2019


    #15
  16. kshetty0212
    Cupcake Jan 7, 2019


    #16
  17. Artemus.
    Community Hero 2020 Jan 7, 2019

    Artemus. , Jan 7, 2019 :
    Wrong forum.
     

    #17
    ishaanjain likes this.
  18. ishaanjain
    Donut Jan 30, 2019


    #18
  19. G_funkierfawn_budgie_
    Cupcake Feb 14, 2019

    G_funkierfawn_budgie_ , Feb 14, 2019 :
    I too have this issue but I fixed USB tethering by doing this

    wifi > hotspot+teht.. > wifi hotspot > toggle turn off hotspot automatically to off
    also try changing you AP band or security if it still not work

    i know this sounds weird but i couldn't connect my PC to wifi via phone usb and spent 20 mins trying to figure out how to fix.
    i somehow randomly tried this and now i have working USB tethering.
     

    #19
  20. pcoventry
    Honeycomb Feb 25, 2019

    pcoventry , Feb 25, 2019 :
    I fixed it by following someone else's thread here - Go to your 4G APN and change it to ,DUN at the end. So I'm in the UK and my APN is three.co.uk - so I changed it to three.co.uk,DUN and saved it - didn't even need to reboot BOOM hotspot on 5Ghz no problem.

    So simple but it works!
     

    #20