0
Network/Connectivity USB Tethering not working (OOS 9.0.1)

  1. hemantcompiler Cupcake Jan 10, 2019

    hemantcompiler, Jan 10, 2019 :
    I had it working just now, but after I removed the phone, the phone had a soft reboot and since after then, whenever I try to connect it, it can connect in every other mode but usb tethering.

    When I try to toggle usb tethering it just doesn't work. It won't turn on. When I see the notification it says that usb tethering is on but it's not as seen on my laptop.

    Then when I remove the mobile, the notification ( that usb tethering is on ) just stays there untill I reboot the phone.

    Can somebody please tell me how can try to fix it?

    Have tried rebooting but with no help.
     

    #1
  2. simmondp Froyo Jan 10, 2019

    simmondp, Jan 10, 2019 :
    Just tried it on my Chromebook for you, OP5 Beta 24 (9.0.?) Patch at 1st Dec 18

    works just fine, as it always did, remember it will only enable while it is plugged in using a USB cable.

    Turn it on via [Settings] / [Wi-Fi and Internet] / [HotSpot & Tethering] not the USB connection option message that comes up when you plug in a USB lead.
     

    #2
  3. hemantcompiler Cupcake Jan 15, 2019

    hemantcompiler, Jan 15, 2019 :
    Okay, so here is the problem, when USB is not plugged in, the option is greyed out (in Settings -> Wi-Fi and Internet -> HotSpot & Tethering ). So anyway I cannot turn on USB tethering when the USB is not plugged in, but once I connect the USB cable the option becomes active, but despite that when I click it, it won't turn on. It always stays in the off position.

    Now once I try to turn on USB tethering, the notification changes to - "USB tethering turned on" but it's not "on" from the settings or in the PC. Now at this point, you cannot change the notification, it's stuck. If you remove the USB, the notification stays, and the USB tethering option in settings is active as well, that is, it is NOT "greyed out" even after removing the USB.

    At this point to reset the things, I either have to restart the phone or force close the "Android system" app.

    But sometimes ("Very rare"), It just works. Can you tell me how to debug it?
     
    Last edited: Jan 15, 2019

    #3
  4. simmondp Froyo Jan 15, 2019

    simmondp, Jan 15, 2019 :
    So just tried this on a PC (Windows 10 fully up to date 1809) and I'm afraid to say - it works just as expected.

    Have you tried;

    a. a different USB cable?
    b. Clearing the cache?

    Else, since I work perfectly as expected, I'm unable to help!
     

    #4
  5. hemantcompiler Cupcake Jan 15, 2019

    hemantcompiler, Jan 15, 2019 :
    What all data will be lost by clearing cache? Can you tell me the steps? Any link is also fine. Thank you
     

    #5
  6. simmondp Froyo Jan 17, 2019

    simmondp, Jan 17, 2019 :
    Use with extreme care, but my first port of call when anything is a bit odd

    1. Turn off the device.
    2. Press and hold the Volume down and Power button at the same time.
    3. When the OnePlus logo appears, release the Power button, but continue holding the Volume down button.
    4. At the Password screen, enter the Password or PIN number that I use to unlock my device. When done, tap Ok.
    5. Follow screen prompts to Clear Cache
     

    #6
  7. Q1552652175882 Cupcake Mar 15, 2019 at 12:19 PM


    #7