4
Vibration is not working

  1. F_Trilok_Reddy_jtbt
    Cupcake Nov 18, 2018

    F_Trilok_Reddy_jtbt , Nov 18, 2018 :
    Hi everyone,

    In my OnePlus vibration is not working. I troubleshooted by restarting and changing multiple options (High, low, med intensity) in settings. But, still vibration is not working. To ensure hardware I restarted phone. When phone is booting at that time it's vibrating, that means hardware is okay. Then why vibration is not working for calls or any other feature when phone is operating in normal mode of operation. Whether this is OS problem or else hardware issue. I don't think this is hardware problem. Hoping for quick response.

    Thanks
    Trilok
     

    #1
  2. RapchandoseBuoy
    Ice Cream Sandwich Nov 18, 2018


    #2
  3. F_Trilok_Reddy_jtbt
    Cupcake Nov 18, 2018


    #3
  4. NovumBattle
    Cupcake Nov 18, 2018

    NovumBattle , Nov 18, 2018 :
    I have the same issue.
    I also did the vibration test on *#808# and it's vibrating but not on calls and notifications. yes I am in vibration mode.
    Even if I click on a different vibration pattern it's not vibrating.
    And it did vibrate before the recent update. So it's has to be a software issue.
    I am on oxygen is 9.0.5

    OnePlus please fix this issue asap. :)
     

    #4
  5. F_Trilok_Reddy_jtbt
    Cupcake Nov 18, 2018


    #5
  6. Ashwinkumar989
    Honeycomb Nov 18, 2018

    Ashwinkumar989 , Nov 18, 2018 :
    Check your do not disturb mode setting and also make sure you enabled vibration for incoming calls on vibration settings
    If the problem persist report this issue immediately on oneplus bug reports forum
     

    #6
  7. shubhamsubhash
    Froyo Nov 18, 2018


    #7
  8. F_Trilok_Reddy_jtbt
    Cupcake Nov 19, 2018


    #8
  9. NovumBattle
    Cupcake Nov 19, 2018

    NovumBattle , Nov 19, 2018 :
    thanks that solves my issue. but was at activated on your phone in the first place? I don't get why this is off by default (at least on my phone)
     

    #9
    lungdocindia likes this.
  10. shubhamsubhash
    Froyo Nov 19, 2018

    shubhamsubhash , Nov 19, 2018 :
    @NovumBattle it's off by default in mine also.
     

    #10
  11. NovumBattle
    Cupcake Nov 19, 2018


    #11
  12. shubhamsubhash
    Froyo Nov 19, 2018

    shubhamsubhash , Nov 19, 2018 :
    no it's not a fault bcoz I hv replaced 6t earlier due to the same issue.but when I chkd it was by default in both.so it's same for all the handsets of 6t.
     

    #12
  13. NovumBattle
    Cupcake Nov 19, 2018

    NovumBattle , Nov 19, 2018 :


    shubhamsubhash

    no it's not a fault bcoz I hv replaced 6t earlier due to the same issue.but when I chkd it was by default in both.so it's same for all the handsets of 6t.​


    I mean this is a software issue.
    Go to Sounds>Vibration Pattern

    1542605278509.jpg
    (sorry it is in German)
    If I click on a different pattern option it does not vibrate the new selected pattern and it did before the recent update. Your work around does not solve this issue.
    And normally it should vibrate in vibration mode without you having to change a default option in accessibility.
     

    #13
  14. shubhamsubhash
    Froyo Nov 19, 2018

    shubhamsubhash , Nov 19, 2018 :
    yes agreed.it should be in vibration by default without doing any changes.but I hv chkd vibration pattern is working fine for me i.e. playing same pattern as selected.i would suggest if u r facing issue then replace it.
     

    #14
  15. NovumBattle
    Cupcake Nov 20, 2018

    NovumBattle , Nov 20, 2018 :
    A factory reset of the phone resolved the issue for me.
     

    #15
  16. F_Elton_A._Rezende_CHGs
    Cupcake May 1, 2019

    F_Elton_A._Rezende_CHGs , May 1, 2019 :
    Hi guys! I was having the same problem and just solved it.

    The problem was that I was using the battery saver on, that is why it was not vibrating... Just turned it off and the problem was gone!
     

    #16
    hmalsheikh, jonaswarnke and orkopolo like this.
  17. Kytharsis
    Marshmallow May 1, 2019

    Kytharsis , May 1, 2019 :
    Glad you were able to solve your issue... but was resurrecting this thread necessary?
     

    #17
  18. F_Elton_A._Rezende_CHGs
    Cupcake May 3, 2019

    F_Elton_A._Rezende_CHGs , May 3, 2019 :
    I did it because I searched in Google and I found this treat on the top,so I thought that my experience could help others that are having the same issue.
     

    #18
    jonaswarnke likes this.
  19. J1560673821101
    Cupcake Jun 16, 2019

    J1560673821101 , Jun 16, 2019 :
    This helped me, thank you!
     

    #19
  20. orkopolo
    Cupcake Jun 21, 2019

    orkopolo , Jun 21, 2019 :
    I was ready to ship back my OnePlus 7 Pro because I thought the vibration was broken. As others have stated it wouldn't vibrate even when choosing the vibration pattern in the screenshot above. THANK YOU for pointing me to the battery saver setting. This really should be an ON/OFF option to enable or disable vibration in battery saver mode.... at least I would have seen that the vibration was purposely turned off.

    Thanks again for reviving this thread. It was the first one to pop up in Google when desperately searching for hope on this issue.
     

    #20
    imago imaginis likes this.