4
Network/Connectivity Vodafone APN Problems | 4G dropping to EDGE

  1. Albatrosify
    Donut Jun 12, 2017

    Albatrosify , Jun 12, 2017 :
    Hello,

    I changed my mobile contract to Vodafone.
    Anyhow since then I have prolems with connectivity (eventhough Vodafone has excellent network here).

    By default the mobile will connect to 4G initially, after 10-15 seconds it will fallback to EDGE..
    Each week I get a message from Vodafone telling me "To use dataservices, correct APN settings are necessary". These settings however are correct.

    I read in other german boards, that people with oneplus devices all experience this problems.

    I did some test, and used the hidden settings menu (accessible via caller apk)..
    Set Network to LTE/WCDMA and immediately the phone connects to 4G and stays connected.

    Anyhow I sometimes pass rural areas where for a moment is only EDGE available. And with this setting i loose connectivity in rural areas at all. So it is no option.

    The iPad next to me is always connected to either 3G or 4G (also Vodafone contract).
    What is really weird to me is, that after initially connecting to 4G the mobile IMMEDIATELY reverts to EDGE, instead of trying 3G connection which is stable here, and of course way faster than EDGE.

    I contacted the support, but they said there is no solution yet, and I should post here, so technicians read it.

    Any one else has ideas?
     

    #1
  2. Bartnl
    Lollipop Jun 12, 2017

    Bartnl , Jun 12, 2017 :
    Weird that he helpdesk is guiding you to the user forum as there are no OP technicians here.
    What I think the best thing you can do is to open a support ticket, which goes directly to the technicians of OP and let them figure it out for you.
    https://oneplus.net/support/ticket/submit
     

    #2
  3. mkplus3t
    Cupcake Jun 14, 2017

    mkplus3t , Jun 14, 2017 :
    I have this problem since ota update 4.1.6 too
    I did not had this probleme with version 4.1.5
     

    #3
  4. Markri
    Cupcake Jun 23, 2017

    Markri , Jun 23, 2017 :
    Hey,

    i also have this issue, my provider is 1&1 in germany but it uses the vodafone network.
    After wifi i only have edge but when i put flight mode in and back out again, it connects too HSPA+

    What could be the problem? my settings are correct, i feel like its since the last update like this
     

    #4
  5. roberthine
    Donut Jun 23, 2017

    roberthine , Jun 23, 2017 :
    I have always had this problem with every version of the software, it also doesn't matter which network provider I use, when I search for networks it will see the 4g networks but will not stay connected to any of them. Either the antenna is faulty of the software is to aggressive in switching data networks. I keep hoping they will fix it with every update but it never happens.
     

    #5
    Albatrosify likes this.
  6. X70
    Eclair Jun 23, 2017

    X70 , Jun 23, 2017 :
    I have the same problem but in reverse xD

    I'm also an Vodafone DE customer. When I start my phone it connects EDGE. Even if there is good 4G. It takes up to 15 min until my OP change to the 4G network. :/
     

    #6
  7. Nikfam
    Gingerbread Jun 23, 2017

    Nikfam , Jun 23, 2017 :
    The same issue for me more or less. I also have 1&1 in Germany but my dataplan is confined to H+ speeds. When I use the setting 2G/3G/4G it locks to edge if the signal is momentarily weak and never returns to H+. If I set it to 2G/3G only then I have no issue but my second sim which has 4G is wasted for no reason.. A lot of hardware in one plus appear to be cheap and at the end I wonder if it justifies the 430euro price
     

    #7
  8. G_Vincenzo_Maria_Iorio_X
    Cupcake Jun 24, 2017


    #8
  9. mkplus3t
    Cupcake Aug 23, 2017

    mkplus3t , Aug 23, 2017 :
    I reinstalled 4.1.3 instead of 4.1.6.
    Everthing with Vodafone, Telia, Nortel, G. Telekom together with 4g/4g+/wcdma versus edge is running well again. It is not dropping to Edge anymore when a better connection is available.
     

    #9
  10. Hiral_Thaker
    Cupcake Aug 23, 2017

    Hiral_Thaker , Aug 23, 2017 :
    hi,

    facing the same issues with internet accessibiltiy visited store rectified apns still the problem persist not able to use 4g neither 3g

    please let me know too if anyone come across the solution
     

    #10
  11. mkplus3t
    Cupcake Jul 30, 2020

    mkplus3t , Jul 30, 2020 :
    give the hints on the internet to change the Qualcomm Profiles (qpst Qualcomm, Oneplus volte) a Chance.
    Check with the qpst/pdc.exe if your Oneplus is using a " usefull" profile. my wss sutomatically instalkef by Oneplus for a asia Network. because of bands, Features etc not a good choice for america , europe or africa.
     

    #11