VoLTE and VoWi-Fi carrier whitelisting (or check bypassing)

  1. Shady_Guy_Jose
    Eclair Apr 12, 2021

    Shady_Guy_Jose , Apr 12, 2021 :
    Hi! We have two OnePlus phones here at home (I'm using a brand-new OnePlus 9 Pro, while my dad has been using a OnePlus 8 Pro for the past year), and our carrier (NOS, Portugal) has recently activated VoLTE and VoWi-Fi. However, they whitelist phones on a per-model basis, and while they do allow unlocked phones to use these, they only certify models they sell themselves. Is it possible in any way for us to bypass carrier checks and use these services, or are we entirely dependent on OnePlus and the carrier whitelisting the phones? If so, who do I need to pressure? OnePlus, the carrier, or both?


  2. hbk1402
    Jelly Bean Apr 13, 2021

    Best Answer
    hbk1402 , Apr 13, 2021 :
    There are two options,
    1. Submit the feedback in the below and wait for OP to come up with a fix,
    2. The below thread has the complete steps though it is for OP 8 series, steps.remain the same. But it requires apks to be installed. Read it and if you are not sure check out in youtube and there are videos demonstrating the same. Only if you are clear with the steps, you can try.

  3. hbk1402
    Jelly Bean Apr 12, 2021

    hbk1402 , Apr 12, 2021 :
    You need to check with your carrier, I suppose. As these features are supported by OP.

  4. Shady_Guy_Jose
    Eclair Apr 12, 2021

    Shady_Guy_Jose , Apr 12, 2021 :
    I did. They said OnePlus devices weren't certified. And they will likely never be, because the carrier doesn't sell them. So aren't most Xiaomi phones, yet they can disable carrier checks and force VoLTE and VoWi-Fi through dialer codes. I'd like to know if there's anything similar we can do on our end, or if OnePlus themselves can push the carrier to certify their phones.

  5. hbk1402
    Jelly Bean Apr 13, 2021

    hbk1402 , Apr 13, 2021 :
    Can you try the below steps?

    Open phone dialer, type *#800# select OnePlus and logout; then select function switch and select VOLTE and VOWIFI. Reboot the phone. Once the phone has fully rebooted with the options enabled, go to phone settings and select SIM & Network and you'll see the options to enable VOlTe and VOWIFI.

  6. Shady_Guy_Jose
    Eclair Apr 13, 2021

  7. Shady_Guy_Jose
    Eclair Apr 13, 2021

    Shady_Guy_Jose , Apr 13, 2021 :
    Thank you very much! I had to fiddle around with some of those configs, but I managed to get it working using the Vodafone Germany profile (most EU networks are the same, so I gave that one a try and it worked). However, that post said 5G might be broken by those, so I guess I'll have to wait until it rolls out in my country to see if it works or not (and, if it doesn't, I hope the post it cites as a solution still works by then). For now, I have both VoLTE and VoWi-Fi working, so I guess it's a win. Thanks again! Nevertheless, I'll submit feedback so that less technically minded users (like my dad) can get these working seamlessly.
    Last edited: Apr 13, 2021

  8. hbk1402
    Jelly Bean Apr 13, 2021

    hbk1402 , Apr 13, 2021 :
    You are welcome... If you feel it answered your question and resolve your issue, please mark this thread as solved/ answered. Donot close it.

    So it will help other ppl who are facing similar issue by easily looking at this answered thread... 🙂