2

VoLTE being forced even when it should switch to WiFi calling.

  1. bpwest80 KitKat Jun 12, 2019

    bpwest80, Jun 12, 2019 :
    My phone is forcing VoLTE even though I have "WiFi Calling" set as preferred. If I switch from LTE to WiFi the only way to get Wi-Fi Calling to work is work a reboot. After the reboot, VoWiFi shows in the status bar. It's been this way since I got it. Every now and then it'll switch on it's own but that rarely ever happens. It usually takes a reboot.
     

    #1
    D1562913303891 and Matej Huba like this.
  2. bpwest80 KitKat Jun 12, 2019


    #2
  3. Bodin Praphanthongchai Cupcake Jun 12, 2019

  4. bpwest80 KitKat Jun 12, 2019


    #4
  5. bpwest80 KitKat Jun 14, 2019

    bpwest80, Jun 14, 2019 :
    That suggestion no longer works. I turned off "Intelligently select WiFi" but I'm still stuck on VoLTE unless I reboot the phone.
     

    #5
  6. bpwest80 KitKat Jul 9, 2019


    #6
  7. barnabyj Honeycomb Jul 9, 2019

    barnabyj, Jul 9, 2019 :
    OP is looking into it still. I submitted a bug report, gave them a bunch of log data. I suggest everyone do the same.
     

    #7
    xavierf62 and bpwest80 like this.
  8. bpwest80 KitKat Jul 9, 2019

    bpwest80, Jul 9, 2019 :
    Thanks
     

    #8
  9. DeathMoJo Gingerbread Jul 10, 2019


    #9
  10. bpwest80 KitKat Jul 10, 2019

    bpwest80, Jul 10, 2019 :
    They need to make the bug report process a little easier and less time consuming.
     

    #10
    DeathMoJo likes this.
  11. barnabyj Honeycomb Jul 10, 2019

    barnabyj, Jul 10, 2019 :
    I was contacted by OP directly after submitting the bug report. he had me enable logging manually to collect the data. so, expect some extra work on this one.. [e]1f609[/e]
     

    #11
    bpwest80 likes this.
  12. ZRXINLA Donut Jul 16, 2019

    ZRXINLA, Jul 16, 2019 :
    still connects then disconnects. connects then disconnects, connects then disconnects..........co.....the....dis.........getting dizzy.
     

    #12
  13. bpwest80 KitKat Jul 16, 2019

    bpwest80, Jul 16, 2019 :
    I know it. WiFi calling hardly works.
     

    #13
  14. DeathMoJo Gingerbread Jul 16, 2019

    DeathMoJo, Jul 16, 2019 :
    It is what it is. I just don't know what triggers why it doesn't switch back to voice over wifi. The other side is the time to log the information.
     

    #14
  15. Mikejenkins Cupcake Jul 16, 2019

    Mikejenkins, Jul 16, 2019 :
    I see this regular. I don't think it's a phone issue. as it happened on my Huawei p20 pro, Samsung S10+ and now the same with my OnePlus 7 pro. I think it's more carrier relates prioritizing 4g/LTE calls. I work for EE an it is being investigated
     

    #15
  16. DeathMoJo Gingerbread Jul 16, 2019

    DeathMoJo, Jul 16, 2019 :


    Mikejenkins

    I see this regular. I don't think it's a phone issue. as it happened on my Huawei p20 pro, Samsung S10+ and now the same with my OnePlus 7 pro. I think it's more carrier relates prioritizing 4g/LTE calls. I work for EE an it is being investigated​


    That would not explain why it can't hold vowifi when not making a call. If I restart the phone, vowifi comes back up. Eventually it will just be connected to volte. If I cycle wifi connection and toggle airplane mode, no change in status. I make a call in the house and it's over volte not vowifi, unless the phone is restarted.

    My last two phones held vowifi solid in the same house. I can understand if I'm moving around or using different wifi but the only change in this equation is the phone.
     

    #16
  17. barnabyj Honeycomb Jul 16, 2019


    #17
  18. Mikejenkins Cupcake Jul 16, 2019

    Mikejenkins, Jul 16, 2019 :
    the phone will try and use 4g calling over wi-fi calling. try knocking the network mode to 2g/3g and WiFi calling will stay on
     

    #18
  19. barnabyj Honeycomb Jul 16, 2019

    barnabyj, Jul 16, 2019 :
    there is a setting to prefer WiFi calling, and it's enabled. everything works fine for days, then it stops. there is no reason to turn off 4g to try and fix this. this is a bug, and it's actively being investigated by one plus. I've been giving logs to the bug hunter team for this, as have many others who have submitted a bug report.
     

    #19
  20. Sir_Pool_de_Float_MD Eclair Jul 16, 2019

    Sir_Pool_de_Float_MD, Jul 16, 2019 :
    WiFi Calling works perfectly on T-Mobile US firmware, and I too had issues when I converted to international firmware. Went back to TMO, and perfect once again. Currently on 9.5.8, but worked on prior versions as well.
     

    #20